Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Private Browsing mode doesn't work

  • 2 uphendule
  • 12 zinale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu pizazz

more options

I've been without a pc for awhile, now have new one with Windows 10. Just downloaded latest Firefox. I set it to Always Open in Private Browsing mode. But it doesn't work. When I close browser and then re-open, my Start page doesn't show the mask or indicate private browsing. I can get it by the usual way, right-click on icon that offers options to open new window or a private one. I've tried turning on/off private browsing mode a few times, still no luck.

I've been without a pc for awhile, now have new one with Windows 10. Just downloaded latest Firefox. I set it to Always Open in Private Browsing mode. But it doesn't work. When I close browser and then re-open, my Start page doesn't show the mask or indicate private browsing. I can get it by the usual way, right-click on icon that offers options to open new window or a private one. I've tried turning on/off private browsing mode a few times, still no luck.

Isisombululo esikhethiwe

You probably won't see the purple Private Browsing mode mask when you are in permanent PB mode because all windows are automatically in PB mode. You only see the mask when Firefox is started in normal mode and you open a New Private Window.

You can use an extension to get Private Browsing mode support per tab.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 3

All Replies (2)

more options

Isisombululo Esikhethiwe

You probably won't see the purple Private Browsing mode mask when you are in permanent PB mode because all windows are automatically in PB mode. You only see the mask when Firefox is started in normal mode and you open a New Private Window.

You can use an extension to get Private Browsing mode support per tab.

more options

cor-el, thank you for your reply. You saved me from unnecessary frustration. I think Firefox should include that info on website where they explain how Private Browsing works. Very helpful.