Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

New version lost all my saved passwords and won't save any - tried help

  • 6 uphendule
  • 3 zinale nkinga
  • 445 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Earlier versions of FF saved passwords just fine, but for the past couple of updates that feature has stopped working. I have tried the steps shown in the "passwords not saved" FAQ, even changed my history settings from Custom to always save. No matter. Does not do passwords or even ask me. All of the passwords that had been in my profile for the past couple of years are no longer visible in the "show saved" option window. Do I have to uninstall Firefox, and start over?????

Jay

Isisombululo esikhethiwe

The "Remember Password" extension has been reported to cause issues with the passwords disappearing, so if you have this extension then remove (uninstall) it.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

It is possible that there is a problem with key3.db (encryption key) and logins.json (encrypted names and passwords) in Firefox. You can open the logins.json file in the Scratchpad (Firefox/Tools > Web Developer) to check its content. Click the "Pretty Print" button to format the file for readability. If there are names and encrypted passwords in logins.json then there is likely a problem with the key3.db file that stores the encryption key. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) or move these files to another folder to make it possible to undo the action.

Rename or remove a possible signons.sqlite file (signons.sqlite.old) used by older Firefox versions as well. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.

You can use this button to go to the current Firefox profile folder:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Security Issue: Update your Flash Player Version 18.0.0.232
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

more options

Thanks, FredMcD. Think you are on the right track but I'm not there yet. I updated my Adobe Flash player to 10.0.0.232; but that did not solve the problem. I notice that Flashplayer shows up on my Windows Programs list in Control Panel, but does not show up as an addon in Fire fox. What I see in firefox is Shockwave Flash. If I start firefox in Safe mode then the saved passwords option works and I can see my list of saved passwords. But only in safe mode.

Jay

more options

Mistyped. Adobe flash is 18.0.0.232

more options

Isisombululo Esikhethiwe

The "Remember Password" extension has been reported to cause issues with the passwords disappearing, so if you have this extension then remove (uninstall) it.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

It is possible that there is a problem with key3.db (encryption key) and logins.json (encrypted names and passwords) in Firefox. You can open the logins.json file in the Scratchpad (Firefox/Tools > Web Developer) to check its content. Click the "Pretty Print" button to format the file for readability. If there are names and encrypted passwords in logins.json then there is likely a problem with the key3.db file that stores the encryption key. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) or move these files to another folder to make it possible to undo the action.

Rename or remove a possible signons.sqlite file (signons.sqlite.old) used by older Firefox versions as well. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.

You can use this button to go to the current Firefox profile folder:

more options

After finding that things worked in the Safe Mode. I started experimenting with disabling verious add ons. It did indeed turn out to be the "remember Passwords" extension version 1.1.1 by Stanimir Slamendov. I had been using it for a year or so, but is apparently not compatible with the latest versions of Firefox.

Thanks everyone for your advice and help tracking this down.

Jay.W

more options

Jay.W said

. . . . . . but I'm not there yet. I updated my Adobe Flash player . . .

The Flash Player was a separate issue. Sorry for the confusion.