Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

i keep getting a message saying firefox has prevented the unsafe plugin "adobe flash" from running

  • 16 uphendule
  • 22 zinale nkinga
  • 461 views
  • Igcine ukuphendulwa ngu madmagic

more options

my flash player IS up to date but firefox keeps crashing and i keep getting this error message firefox has prevented the unsafe plugin "adobe flash" from running (whatever webpage im on) please let me know how i can fix this? ASAP

Isisombululo esikhethiwe

Hi Janetc69,

I had the same issue, after informing myself with a few PC mags online, I simply uninstalled Adobe flash player from my laptop. Since then, I have had no issues with playing videos with the firefox browser. Whats more, it seems to work better than before. Anyway most browsers are slowly eliminating Adobe flash player from their systems. If this doesnt work you can always reinstall Adobe, try it.

good luck!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (16)

more options

Sorry for the confusion. In recent days, it was discovered that the latest Flash plugin is vulnerable and unfortunately there is not yet a replacement.

The plugin checker site now has a large notification:

All versions of Adobe’s Flash Player plugin are currently vulnerable.

A "Learn more" link leads to this page: https://support.mozilla.org/kb/set-adobe-flash-click-play-firefox

So even though there is an update button, in this case, there is no update available so please ignore the button for now. You might check again tomorrow.

Until then, if you are not accustomed to using the "Ask to Activate" feature for a plugin, here's what to expect:

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the Lego-like icon in the address bar to allow Flash.

But the page might be using Flash only for tracking or playing a video ad. If you don't see an immediate need for Flash, feel free to ignore the notification, it will just sit there in case you want it later.

more options

Now, about those crashes, sorry about that. Are you getting the Mozilla Crash Reporter dialog? If so, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" for steps to get those crash IDs from the about:crashes page, and then post some of the recent ones here.

more options

It keeps happening i keep sending the reports and NOTHING.

more options

Hi janetlc69, I know, I know, the reports go into a huge system that triages them for fixing, but they don't send personal responses. In order to get assistance with your crashes you are in the right place now. To let us have access to your crash reports so we can see what's going on, we need some of the report IDs. The article I mentioned before has the steps for finding those.

more options

bp-2901b52e-31ad-4be8-8b4f-73a472150714 on 7/13/15 6:38 PM bp-1bb6974b-513b-4ffe-b2ce-202932150713 on 7/12/15 6:14 PM bp-b05dab73-ddbc-43a0-a785-2466b2150713 on 7/12/15 5:10 PM

these are the last few crash reports i had

more options

These crashes involve a certain kind of accelerated graphics rendering. Do you know whether there might be any updates available for your Nvidia GeForce card driver software? This article lists safe places to check: Upgrade your graphics drivers to use hardware acceleration and WebGL.

If that looks to be too time-consuming to run down, could you try disabling Firefox from using hardware acceleration? You could do that here:

"3-bar" menu button (or Firefox menu) > Preferences > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. It may take some time to know whether it is making any difference.

more options

I have a macbook pro. im not sure what kind of video card i have.

more options

Hi janetlc69, I only know what I see in the crash reports...

Could you copy and paste the Graphics section from the support information page? You can open that using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Return

Scroll down to where you see the Graphics header, and then you can select from Graphics through the end of the table below it, copy, and paste into a reply.

more options

ok this is what i had.

more options

Hmm, I was hoping for more version information like I see on Windows. I can't tell either the version number or release date. Hopefully a Mac person can point to additional suggestions if our support article didn't lead to a useful place on Nvidia's site.

more options

so i guess im outta luck then?

more options

I think my earlier post is all I can suggest at the moment: https://support.mozilla.org/questions/1072028#answer-753273

more options

yeah im outta luck apple is a piece of crap company they are not going to help me. thanks anyway

more options

Well, in that case, it makes sense to proceed to the later section about changing a couple Firefox settings:

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_i-still-have-problems-with-my-graphics-card-in-firefox

more options

janetlc69 said

my flash player IS up to date but firefox keeps crashing and i keep getting this error message firefox has prevented the unsafe plugin "adobe flash" from running (whatever webpage im on) please let me know how i can fix this? ASAP
more options

Isisombululo Esikhethiwe

Hi Janetc69,

I had the same issue, after informing myself with a few PC mags online, I simply uninstalled Adobe flash player from my laptop. Since then, I have had no issues with playing videos with the firefox browser. Whats more, it seems to work better than before. Anyway most browsers are slowly eliminating Adobe flash player from their systems. If this doesnt work you can always reinstall Adobe, try it.

good luck!