Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

What is Google Chrome? Do you recommend installing it? Is it different than the regular Google?

  • 16 uphendule
  • 4 zinale nkinga
  • 326 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I am having trouble with a retailer's website. They recommend using Google Chrome. I do not know what it is. Please reply.

Isisombululo esikhethiwe

Close Firefox. After a few moments to let FF close out, hold down the <shift> key and start Firefox. If the problem goes away, it tells us something. If not, it tells us something else. No harm will come to your system by doing this.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (16)

more options

It's another web browser. http://en.wikipedia.org/wiki/Google_Chrome http://www.google.com/chrome/

I don't recommend installing Chrome due to its' updater service running all the time; whenever your PC is turned on.


What sort of problem with that website? And which one?

more options

I am having trouble with Kohl's Dept. Store website. When I try to order something, I keep getting the "hand cursor" which seems like it is frozen. Therefore, I cannot "add to bag" any items. I never had this trouble before.

more options

Try the Firefox SafeMode to see how it works there. A troubleshooting mode, which disables most Add-ons. Troubleshoot Firefox issues using Firefox SafeMode

When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.
You can open the Firefox 15.0+  SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.  
Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running. 


To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.


If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one. http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes Or it might be caused by Hardware Acceleration.

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

more options

I don't understand why I have to go through all this trouble; I thought the problem was with the retailer's website.......not my computer.

more options

It will take you less than a minute to open the Firefox SafeMode and see if the Kohl's website works properly with your extensions disabled.

more options

What kind of trouble do you have with that website?

Note that if you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I am still having trouble with Kohls website. The hand cursor sticks on the box that says "add to bag." I have not tried the safe mode yet because I really do not know anything about it and keep thinking that maybe I will mess something up and then not know what to do. Is it the fault of the department store or my computer? I have never had this trouble before.

more options

Did you bother reading this support article to learn about the SafeMode? Troubleshoot Firefox issues using Safe Mode

more options

The instructions to start Firefox in Safe Mode say to "click the menu button." I don't know where the Menu button is located.

more options

Isisombululo Esikhethiwe

Close Firefox. After a few moments to let FF close out, hold down the <shift> key and start Firefox. If the problem goes away, it tells us something. If not, it tells us something else. No harm will come to your system by doing this.

more options

I did exactly what you said to do and, finally, I think it worked! I went to Kohls website and tried ordering a few things just to see what would happen and that cursor that was frozen now seems to be OK. Even Kohls customer service team couldn't solve this problem. We have been going back and forth on this for about 4 or 5 days. Thanks for all your help!

more options

That you had no problem could mean that the issue is an add-on, or one of your settings. Is the problem still there when you run Firefox normally?

Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, find and check the plugins, make sure they are set properly. .

more options

I followed these steps, however, when I got to PERMISSIONS, I do not know what to do from here. Everything is checked "set to default." I am not familiar with any of this.

more options

That's why we are here.

Go thru the list. Change all of the plugins to Ask.

After reload the page.

more options

I did all the steps, but now at the top of my screen it is asking something about "adobe flash"...continue blocking or allow. What is this for? I don't want those boxes at the top of my screen.

more options

If, at the top of the screen, you get a message that a plugin is asking to run, choose yes or no. You can also choose Remember For This Site. That is because the plugin has been told to ask permission before it can run.