搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Installed java plugin in /usr/lib64/mozilla/plugins. Still it doesn't show up in the plugin list. Can you help?

  • 4 回覆
  • 9 有這個問題
  • 2325 次檢視
  • 最近回覆由 dyda

more options

I have the libnpjp2.so -> /usr/java/jre1.7.0_04/lib/i386/libnpjp2.so symlink installed in /usr/lib64/mozilla/plugins (linux, RHEL6, Firefox 24.3.0) Still this java plugin doesn't show up in the plugin list. Other plugin in the same /usr/lib64/mozilla/plugins directory, such as libflashplayer.so -> /usr/lib64/flash-plugin/libflashplayer.so for instance works fine. Any suggestions?

所有回覆 (4)

more options

Please try the following:

  1. Open the Firefox profile folder
  2. Completely close Firefox and rename the pluginreg.dat file.
    A new pluginreg.dat file will be generated once you restart the browser.
    Any plugins you may have disabled in the Firefox Add-ons Manager will be enabled.
    More information about this step can be found here.
more options

Hi ComputerWhizz,

Your reply was helpful as it identified the problem, thank you. Upon restarting firefox, I get now: LoadPlugin: failed to initialize shared library /usr/java/jre1.7.0_04/lib/i386/libnpjp2.so wrong ELF class: ELFCLASS32 I think this indicates a 23bit vs 64bit issue. Annoying thing is that of course this jre is what I get from redhat. Do you have any suggestion?

Thanks.

more options

Sounds that you have a 32 bit Firefox version and not a 64 bit version.
So you need the 32 bit Java version.

Are you sure that the other detected plugins aren't located elsewhere?

You can find the installation path of all plugins on the about:plugins page.


See also:

more options

Thanks cor-el, but not quite. I have the 64 bit Firefox, the problem was that what redhat gives you via yum is a 32 bit java. So, not knowing this I put a symlink into /usr/lib64/mozilla/plugins that was pointing to this 32 bit .so so the 64 bit firefox chocked. So the solution was to get into a redhat subchannel and install icedtea-web.x86_64, via yum and set up a new link in /usr/lib64/mozilla as libjavaplugin.so -> /etc/alternatives/libjavaplugin.so.x86_64 Let me just say that this whole thing is crazy. It would sooo much easier if firefox came with its java plugin, but I guess I'm not the first one to realize this.