搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

where is open links in new tab option as I dont want to right click?

  • 13 回覆
  • 14 有這個問題
  • 40947 次檢視
  • 最近回覆由 cor-el

more options

I am using kubuntu 12.04 Fire fox 20. I want to open links in a new tab without right clicking I used to be able to this why can't I now?

被選擇的解決方法

By the way, Firefox also offers you the option to open a link in a new tab using:

  • middle-click the link (e.g., mouse scroll wheel)
  • Ctrl+click the link (Mac: Command+Click)
從原來的回覆中察看解決方案 👍 3

所有回覆 (13)

more options

The built-in option allows you to divert links that open in a new window to a new tab instead. This is for links pre-coded by the site to launch in a new window.

As far as I know, Firefox never had a feature to launch ALL links in a new tab. However, you might have been using an add-on for that. Tab Mix Plus is a popular extension you could try: Tab Mix Plus

In the Tab Mix Plus options, on the Links tab, you will see a drop-down to set this:

Force to open in new tab:

  • Nothing
  • All Links
  • Links to other sites

Does that do what you want?

more options

Ctrl + Click

more options

選擇的解決方法

By the way, Firefox also offers you the option to open a link in a new tab using:

  • middle-click the link (e.g., mouse scroll wheel)
  • Ctrl+click the link (Mac: Command+Click)
more options
more options

You musn't of been usinfg firefox for very long then buddy.

more options

Thanks, its better but not really the same.

more options

Thanks omni replyers "mouse scroll" works best for me now. I have an answer. Yay.

more options

I have another Machine with XP on it, I had to do a reinstall, because of a virus. and, after all updates installed. the firefox build that was on the machine would go to a new tab when I clicked on a link "using Ixquick search engine" it would open a new tab and go right to it with out having to doing anything. But now I have to right click on link to open new tab, and even then I will have to click on the new tab! why did it work right " meaning go to new tab" before I had to reinstall? By the way the center button trick on mouse does work good! Thanks

由 devildawg1 於 修改

more options

Hi devildawg1, search engines often have a setting to open results in a new window (which gets diverted to a new tab by default). This actually is a change embedded into the links in the page, and the search engine knows your preference based on a cookie.

Because you reinstalled, you likely would have lost your cookies. Can you visit the settings page and make sure you have the "new window" setting turned on?

https://ixquick.com/do/preferences.pl

If that isn't what you mean by link "using Ixquick search engine", could you explain your question in more detail?

more options

Hi jscher2000, I have all settings set the same way I did before. this machine is my main one with win 7 and set up the same way in every detail. not sure is that makes any difference, but when using this machine, when I click in a link and it will go right to and open the new tab. I think this build might be V22 but not sure. any way all settings are setup just as they were before the reinstall. meaning Browser and Ixquick, all setting the same as before. Thanks

由 devildawg1 於 修改

more options

Hi devildawg1, on the machine that's not behaving, try this general advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page and revisit the Ixquick settings page to create a fresh cookie. Does that help?

more options

Hi jscher2000, I'll try that, if that doesn't help I'll get back to you. OK? Thanks for your help!

more options

You can also try to open a new window to see if the new window works better.