搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I can't get password prompt to display; have already tried resetting Firefox and still problem occurs in Safe Mode.

  • 3 回覆
  • 16 有這個問題
  • 3012 次檢視
  • 最近回覆由 cor-el

more options

The problem is with not with every website, just one. This is a site that previously remembered my username & pw, but I changed the pw and the prompt did not display to update it, so I deleted it from the Firefox/Options/Security/Saved Passwords tab, and now when I type in the new pw, it's still not asking me whether I want to remember the pw (nor does it remember the old pw). I tried Safe Mode and I tried resetting Firefox. Neither one worked.

所有回覆 (3)

more options

You can check if there are entries in the password manager with an empty user name.

Remove saved Password(s):

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

You can also check the exceptions.

  • Tools > Options > Security: Passwords: Exceptions

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Thank you for your reply. As stated above I had already tried the first option, and the site isn't on the exceptions list either. I just tried the second option ("forgetting" the site) and that didn't work either. (I don't know whether it makes a difference or not, but I tried the "forgetting" option twice, re-testing the password both before and after closing the browser. The password prompt still didn't display.) Do you have any other suggestions?

more options

The website may be using autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

If you can post a link to that site then we can check this.