Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

hotmail.com individual emails do not open under Firefox 12.0

  • 20 回覆
  • 236 有這個問題
  • 7071 次檢視
  • 最近回覆由 smcc42

more options

When I am signed into hotmail using firefox browser, I am unable to open emails or write a new email. I am running firefox 12.0 on windows 7 . I do not have this problem with hotmail using Google Chrome or Microsoft Internet Explorer. Any help would be appreciated. I have already uninstalled and re-installed Firefox 12.0 once and this did not solve the problem.

由 phkahn 於 修改

被選擇的解決方法

do you use foxit reader? If you do, uninstall it and re-install version 5.1.4.0104. See the link a few posts back by silkphoenix.

從原來的回覆中察看解決方案 👍 8

All Replies (20)

more options

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

1. Clear Firefox's Cache

orange Firefox button or Tools menu > Options > Advanced

On the Network mini-tab > Offline Storage : "Clear Now"

2. If needed, delete the site's cookies here

While viewing a page on the site, right-click and choose View Page Info > Security > "View Cookies"

In the search box at the top of the dialog, it probably will say live.com rather than hotmail.com; that's normal.

After removing the cookies, reload and re-login. Does it behave any better?

more options

phkahn -- By any chance, do you have AVG installed? It happened to me this morning after I updated both AVG as well as Foxit Reader. Hotmail was working fine before that. I have AVG 2012.0.2171 and Foxit Reader 2.2.1.417. I couldn't open/delete/compose emails in Hotmail. It's working fine in both Chrome and IE.

jscher2000 -- I have done all those you mentioned and the problem persisted.

PS: I have also disabled AVG Do-Not-Block and Safe Search add-ons, as well as disable AVG completely in my PC, none of these procedures help.

more options

OK, I think I have found the culprit here. I revert my Foxit Reader back to version 5.1.4.0104, cleared the Cache and all cookies for Hotmail, then log-out and log-in Hotmail again, and it is working normally now.

phkahn, If you updated your Foxit Reader to the latest version, you might want to revert it back to the old one, that's my suggestion.

more options

Thank you for your suggestions. I tried what you suggested but it did not work. I solved the problem for now by uninstalling Foxit Reader.

more options

To Silkphoenix: I uninstalled Foxit Reader and now the Hotmail.com site works on Firefox 12.0 . I will try to reinstall Foxit Reader. Thanks for your help.

p.s. I installed Foxit Reader without the Mozilla plug-in and without the Shell extensions and Hotmail.com on Firefox 12.0 works fine. Thanks again for your help.

由 phkahn 於 修改

more options

I have the same problem. Try deactivating the foxit reader plugin. This works fine for me, but i can't read PDF files in firefox...

more options

chvatro -- You can download the old Foxit Reader version 5.1.4.0104 here:

http://www.oldapps.com/foxit_reader.php


That's what I am using now.

more options

I uninstalled foxit reader and everything works in hotmail again.

more options

Mouse will not work in Hotmail, but works normally in gmail or Frontier mail. I have started having problems with my Hotmail account only when using Firefox. Hotmail works normally when I use Internet Explorer. For some reason when I click on an email, nothing happens. When I click on the box in front of the email to select it, I get a check mark (which is normal) but I can’t move or delete it. When I try to switch folders nothing happens either. The only thing I can select with my mouse is the “?” (help symbol). If I do a CTRL/n (keyboard shortcut to compose an email), the screen goes to the compose screen. Then my mouse starts working normally. I worked with Hotmail support for several days when I remembered that about the time the problem started I had downloaded and installed the latest Firefox download. Hotmail support suggested I contact Firefox support to see if they have a solution

Donald Bigbee bigbee63@live.com

more options

選擇的解決方法

do you use foxit reader? If you do, uninstall it and re-install version 5.1.4.0104. See the link a few posts back by silkphoenix.

more options

No, I don't use foxit reader. In fact I had never heard of it. I checked and it is not installed on my PC.

 Thanks anyway.

Old Man of the Sea.

more options

Just an FYI. The Foxit folks are aware of the issue and are working on a fix. For now running an older version is your best bet.

more options

After years of only using firefox I've had to give it up and go to chrome because firefox has become so buggy with hotmail that I can barely use it. Emails won't open, pages won't scroll. It's really frustrating. I don't have foxit, don't even know what it is. I thought it might be a mac issue since I have only had this problem since I got my mac air. Mac os 10.7.4, firefox 12.0

more options

Hi profamericain, since you posted here, I suspect you might want to give Firefox one more try. Firefox 13 has a new "Reset" feature which creates a new settings folder leaving behind most of what can cause problems in Firefox -- including all your add-ons. For more information, you can check out this article: Refresh Firefox - reset add-ons and settings.

more options

I started to have problems with Foxit at the Amazon site this AM. :(

The rollback solution from this solution worked perfectly. Thank you so much, silkphoenix!

more options

Thanks, I installed 13 and will see how it works.

more options

I just want to give an update to everyone that Foxit Reader has fixed its problem with Hotmail with the latest version 5.3.1.0606. I updated mine and everything is fine with Hotmail in Firefox.

more options

I seem to have solved the problem by going to Firefox -> Options -> Security -> Exceptions to sites which may install add-ons. I added hotmail.com to the allowed list and Hotmail seems to be working well again.

more options

Hi smcc, can you tell what, if anything, live.com was trying to install?

more options

I have absolutely no idea! I found the answer on Microsoft answers http://answers.microsoft.com/en-us/windowslive/forum/hotmail-email/i-cant-open-my-hotmail-emails-in-firefox-why/d4bdf3a2-b107-4c0f-a8e4-2e930a827c75.

The relevant post is:- "Non of the above solved the problem. But after clearing all the possible cache and files, I did as someone on the firefox solution page had once written ie. I added hotmail.com, live.com, passport.com and msn.com to the safelist of the sites which may add add-ons (firefox-settings-safety-exception to the websites which may add add-ons).

Now everything works again! :)"

I added only hotmail.com.