搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Video playback stops after a few minutes

  • 4 回覆
  • 4 有這個問題
  • 1 次檢視
  • 最近回覆由 Dan

more options

I'm encountering an issue on Firefox mobile where in-browser video playback only buffers a few minutes of a video file, plays it normally for a few minutes, and then stops and won't load any additional video. Refreshing the page and scrubbing forward on the video to the point I left off will let me continue for the next few minutes but it inevitably stops again after a few more minutes. It's as though Firefox is only willing to buffer a video when the page is first loaded, and it forgets to keep buffering as the video is played through. This is frustrating for short videos where this would need to be done a couple of times, but is untenable for anything longer.

This issue replicates on any streaming website I use the browser for, it happens on multiple different networks, and it not an issue with any other video apps on my device. So I suspect it is locallized to an issue with Firefox mobile. I have tried updating Firefox (running v 110.0.1) but the problem persists

Is there a fix for this? A setting I'm missing somewhere? Maybe is it possible to increase the buffer limit on the mobile app so that it can load a whole video at once, instead of just a small portion of it when the page first loads?

Thank you!

I'm encountering an issue on Firefox mobile where in-browser video playback only buffers a few minutes of a video file, plays it normally for a few minutes, and then stops and won't load any additional video. Refreshing the page and scrubbing forward on the video to the point I left off will let me continue for the next few minutes but it inevitably stops again after a few more minutes. It's as though Firefox is only willing to buffer a video when the page is first loaded, and it forgets to keep buffering as the video is played through. This is frustrating for short videos where this would need to be done a couple of times, but is untenable for anything longer. This issue replicates on any streaming website I use the browser for, it happens on multiple different networks, and it not an issue with any other video apps on my device. So I suspect it is locallized to an issue with Firefox mobile. I have tried updating Firefox (running v 110.0.1) but the problem persists Is there a fix for this? A setting I'm missing somewhere? Maybe is it possible to increase the buffer limit on the mobile app so that it can load a whole video at once, instead of just a small portion of it when the page first loads? Thank you!

所有回覆 (4)

more options

Hi Dan

Have you tried using the Video Background Play Fix add-on available from the Add-ons option in the Firefox for Android menu? This should help resolve this issue.

more options

Paul said

Hi Dan Have you tried using the Video Background Play Fix add-on available from the Add-ons option in the Firefox for Android menu? This should help resolve this issue.

Thank you Paul, but this did not work. It appears that the app you reference only applies to YouTube and Vimeo.

more options

Are you able to share a link to an example video where this issue happens?

more options

Paul said

Are you able to share a link to an example video where this issue happens?

Sure, here's one such example: https://www.crave.ca/en/tv-shows/chernobyl/vichnaya-pamyat-s1e5