搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Opening links / tabs behaviour help

  • 5 回覆
  • 1 有這個問題
  • 59 次檢視
  • 最近回覆由 YongHan

more options

I've recently made the switch to Firefox coming from Opera, and there's a few behaviours I'm missing / haven't figured out how to set up to match what I'm used to. Could someone point me in the right direction?

1) When I click an external link (e.g. in Discord) to open in browser (Firefox is now default), it opens the link but it overrides the currently selected tab rather than opening a new tab.

2) Following on from that, clicking the link also doesn't make Firefox the active window. Previously if I opened a new link from elsewhere, the other browser would come to the front. Can Firefox do that too?

I currently have it set so that opening a link in a new tab doesn't switch to that tab. Which is behaviour I want (if I'm doing that in Firefox itself).

I've recently made the switch to Firefox coming from Opera, and there's a few behaviours I'm missing / haven't figured out how to set up to match what I'm used to. Could someone point me in the right direction? 1) When I click an external link (e.g. in Discord) to open in browser (Firefox is now default), it opens the link but it overrides the currently selected tab rather than opening a new tab. 2) Following on from that, clicking the link also doesn't make Firefox the active window. Previously if I opened a new link from elsewhere, the other browser would come to the front. Can Firefox do that too? I currently have it set so that opening a link in a new tab doesn't switch to that tab. Which is behaviour I want (if I'm doing that in Firefox itself).

被選擇的解決方法

Hello BraXzy,

Regarding your first request, here is a detailed solution provided by a moderator that works (I have tested it on my machine by opening an external link in Discord): Link to question with detailed solution: https://support.mozilla.org/en-US/questions/1258193

In your case, type "browser.link.open_newwindow.override.external" and click the pencil icon on the right of the column to change it from -1 (default) to 3. If you want detailed explanations on what these numbers mean, refer to the link above.

Regarding your second request, when testing on my machine, Firefox appears to come to the front when clicking external links in Discord after applying the above configuration setting. I tested with Google Chrome being open and clicking an external link in Discord, and it appears that Firefox (which is set as the default browser) will then come to the front.

Hopefully this answer helps, if it did, kindly mark this answer as the solution(solved)!

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

選擇的解決方法

Hello BraXzy,

Regarding your first request, here is a detailed solution provided by a moderator that works (I have tested it on my machine by opening an external link in Discord): Link to question with detailed solution: https://support.mozilla.org/en-US/questions/1258193

In your case, type "browser.link.open_newwindow.override.external" and click the pencil icon on the right of the column to change it from -1 (default) to 3. If you want detailed explanations on what these numbers mean, refer to the link above.

Regarding your second request, when testing on my machine, Firefox appears to come to the front when clicking external links in Discord after applying the above configuration setting. I tested with Google Chrome being open and clicking an external link in Discord, and it appears that Firefox (which is set as the default browser) will then come to the front.

Hopefully this answer helps, if it did, kindly mark this answer as the solution(solved)!

由 YongHan 於 修改

有幫助嗎?

more options

YongHan said

Hello , Regarding your first request, here is a detailed solution provided by a moderator that works (I have tested it on my machine by opening an external link in Discord): Link to question with detailed solution: https://support.mozilla.org/en-US/questions/1258193 In your case, type "browser.link.open_newwindow.override.external" and click the pencil icon on the right of the column to change it from -1 (default) to 3. If you want detailed explanations on what these numbers mean, refer to the link above. Regarding your second request, when testing on my machine, Firefox appears to come to the front when clicking external links in Discord after applying the above configuration setting. I tested with Google Chrome being open and clicking an external link in Discord, and it appears that Firefox (which is set as the default browser) will then come to the front. Hopefully this answer helps, if it did, kindly mark this answer as the solution(solved)!

Thank you so much for your help. The first part is working exactly as I hoped :)

As for the second part, I want to keep it so that while using Firefox, opening a link in New Tab does so in the background. But if I open an external link it opens. Is it possible to have both?

Could you also please edit my username in the original post as I have now updated it thank you!

由 BraXzy 於 修改

有幫助嗎?

more options

Hello BraXzy,

For the second request, you can click the menu (3-line) button on the top-right corner of your Firefox browser, then click "Settings". At the "Tabs" section, uncheck the "When you open a link, image or media in a new tab, switch to it immediately" checkbox.

Firefox should now work as intended, opening a non-external link in New Tab will not forcibly switch you to the New Tab and will instead open in the background. Opening external links in Discord will bring Firefox to the front and in this case will switch you to the New Tab for the opened external link. I tested on my machine for both scenarios. I also edited your username in the original post!

Refer to the screenshot if you need additional context. Hopefully this answer managed to help you, if it did, kindly mark this answer as the solution(solved)!

由 YongHan 於 修改

有幫助嗎?

more options

YongHan said

Hello BraXzy, For the second request, you can click the menu (3-line) button on the top-right corner of your Firefox browser, then click "Settings". At the "Tabs" section, uncheck the "When you open a link, image or media in a new tab, switch to it immediately" checkbox. Firefox should now work as intended, opening a non-external link in New Tab will not forcibly switch you to the New Tab and will instead open in the background. Opening external links in Discord will bring Firefox to the front and in this case will switch you to the New Tab for the opened external link. I tested on my machine for both scenarios. I also edited your username in the original post! Refer to the screenshot if you need additional context. Hopefully this answer managed to help you, if it did, kindly mark this answer as the solution(solved)!

Thank you so much for your help, it still wasn't quite working on my machine but I found that this setting did what I needed:

browser.tabs.loadDivertedInBackground changed from true to false

So now if I'm on Firefox and middle mouse click a link, it still loads in the background (thanks to the initial setting you mentioned). And if I click a link externally, it switches to that tab and focuses the window.

有幫助嗎?

more options

Hello BraXzy,

Glad to hear that you managed to solve the issue! browser.tabs.loadDivertedInBackground is usually set to False by default so good call on determining that your setting was changed from default settings and that it was causing your issue.

由 YongHan 於 修改

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題