搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

GArbled Text

  • 9 回覆
  • 1 有這個問題
  • 22 次檢視
  • 最近回覆由 Seburo

more options

Well, even the pulldown is not working here. None of the solutions for the garbled text works for me (and now that pulldown option isn't always working) and I am about to permanently change to Safari after years of being a Firefox advocate and user. Without any way to actually ask an actual person about this question/problem and not being a programmer I am exceedingly frustrated and disappointed. I do have to agree with the commenter who said we shouldn't have to go through this just to get a website to display. I've tried several times to upload an image but frankly I feel like just giving up

所有回覆 (9)

more options

You did not say what it is you already tried.

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

有幫助嗎?

more options

Is this text just on the web page?

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

有幫助嗎?

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

有幫助嗎?

more options

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

有幫助嗎?

more options

Fred McD: Screenshot now uploaded. It wouldn't upload earlier. I have tried the inspect element, I have the preferences set to let sites choose fonts, when I inspected the element it's just helvetica which, of course, is in the system fonts on my Mac. Is it possible that this has something to do with this OS (11.3.1 BigSur)? It does not happen on my Mac laptop with Firefox and an older OS. Thank you!

有幫助嗎?

more options

Is this Helvetica font (all variants) installed as a system font and not as a user font in a non standard location ?

有幫助嗎?

more options

Thanks for reply. Helvetica is in a million places on my computer including being listed in system fonts. Since I'm a designer folks are always including fonts with jobs so helvetica pops up all the time.

有幫助嗎?

more options

For Cor-el... I say with trepidation that I think it might be fixed. The font issue led me to Font book where I fixed duplicate helveticas and now I have not been seeing any garbled text. Everything, at least on a Mac, is always about fonts. Thanks to everyone and I will keep you posted.

有幫助嗎?

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題