搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Australian Gov HTTPS (BOM) access problems - Weather/radar Site - Bureau of Meteorology (Australia) – not working under HTTPS and Firefox.

  • 11 回覆
  • 2 有這個問題
  • 40 次檢視
  • 最近回覆由 cor-el

more options

31-August 2021 . Hi all, recently the Australian government , “Bureau of Meteorology” weather and radar – website has stopped working under HTTPS and FireFox – it does work under Microsoft Edge though (Yuk). . Unfortunately even if under the FireFox internal settings - you disable the need for a HTTPS connection – the website still kicks you out anyway – and any direct call to the site (http://www.bom.gov.au) – will just kick you to an endless loop of no achievement – by basically constantly telling you “you cannot use HTTPS” and the HTTP link provided just loops you back to the same place. . For now – the only solution I have found is to leave “HTTPS” on – and create an exception for every single page (very zzzzz). . So for me , I am only excepting and viewing the local weather radar page and getting all other info from other sources. . Machine specs - Win10 Pro , Firefox Version 91.0.2 (64-bit) . I have also (via Edge) – reported this to the “BOM” in Australia, . I hope this helps someone , as I cannot be the only person in Australia trying to access this site – but having to sign up - to report the problem here, I did find more than a bit off putting.

附加的畫面擷圖

所有回覆 (11)

more options

有幫助嗎?

more options

See also:

I assume that at some point they BOM will support HTTPS once again.

有幫助嗎?

more options

I guess that people understand that answers like . "I assume that at some point they BOM will support HTTPS once again." and "This is popular issue" - dont actually help anyone. . At the start, I posted the "Kludge" I am using to get around it (for now) - you could try telling people about that

有幫助嗎?

more options

Hi ponytrekker. Thanks for your note on my question 1347063.

I can make one addition to the discussion. I find that if I open a Firefox window in 'private browsing mode' I am unable to view the BOM website due to the HTTPS issue. I previously had 'Always use private browsing mode' ticked on in my Privacy settings. That was before I performed a Refresh and went back to Firefox default settings which in my case resolved the problem.

I don't know if this will assist you, but it may be worthwhile checking your Privacy settings.

Regards, Ron

有幫助嗎?

more options

As I said , its a Kludge (not a fix) - and for whatever reason - it seems this version of Firefox may not actually save the exceptons (even though it says it does) - as I did a system reboot and they were all gone (so I had to use edge to get into Bom, to get the address of the radar page to redo the exeption. . Now FaceBook is having the exact same HTTPS problem (3 Sept 2021) - so the complaints may be coming in thick and fast.

有幫助嗎?

more options

Exceptions are part of the Site Preferences.

Clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data.

I can't imagine that Facebook isn't supporting secure HTTPS like BOM and I'm not seeing this with Facebook, so something else must be wrong for you with Facebook.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

有幫助嗎?

more options

cor-el said

Exceptions are part of the Site Preferences. Clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data. I can't imagine that Facebook isn't supporting secure HTTPS like BOM and I'm not seeing this with Facebook, so something else must be wrong for you with Facebook.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

. Simply put – I have tried all this , to no avail, starting in troubleshooting mode is quite painful (after you find it – then have to restart again and go to all sites etc, etc). . All site data etc is cleared on exit/restart as a normal part of what I do – but if I save something in the settings/preferences – I actually expect it to remain saved, until I choose to delete this, not when FireFox deletes it without telling me – god help anyone who constantly restarts FireFox. . I have been tracking problems since the last Firefox update – which I since now turned all automatic updates off and will likely never turn them back on and deny all update requests bar the next if this ever gets fixed. If there was a update “rollback” option I could find – I would have already done that. . It has already taken me some time to pin it down to Firefox and it having problems with various websites – and the fact that few people seem to care about it - is not heart warming, nor is telling me that a lot of other people have the same problem. . Telling me to effectively “turn my computer off and on” isn’t really helpful to anyone, as if I can repost the problem here, I may already know to do that and even where the power button is. . I don’t run any special themes and only run one add on that cleans up FaceBook – and disabling that makes no difference to anything. . The local FaceBook website of “www.facebook.com.au” – now fails even when HTTPS is turned off (for a HTTPS error) , but at least its redirect to the general HTTP version of “www.facebook.com” works unlike the redirect link on “www.bom.com.au” which does not. . But the problems do not just stop there as they just grow and grow until FireFox and whatever its problems are (considering they didn’t exist until the update) – literally, eventually locks up the whole damm system. In spending the morning testing – I have found that if I simply ovoid FireFox – the other problems go away. . I am doing significant research into a book on a deadline – and this machine can no longer be trusted under FireFox – so I have gone to Edge (which I hate) - as it works and doesn’t have these problems that few seem to care about. . Having a reasonable network, text writing (under word), photo editing and research file storage are now being done remotely on three other machines (via remote desktop) – and FaceBook is also remote on a Win 7 machine, to ensure there are no further stoppages. . Because of this – and no suggestion of a fix or even anyone working on it – with some serious time restraints (for me) – this will be the last piece of time I waste on this for the foreseeable future. If at some point I see an update to Firefox I will let it go though as for now, FireFox is useless to me. . Seeing there is clearly a few people having problems – you obviously have plenty of data, and it seems that Australia isn’t that important anyway - so you don’t need mine. . This was written remotely on a old Win XP laptop – using an old version of Word, and I have gone back to work.

有幫助嗎?

more options

I have seen various reports of the issue but I can load the site without difficulty and I can also load Facebook (https) without difficulty, from Australia. Linux OS and Firefox 91.0.

有幫助嗎?

more options

Note that there seems to be an issue with the https://www.facebook.com.au certificate, so best is to go to www.facebook.com.

有幫助嗎?

more options

6th November 2021. . And so the “Fun” goes on. . Although I have got pretty good at using Microsoft Edge – a situation I literally never expected to be forced into having used FireFox since pre Win XP. . Having recommended it to many people and donated to it, these are things I no longer do and currently tell people to ovoid the later versions of FireFox (as they are all complaining to me) – until, if ever “they” get it sorted out. . I re-enabled the updating on FireFox and let the multiple updates come though and have tested each one, only to be disappointed – so no one can say I haven tried. . Yet another new FireFox update came through last night – at least it finally fixed the access to my own (excruciatingly simple) test website, hosted in the US. That’s like a few others , is a problem I haven’t even bothered to mention – I just gave up and stayed on MS Edge for that and a bunch of things. . For the record , I have contacted the Bureau of Meteorology in Australia – unsurprisingly, they are having no issues with any other browser – except for the later versions of FireFox, so as far as they are concerned – it’s a FireFox problem, and as it only occurred after a FireFox update – I would be very inclined to agree with them. After all – a browser is supposed to be about accessing websites on the internet – not denying me access to a site because FireFox cannot actually handle what its doing - or forcing a website to rewrite their code to suit FireFox , when no other browser is having the problem. . Today – with the latest update – (even in troubleshoot mode) - access to the preferences tab, is nearly ludicrously slow if it works at all. . Figuring it was some form of delay in network comms between the program and the FireFox servers, although I don’t understand why that would effect access to the settings tab on my own local computer, I did a network check. . Yup – its a (server) network problem, possibly because of the loading from the new update ? . But interestingly enough – my landing and other pages are set to blank, I disabled all automatic debugging and other things like FireFox surveys and any and all network communications that I could find etc, etc ,etc - so there should be NO network comms to the FireFox servers at all (in any mode) etc – yet there is an very (very) substantial delay currently in having the Settings page come up, which means it locks FireFox completely up (if not crashes it) – for at least 10 mins.. . Considering that there should be nothing moving across the network between FireFox servers and my computer – its starting to seem like, much like FaceBook and a bunch of other things – FireFox is just deciding and forcing me to do it their way as FireFox sneaks info between my computer and the FireFox servers. . As for “http://www.bom.gov.au” – well that remains a circus. Irrespective of what FireFox settings say (if you can get to that tab) - it cannot be accessed if I select “Don’t Enable HTTPS-Only Mode” – so that’s a joke that’s not funny. . So the only way FireFox will access the “BOM” website – is to “Enable HTTPS-Only Mode in all Windows” – and then set an exception to “www.bom.gov.au” – which you have to save , but that still doesn’t seem to stick anyway. . Save – means SAVE it and I believe most people would realistically think that’s a permanent thing, not a temporary one. FireFox doesn’t clear all its data or settings, so FireFox is intentionally forcing that situation – an “Insecure Site” warning may be appropriate – but this intentionally FireFox forced approach has me using Microsoft Edge as it just simply and quickly works, so I can see the current weather conditions in my local agricultural area. . I am sure someone will have a nicely worded “reason” why its everyone else’s problem other than Firebox’s – but tell that to the people you are ultimately forcing to other browsers that just work. . Where to from here ? – well I no longer trust or recommend FireFox as I don’t know what’s going on with the secret network comms – but I know I didn’t authorize them, and despite a bunch of updates it struggles to do some basic things which it appears is all already well known. . The disappointing thing about that is that I have recommended FireFox since Win 98 – now all I get are complaints from my friends about the latest versions. . Image is a composite of this mornings “entertainment”. . UPDATE - the site wont even let me upload the image , its a wonder I could log in (this sent from Ms Edge, after FireFox didn't work.

由 ponytrekker 於 修改

有幫助嗎?

more options

This is being tracked at this bug:

  • 1725646 - HTTPS-First endless loop with http redirection

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)


You can possibly set these https_first prefs to false on the about:config page.

  • dom.security.https_first false
  • dom.security.https_first_pbm false

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題