搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Certain images broken(Green/Pink)

  • 5 回覆
  • 1 有這個問題
  • 46 次檢視
  • 最近回覆由 Mistful

more options

Hi,

Ever since a while ago, some images are not showing correctly in Firefox. I must have gotten this issue in the last update(84.0.2) or slightly earlier. I tried resetting it, and used safe mode, but I still get the same issue. I don't know how to fix it at this point, and the only solution I have at the moment is to switch over to Chrome for important times, such as for online exams, but this is not ideal. Does anyone have a clue about what could be wrong, or am I doomed to use alternatives to Firefox during important times/just for viewing certain pictures?

Current Version: 84.0.2 (Auto-Update/Help -> About Firefox) OS: Windows 10

Thank you.

被選擇的解決方法

I managed to find the issue. The issue was that I had privacy.resistfingerprinting set to true. Setting this to false fixes my issue, it seems.

從原來的回覆中察看解決方案 👍 0

所有回覆 (5)

more options

If running Firefox in Safe Mode doesn't work then this isn't a problem with hardware acceleration in Firefox.

You can try to enable WebRender if this is currently disabled. You can check the Graphics section on the about:support page to see whether WebRender is active.

You can look at these prefs on the about:config page page to enable or disable WebRender.

  • gfx.webrender.enabled = false|true
  • gfx.webrender.force-disabled = true|false

有幫助嗎?

more options

I had gfx.webrender.enabled set to false, and set it to true, but I still have the same issue. I temporarily set gfx.webrender.force-disabled to true, and gfx.webrender.force-enabled to true (individually), but that did not do anything. It seems that the issue has been carried over to my Linux version as well. Safe mode still produces the same issue, when it should use the default profile without any changes. SVGs work perfectly fine, but PNGs are not showing(vertical lines of color instead of picture).

Second OS: Linux Mint 20.1 Cinnamon Firefox Version: 84.0.2

有幫助嗎?

more options

選擇的解決方法

I managed to find the issue. The issue was that I had privacy.resistfingerprinting set to true. Setting this to false fixes my issue, it seems.

由 Mistful 於 修改

有幫助嗎?

more options

If this is about "Resist Fingerprinting" then this also can be a problem with canvas where drawn on canvas are possibly blocked.

  • privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts

有幫助嗎?

more options

Alright. I set privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts to false. Even if it doesn't cause any issues with it enabled(from what I could see from two pages), I can limit the chances of it popping up in the future. Thank you for your help :)

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題