搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Bookmarks defaulting to last bookmark location for no reason.

  • 5 回覆
  • 1 有這個問題
  • 17 次檢視
  • 最近回覆由 cor-el

more options

So, I just noticed today that my bookmarks section is acting oddly. Normally it brings up the option for where to send a bookmark. But randomly, I've seen it suddenly switch to just defaulting to the last bookmark location. For example, I want to bookmark something in a bookmark folder I have specific for things related to writing, but when I go to bookmark the site, the first thing that comes up is the location I created for youtube videos. What exactly is going on here, and how do I fix that?

所有回覆 (5)

more options

Try to set browser.toolbars.bookmarks.2h2020 = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

Looks like you were half right, Turns out I had to set browser.toolbars.bookmarks.2h2020 to false. The one you suggested IS there, but was already set to false. But anyway, it looks like for now things are back to semi-normal. Thanks! :)

more options

Yes, I'm not sure if this feature to remember the last used folder is under browser.toolbars.bookmarks.2h2020 or simply a new feature. It looks that this isn't working very good in some cases.

  • Bug 1432604 - Allow the star panel to select the last used folder when bookmarking

Somebody created a bug report about this,

  • Bug 1684528 - Cannot set fixed default bookmark folder any more

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

You can vote for a bug to show your interest
https://bugzilla.mozilla.org/page.cgi?id=voting.html

more options

cor-el's reply was on the right tract. I found that changing "browser.toolbars.bookmarks.2h2020 = false" did not work for me. But if you go up a few rows you will find browser.bookmarks.editDialog.showForNewBookmarks. That setting had been changed to "FALSE" (which is not the default setting). When I changed it to "TRUE", my bookmarks started giving me the option of where I wanted to save a new bookmark. I never changed this before, so I'm not sure when it changed. But I did see in another post, that sometimes "sync" causes strange behaviors in FF. I did recently turn on sync temporarily to sync my bookmarks on a second computer. Maybe that is when the config setting was changed.

more options

The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done". You can click the highlighted star a second time to open the "Edit This Bookmark" dialog.

See "How do I change the name or location of a bookmark?"