搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot set exceptions in cookies and site data

  • 6 回覆
  • 1 有這個問題
  • 38 次檢視
  • 最近回覆由 SK_AusTX

more options

Outlook on the web will not launch from Office 365:

-(

Something went wrong Repeating redirects detected.

Click here to sign out.

X-ClientId: DFD46A985D07471A8373B0D7F250B09F X-Redir-Error ArLym14B4LPc7fj11wg|AsTJRt4BNJjQ7fj11wg|ArLym14Biwl_7fj11wg|AsTJRt4Bz3N07fj11wg|ArLym14BsJgp7fj11wg|AsTJRt4BZ4sf7fj11wg|ArLym14BgGjK7Pj11wg|AsTJRt4Bkz-07Pj11wg|ArLym14BjMxu7Pj11wg|AsTJRt4BYzlj7Pj11wg|ArLym14Bd3kV7Pj11wg|AsTJRt4BPoIK7Pj11wg|ArLym14B1ku16_j11wg|AsTJRt4BZkum6_j11wg|ArLym14By4BN6_j11wg|AsTJRt4BBjY16_j11wg|ArLym14BHWHg6vj11wg|AsTJRt4BR-7P6vj11wg|ArLym14BRUKR6vj11wg|AsTJRt4BfVSC6vj11wg|ArLym14BNJwo6vj11wg X-FEServer DM5PR19CA0004 Date:5/11/2020 10:16:18 PM

Microsoft wants me to set

http://*.outlook.com https://*.microsoftonline.com

in trusted sites. "Exceptions - Cookies and Site Data" does not allow entering URLs. Please see my screen capture.

附加的畫面擷圖

被選擇的解決方法

Apparently the wildcard (*) was the issue. By using these URLs as exceptions, without the wildcards, the URLs were accepted and Outlook Web works fine now. Thank you for taking time to discuss this issue with me.

從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Something is very wrong with your exceptions! You may want to remove those.

You cannot use an asterisk or other wildcard when setting Firefox permissions. Can you paste one of the following and then click Allow, and then repeat with the other one:

(See screenshot for how that should end up)

Does that help?

有幫助嗎?

more options

I should ask what your general cookie setting is, since this assumes you allow session cookies for other sites and only need exceptions for the special cases. If you block cookies for all sites, you'll almost certainly need more exceptions to stay logged in on the Office365 infrastructure.

有幫助嗎?

more options

"Something is very wrong with your exceptions! You may want to remove those."

Yes! That is what appears when I attempt to add the URLs that are requested by MS.

"Exceptions - Cookies and Site Data" will not allow me to store URLs. I get the nonsense in the first picture instead.

有幫助嗎?

more options

If you paste

https://outlook.office.com

does Firefox let you click Allow?

But anyway, if you are not blocking cookies, then I don't think any exceptions should be required.

(Bear in mind that "Trusted Sites" is an Internet Explorer list not a Firefox list, so the instructions appear not to be tailored to Firefox.)

Maybe there is a different source of the issue, but I'd just be guessing.

Did you already try flushing the cache in case Firefox is using any old files that are obsolete? More info: How to clear the Firefox cache.

有幫助嗎?

more options

Can you modify cookie allow exceptions via "Tools -> Page Info -> Permissions" ?

有幫助嗎?

more options

選擇的解決方法

Apparently the wildcard (*) was the issue. By using these URLs as exceptions, without the wildcards, the URLs were accepted and Outlook Web works fine now. Thank you for taking time to discuss this issue with me.

有幫助嗎?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題