Search Support

html5 video not displaying

  • 12 回覆
  • 1 有這個問題
  • 132 次檢視
  • 最近回覆由 John345

more options

Trying to set up HTML5 peer-peer video conferencing. Its working on Chrome but not Firefox. I have looked at all the available solutions. I have reinstalled firefox; I have checked that media.windows.foundation is set to "true"; I have checked in "safe mode".

This challenge is an issue which occurs 90% of the time. I have yet to assess what conditions occur when html5 video is finally displayed. I can only say that display only occurrred once today and that was when I first inspected the site this morning.

This situation is occurring both in Firefox and the developer edition. Firefox is latest edition and there are no plugins

Any suggestions?

All Replies (12)

more options

Based in UK. Can you direct me to a UK number please?

Helpful?

more options

Number provided came up twice as no answer and then invalid. I am now also being asked to pay to contact.

Is there a UK number to call please; ....or a time when I will be able to connect with someone?

由 John345 於 修改

Helpful?

more options

Please read this article: https://support.mozilla.org/en-US/kb/hello-status

There are some links to webRTC servers.

Helpful?

more options

Thanks :-)

Plenty of chat options out there, but I specifically wish to have this issue resolved for Firefox browsers.

Helpful?

more options

I'm not really sure, how to reproduce this issue. How do you try to run the video connection?

Helpful?

more options

This is one of the pages I've looked at. It explains a very similar issue I am facing, but there is no solution...

https://support.mozilla.org/da/questions/1202739?page=1

I have checked my extensions; I have none.

My camera light is on and permissions have been granted for the site I am using.

It works on chrome and my mobile.

I have selected about:config and requested a list according to: media*enable; nothing is bold

I'm looking for a solution that goes beyond standard tests that I can find online, that generally list what I've tried above.

Firefox v74.0 (64bit)

Helpful?

more options

The phone number you saw or received earlier is a scam. Please do not attempt to call that number.

Helpful?

more options

Did you check the Web Console ?

Helpful?

more options

Loaded the following URL: https://www.onlinemictest.com/webcam-test/

From what I can see from the web console I see the following related to the "webcam test":

1. Cannot play media. No decoders for requested formats: text/html

2. The script from “https://fra1-ib.adnxs.com/rd_log?an_audit=0&referrer=https%3…est%2F,https%3A%2F%2Fwww.onlinemictest.com%2Fwebcam-test%2F&” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.

3. Source map error: Error: NetworkError when attempting to fetch resource. Resource URL: https://acdn.adnxs.com/video/outstream/ANOutstreamVideo.js Source Map URL: http://video.devnxs.net/rel/OutstreamRenderer/4.6.8-HF2/1581449798494/ANOutstreamVideo.js.map

4. The script from “https://s.update.rubiconproject.com/2/873648/analytics.js?si…0Gecko%2F20100101%20Firefox%2F75.0&dt=8736481428691810142000” was loaded even though its MIME type (“”) is not a valid JavaScript MIME type.

5. The script from “https://fra1-ib.adnxs.com/rd_log?an_audit=0&referrer=https%3…est%2F,https%3A%2F%2Fwww.onlinemictest.com%2Fwebcam-test%2F&” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.

I have also clicked the network tab, but no clues.

???

Helpful?

more options

Oops - repeated what had already been posted .....

由 McCoy 於 修改

Helpful?

more options

John345 said

I have looked at all the available solutions. Loaded the following URL: https://www.onlinemictest.com/webcam-test/

It works. You didn't provide the camera permission for that website. You need also the Autoplay video permission.

See How to manage your camera and microphone permissions with Firefox.

Helpful?

more options

It doesn't on my Firefox browser. It has permission but there is no option for autoplay.

For the other site I am testing on, autoplay is turned on

-(

?

由 John345 於 修改

Helpful?

問個問題

如果您還沒有帳號,您必須先 登入您的帳號 來回覆文章。請 開始一個新問題