搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

dictionary add-on and webextension

  • 9 回覆
  • 1 有這個問題
  • 14 次檢視
  • 最近回覆由 mtrevisan

more options

Hello everybody. I've justed ported my dictionary add-on with the new WebExtension and I'm facing a problem. In the old format (install.rdf) I can specify different name and description for each language, like this:

< em:localized > < Description > < em:locale >en< /em:locale > < em:name >name< /em:name > < em:description >description< /em:description > < /Description > < Description > < em:locale >it< /em:locale > < em:name >nome< /em:name > < em:description >descrizione< /em:description > < /Description > ...

Now (manifest.json) I see there is only one pair of name-discription, like this:

{

  "name": "name",
  "description": "description",

...

The problem is that I didn't find a way to specify the name-description pair for other languages. Trying

{

  "name": "__MSG_extensionName__",
  "description": "__MSG_extensionDescription__",
  "default_locale": "it",

... with the usual locales structure (_locales/{lang}/manifest.json) { "application_title": { "message": "name" }, "application_description": { "message": "description" } }

didn't work because when I upload my extension the AMO complains about non valid tag "default_locale". What am I doing wrong? Thank you

由 mtrevisan 於 修改

所有回覆 (9)

more options
more options

I already followed that, and "[...] didn't work because when I upload my extension the AMO complains about non valid tag "default_locale". [...]"

由 mtrevisan 於 修改

more options

the article talks about a different structure (_locales/{lang}/messages.json - instead of localised manifest.json files)

more options

no-one? that's too bad...

more options

You put the default_locale in a locale file ? What is the error ?

由 AndRo Marian 於 修改

more options

The error I got is that of 'non valid tag "default_locale"', as if it couldn't recognize the manifest.json

由 mtrevisan 於 修改

more options

"default_locale" should be "en" or "it". You have "vec".

more options

Ok, but my language is not present in the ISO 639-1, so it doesn't have a two-letter code. Only in ISO 639-3 there is. If the AMO does not work with ISO 639-3 that's a serious problem from my point of view, because my language will never work.

more options

I've tried putting "default_locale": "it", but without success.