X
點擊此處開啟此網站的行動版。

技術支援討論區

Can't make Firefox my default browser as it's NOT listed in Choose an App.

已張貼

I have to use Windows 10 (Home v:1703).

I'd like Firefox to be my default browser, but it's not listed in 'Choose an App'.

There's just Microsoft Edge listed, along with Internet Explorer, and an option to choose an app from the shop.

Microsoft Edge is also presumptuously shown as the default app to start with.


If Firefox isn't listed, how can I set it to be my default browser - or, isn't this 'allowed' in Windows 10 ?

I have to use Windows 10 (Home v:1703). I'd like Firefox to be my default browser, but it's not listed in 'Choose an App'. There's just Microsoft Edge listed, along with Internet Explorer, and an option to choose an app from the shop. Microsoft Edge is also presumptuously shown as the default app to start with. If Firefox isn't listed, how can I set it to be my default browser - or, isn't this 'allowed' in Windows 10 ?

由 Catherine Barber UK 於 修改

被選擇的解決方法

The image enlarged quite well and is different to mine. I can't imagine why.

It is not clear whether you approached via Firefox - Start with the 3 Horizontal Bar Menu(sometimes called the Hamburger) in Firefox - then >Options>General>"Always check if Firefox is your default browser".

Someone more expert should come along soon.

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

Not sure

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063

更多資訊

alan_r 127 個解決方法 1451 個答案

That is interesting. I have Windows10, too, and if I enter "Default Browser" in the Windows Search Box(alongside the Start Button) I am offered Firefox and Opera as well as Edge and IE. No sign of Chrome! You could try from the Firefox end - Options>General>"Always check if Firefox is your default browser".

That is interesting. I have Windows10, too, and if I enter "Default Browser" in the Windows Search Box(alongside the Start Button) I am offered Firefox and Opera as well as Edge and IE. No sign of Chrome! You could try from the Firefox end - Options>General>"Always check if Firefox is your default browser".
alan_r 127 個解決方法 1451 個答案

Response? Say if you need more expert help.

Response? Say if you need more expert help.

提出問題者

Hello Alan and thanks for your reply.

If I did have expert help please could it be in simple layperson's terminology - I am NO computer geek, and trending terminology and computerese in-speak is lost on me!

Firstly, hope my uploaded image is readable - all my screen shots appear to come out tiny. But hope it'd enlarge if you double-click on uploaded image.....

If it does enlarge, I hope it'll show my problem: that Firefox is not listed in the Web Browser drop-down list.

I tried all options suggested, but it seems that things are deliberately skewed towards one being forced to select MS Edge.

There are some options (?) at bottom: -- 'Choose default application by file type' -- 'Choose default application by protocol' -- 'Set defaults by app'

But the terminology of these options - if that's what they are - mean nothing to me, and I wouldn't know how to carry these out.

Hello Alan and thanks for your reply. If I did have expert help please could it be in simple layperson's terminology - I am NO computer geek, and trending terminology and computerese in-speak is lost on me! Firstly, hope my uploaded image is readable - all my screen shots appear to come out tiny. But hope it'd enlarge if you double-click on uploaded image..... If it does enlarge, I hope it'll show my problem: that Firefox is not listed in the Web Browser drop-down list. I tried all options suggested, but it seems that things are deliberately skewed towards one being forced to select MS Edge. There are some options (?) at bottom: -- 'Choose default application by file type' -- 'Choose default application by protocol' -- 'Set defaults by app' But the terminology of these options - if that's what they are - mean nothing to me, and I wouldn't know how to carry these out.
alan_r 127 個解決方法 1451 個答案

選擇的解決方法

The image enlarged quite well and is different to mine. I can't imagine why.

It is not clear whether you approached via Firefox - Start with the 3 Horizontal Bar Menu(sometimes called the Hamburger) in Firefox - then >Options>General>"Always check if Firefox is your default browser".

Someone more expert should come along soon.

The image enlarged quite well and is different to mine. I can't imagine why. It is not clear whether you approached via Firefox - Start with the 3 Horizontal Bar Menu(sometimes called the Hamburger) in Firefox - then >Options>General>"Always check if Firefox is your default browser". Someone more expert should come along soon.

有幫助的回覆

Hello again!

I'm SO glad the image enlarged - so maybe double-clicking on it does the trick! Maybe it's my edition or version of Windows 10 that makes things different.....

I think I tried several routes: one being the Firefox>3 Horizontal Bars Hamburger> and doing as you suggested, until I come to the 'Always check if Firefox is your default browser'.

See upload if you wish.

But clicking on 'Make default' just takes me to the same old Default Apps page, with the Web Browser displaying MS Edge, and no Firefox in drop-down list.

Hello again! I'm SO glad the image enlarged - so maybe double-clicking on it does the trick! Maybe it's my edition or version of Windows 10 that makes things different..... I think I tried several routes: one being the Firefox>3 Horizontal Bars Hamburger> and doing as you suggested, until I come to the 'Always check if Firefox is your default browser'. See upload if you wish. But clicking on 'Make default' just takes me to the same old Default Apps page, with the Web Browser displaying MS Edge, and no Firefox in drop-down list.

由 Catherine Barber UK 於 修改

FredMcD
  • Top 10 Contributor
4259 個解決方法 59628 個答案
https://www.bing.com/search?q=change+default+browser+windows+10&pc=MOZI&form=MOZSBR
John Kaufmann 0 個解決方法 24 個答案

有幫助的回覆

All of the proposed solutions presume that W10 will offer Firefox as one of its browser options, but Catherine's question begins from the fact that it is not offered there, so the proposed "solutions" don't even address her problem, let alone solve it.

I have experienced the same problem after a temporary downgrade to Firefox 52ESR (to recover important functionality from old extensions). After repeated uninstall/reinstall cycles, I still can't get FF to register as an available handler for web protocols {http, https, ...}, though it is registered as a handler for some web file types {htm, html, mht, shtml, xht, xhtml, xml} (but not all web file types: mhtml and shtm are not available, which may be an omission by the FF installer).

This probably is more a Windows than Firefox issue, especially as it seems related to incomplete uninstall preceding the reinstall. But after hours searching this stupid problem in the registry [it will be so good to get back to Linux] and in Windows and Mozilla forums, I can attest that finding answers is not easy -- all purported answers seem to be off-point -- and the frustration is compounded when people who are kind enough to try to help ignore important details. This question still needs an answer.

All of the proposed solutions presume that W10 will offer Firefox as one of its browser options, but Catherine's question ''begins'' from the fact that '''''it is not offered there''''', so the proposed "solutions" don't even ''address'' her problem, let alone solve it. I have experienced the same problem after a temporary downgrade to Firefox 52ESR (to recover important functionality from old extensions). After repeated uninstall/reinstall cycles, I still can't get FF to register as an available handler for web ''protocols'' {http, https, ...}, though it ''is'' registered as a handler for some web ''file types'' {htm, html, mht, shtml, xht, xhtml, xml} (but not ''all'' web file types: mhtml and shtm are not available, which may be an omission by the FF installer). This probably is more a Windows than Firefox issue, especially as it seems related to incomplete uninstall preceding the reinstall. But after hours searching this stupid problem in the registry [''it will be so good to get back to Linux''] and in Windows and Mozilla forums, I can attest that finding answers is not easy -- all purported answers seem to be off-point -- and the frustration is compounded when people who are kind enough to try to help ignore important details. This question still needs an answer.
John Kaufmann 0 個解決方法 24 個答案

Catherine, please see #1207775. It took some digging to learn about the vagaries of Windows 10 relevant to this problem, and yours was not the only case of this problem still without a solution, so it seemed best to open a new issue for the purpose of laying out the problem and a workaround.

As noted there, Windows 10 is something of a mess, particularly for 3rd-party software support on issues like this, because the combination of bugs and the constant version churn (without fixing the bugs) makes it hard to guarantee that any workaround will work for other versions. However, please take a look at that other article and see if it works for you. If not, please post your results, so that we can consider how your version might differ.

Catherine, please see [https://support.mozilla.org/en-US/questions/1207775 #1207775]. It took some digging to learn about the vagaries of Windows 10 relevant to this problem, and yours was not the only case of this problem still without a solution, so it seemed best to open a new issue for the purpose of laying out the problem and a workaround. As noted there, Windows 10 is something of a mess, particularly for 3rd-party software support on issues like this, because the combination of bugs and the constant version churn (without fixing the bugs) makes it hard to guarantee that any workaround will work for other versions. However, please take a look at that other article and see if it works for you. If not, please post your results, so that we can consider how your version might differ.

提出問題者

Hello John and thank you for your reply. However, I solved this Firefox problem some time ago – but another problem is I cannot find a way of getting through to Mozilla Support that this problem had been solved – despite always clicking on 'Mark it as solved‘ on my notification email.

And, I do have a second bigger Thunderbird problem too (see further below) - but, mysteriously, it seems that this never gets posted up on the Forum....?

Win 10 and Thunderbird - well, like many programs, are seriously glitchy - but, is this problem down to the web designers/programmers - who could sort it out - but ONLY if they wanted, or could be bothered.

They don't bother because they know that they can get away with it.


PROBLEM: My Reply-to sent messages don't show up in my Sent folder, only in my Inbox of all places (!).

Is there any way of rectifying this irritation, so that ALL my sent message only show up in my Sent folder? See attachment trying to show what I mean.

I use Thunderbird Mail version: 52.3.0 (32 bit). My OS is Windows 10 version: 1703 Home Edition (64 bit). I only use a Desktop computer.


WHAT I’VE TRIED TO DO: I've tried Tools > Account Settings > Copies & Folders > > 'When Sending Messages automatically: ' [Check box option] 'Place a copy in: ' [Radio Button option] ' "Sent" Folder on: kate@catbarber.plus.com ' [Radio Button option] ' Other: Sent on kate@catbarber.plus.com ' (I always clicked OK when exiting).

I cannot see the difference between the wording on these two radio button options, and indeed there seemed no result from either, when I tried both these options.

Both times my Reply-to sent message just remained in my Inbox, and failed to show up in my Sent Folder.

I find this really irritating and completely unhelpful - what is the logic of showing a sent message in the Inbox and not in the Sent Folder!?

Hello John and thank you for your reply. However, I solved this Firefox problem some time ago – but another problem is I cannot find a way of getting through to Mozilla Support that this problem ''had ''been solved – despite always clicking on 'Mark it as solved‘ on my notification email. And, I do have a second bigger Thunderbird problem too (see further below) - but, mysteriously, it seems that this never gets posted up on the Forum....? Win 10 and Thunderbird - well, like many programs, are seriously glitchy - but, is this problem down to the web designers/programmers - who ''could ''sort it out - but ONLY if ''they ''wanted, or could be bothered. They don't bother because they know that they can get away with it. PROBLEM: My Reply-to sent messages don't show up in my Sent folder, only in my Inbox of all places (!). Is there any way of rectifying this irritation, so that ALL my sent message only show up in my Sent folder? See attachment trying to show what I mean. I use Thunderbird Mail version: 52.3.0 (32 bit). My OS is Windows 10 version: 1703 Home Edition (64 bit). I only use a Desktop computer. WHAT I’VE TRIED TO DO: I've tried Tools > Account Settings > Copies & Folders > > 'When Sending Messages automatically: ' [Check box option] 'Place a copy in: ' [Radio Button option] ' "Sent" Folder on: kate@catbarber.plus.com ' [Radio Button option] ' Other: Sent on kate@catbarber.plus.com ' (I always clicked OK when exiting). I cannot see the difference between the wording on these two radio button options, and indeed there seemed no result from either, when I tried both these options. Both times my Reply-to sent message just remained in my Inbox, and failed to show up in my Sent Folder. I find this really irritating and completely unhelpful - ''what ''is the logic of showing a sent message in the Inbox and not in the Sent Folder!?

由 Catherine Barber UK 於 修改

John Kaufmann 0 個解決方法 24 個答案

Catherine Barber UK said

Hello John and thank you for your reply. However, I solved this Firefox problem some time ago – but another problem is I cannot find a way of getting through to Mozilla Support that this problem had been solved – despite always clicking on 'Mark it as solved‘ on my notification email.
1) When you say "some time ago", was that after your Nov.18 post? --
There are some options (?) at bottom:
-- 'Choose default application by file type'
-- 'Choose default application by protocol'
-- 'Set defaults by app'
But the terminology of these options - if that's what they are - mean nothing to me, and I wouldn't know how to carry these out.

-- and, if so, did you finally 'Choose default application by protocol' to get Firefox designated as default Web browser? If not, what did you do?

2) Does your solution include having Firefox included in the Web browser 'Choose an app' box? - or is Firefox just listed as default browser without being included among the options in 'Choose an app'?

3) Regardless what happens in regard to your notification email, you can and should still post here, in the same thread, to say (a) that the problem is solved and (b) how you solved it. That kind of follow-up to share solutions is what makes these forums work.


And, I do have a second bigger Thunderbird problem too (see further below) - but, mysteriously, it seems that this never gets posted up on the Forum....?

That is, you tried to post a Thunderbird question in this forum, and it was not posted? Just guessing: that might be due to the split between Fx and TB to allow Fx to move on in ways that are not necessarily conducive to an email client, and that split may extend to this support forum. There is a good Thunderbird support group, available by mailing list:

mozilla-support-thunderbird@lists.mozilla.org

or by newsgroup:

mozilla.support.thunderbird

I suggest posting there to get Thunderbird answers. However, as we are already here, I will try to answer this question, below.


Win 10 and Thunderbird - well, like many programs, are seriously glitchy - but is this problem down to the web designers/programmers - who could sort it out - but ONLY if they wanted, or could be bothered. They don't bother because they know that they can get away with it.

Sorry, but we need to make a distinction here:

Windows 10 is buggy. That is not only no secret, but Microsoft is fairly frank about their policy of putting out buggy software, because people will stick with them while they work out the bugs [if they ever do]. For that, MS is handsomely compensated and has a virtual monopoly on major categories of desktop software.

FOSS (Free and open-source software) products like Mozilla's Firefox and Thunderbird are amazing software produced by people who only do it because they care. Sure, they can make mistakes, but are not nonchalant about them. Their compensation is the satisfaction of seeing things work.


PROBLEM: My Reply-to sent messages don't show up in my Sent folder, only in my Inbox of all places (!).
Is there any way of rectifying this irritation, so that ALL my sent message only show up in my Sent folder?
...
WHAT I’VE TRIED TO DO:
I've tried Tools > Account Settings > Copies & Folders > > 'When Sending Messages automatically: '
[Check box option] 'Place a copy in: '
[Radio Button option] ' "Sent" Folder on: kate@catbarber.plus.com '
[Radio Button option] ' Other: Sent on kate@catbarber.plus.com '
...
I cannot see the difference between the wording on these two radio button options, and indeed there seemed no result from either, when I tried both these options.
Both times my Reply-to sent message just remained in my Inbox, and failed to show up in my Sent Folder.

The main difference between those two radio-button options is that the first is a default, while the second allows you to browse to any folder to hold sent messages. A subsidiary difference is in the default behavior with regard to the next (checkbox) option, "Place replies in the folder of the message being replied to" Is that checked? If so, it will produce the results you see.

I find this really irritating and completely unhelpful - what is the logic of showing a sent message in the Inbox and not in the Sent Folder!?

That checkbox option to "Place replies in the folder of the message being replied to" is not really for the Inbox. It has greatest utility when you filter incoming messages into topical folders [I have a lot of them], and then you read the messages in those topical folders, and want to to keep the replies in those folders. It can save time and is a great productivity aid.

''Catherine Barber UK [[#answer-1084241|said]]'' <blockquote> Hello John and thank you for your reply. However, I solved this Firefox problem some time ago – but another problem is I cannot find a way of getting through to Mozilla Support that this problem ''had ''been solved – despite always clicking on 'Mark it as solved‘ on my notification email. </blockquote> 1) When you say "some time ago", was that after your Nov.18 post? --<blockquote> There are some options (?) at bottom:<br/> -- 'Choose default application by file type'<br/> -- 'Choose default application by protocol'<br/> -- 'Set defaults by app'<br/> But the terminology of these options - if that's what they are - mean nothing to me, and I wouldn't know how to carry these out. </blockquote> -- and, if so, did you finally 'Choose default application by protocol' to get Firefox designated as default Web browser? If not, what did you do? 2) Does your solution include having Firefox included in the Web browser 'Choose an app' box? - or is Firefox just listed as default browser ''without'' being included among the options in 'Choose an app'? 3) Regardless what happens in regard to your notification email, you can and should still post here, in the same thread, to say (a) that the problem is solved and (b) how you solved it. That kind of follow-up to share solutions is what makes these forums work. <hr> <blockquote> And, I do have a second bigger Thunderbird problem too (see further below) - but, mysteriously, it seems that this never gets posted up on the Forum....? </blockquote> That is, you tried to post a ''Thunderbird'' question in this forum, and it was not posted? Just guessing: that might be due to the split between Fx and TB to allow Fx to move on in ways that are not necessarily conducive to an email client, and that split may extend to this support forum. There is a good Thunderbird support group, available by mailing list: mozilla-support-thunderbird@lists.mozilla.org or by newsgroup: mozilla.support.thunderbird I suggest posting there to get Thunderbird answers. However, as we are already here, I will try to answer ''this'' question, below. <hr> <blockquote> Win 10 and Thunderbird - well, like many programs, are seriously glitchy - but is this problem down to the web designers/programmers - who ''could ''sort it out - but ONLY if ''they ''wanted, or could be bothered. They don't bother because they know that they can get away with it. </blockquote> Sorry, but we need to make a distinction here: Windows 10 ''is'' buggy. That is not only no secret, but Microsoft is fairly frank about their policy of putting out buggy software, because people will stick with them while they work out the bugs [if they ever do]. For that, MS is handsomely compensated and has a virtual monopoly on major categories of desktop software. FOSS (Free and open-source software) products like Mozilla's Firefox and Thunderbird are amazing software produced by people who only do it ''because'' they care. Sure, they can make mistakes, but are not nonchalant about them. ''Their'' compensation is the satisfaction of seeing things work. <hr> <blockquote> PROBLEM: My Reply-to sent messages don't show up in my Sent folder, only in my Inbox of all places (!). <br/> Is there any way of rectifying this irritation, so that ALL my sent message only show up in my Sent folder? <br/> ... <br/> WHAT I’VE TRIED TO DO: <br/> I've tried Tools > Account Settings > Copies & Folders > > 'When Sending Messages automatically: ' <br/> [Check box option] 'Place a copy in: ' <br/> [Radio Button option] ' "Sent" Folder on: kate@catbarber.plus.com ' <br/> [Radio Button option] ' Other: Sent on kate@catbarber.plus.com ' <br/> ... <br/> I cannot see the difference between the wording on these two radio button options, and indeed there seemed no result from either, when I tried both these options. <br/> Both times my Reply-to sent message just remained in my Inbox, and failed to show up in my Sent Folder. </blockquote> The main difference between those two radio-button options is that the first is a default, while the second allows you to browse to any folder to hold sent messages. A subsidiary difference is in the default behavior with regard to the next (checkbox) option, "Place replies in the folder of the message being replied to" Is that checked? If so, it will produce the results you see. <blockquote> I find this really irritating and completely unhelpful - ''what ''is the logic of showing a sent message in the Inbox and not in the Sent Folder!? </blockquote> That checkbox option to "Place replies in the folder of the message being replied to" is not really for the Inbox. It has greatest utility when you filter incoming messages into topical folders [I have a lot of them], and then you read the messages in those topical folders, and want to to keep the replies in those folders. It can save time and is a great productivity aid.

由 John Kaufmann 於 修改