搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No Sound in Firefox

  • 3 回覆
  • 2 有這個問題
  • 32 次檢視
  • 最近回覆由 solrage

more options

I was clicking on YouTube links on a forum and everything was working fine. Suddenly, I re-clicked on one of the links and... no sound. I've:

-Clicked on the other links that had just been working... no sound. -Tried Vimeo... no sound. -Tried Internet Explorer and files from my PC and I get sound. -I downloaded the Flashplayer for YouTube and tried in both Flash and HTML mode... no sound. -Tried clearing my cache and restarting... no sound.

When I play videos I can open the volume mixer, everything's unmuted, but there is no "green bar" that shows sound coming from Firefox. This makes absolutely no sense why it suddenly went from working to not working when I didn't change anything.

所有回覆 (3)

more options

OK, I found a very inconvenient work-around. Apparently, sound stops working whenever I click while a video is playing. It does it whether I skip forward or go back a page. I have to open Sound, switch my Default output, and then switch it back for the sound to come on again. It doesn't do this on Internet Explorer. Is there a sudden conflict between my mouse and Firefox sound?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Same problem in Safe Mode. I've downloaded Chrome and I'm not having this problem either, so it's definitely something with Firefox...