搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Link on Microsoft site opens in IE instead of Firefox (which IS default browser)

  • 7 回覆
  • 4 有這個問題
  • 39 次檢視
  • 最近回覆由 cor-el

more options

I recently updated from Win 8 to Win 10. Every time I click a link on a Microsoft site, the link opens in IE ("Edge") rather than Firefox.

I have ensured that Firefox is my default browser and have set it to check every time.

If I right click on the link, and choose "Open in new tab" then it opens in a new tab in Firefox, otherwise it launches IE and opens in there.

I tried to uninstall IE (I am mad at this happening) but dear Microsoft won't allow that.

I have scoured the Internet to no avail and I'm hoping that someone from Mozilla will have some insights. Pretty please! Thanks in advance, Jules

所有回覆 (7)

more options

IE is a part of Windows. Do Not remove it.

The problem may be the link itself. Links can be set to open new windows when selected. Or new links, or another program. Using the right click options can override that.

more options

Hi Fred,

Thanks for your response.

Just so you (and others) know - I am well versed in tech, and understand that IE is integrated in the OS (and that, without extreme measures for the average user, it cannot be removed. I know where not to tread.).

I copied the miscreant link from the MS page that was causing this behavior using right-click "Copy link...". Then I pasted it in a new tab in FF and it opened in FF. The link, when pasted, also opened in Chrome without jumping to IE. Hyperlinks open in FF by default in my system.

It is only since I installed Windows 10 that I've seen this behavior. I had been a little suspect that MS might be able to instruct the OS when you click a link on their own site from a non-IE browser that it launches the link in IE rather than the default browser. As if to "introduce" you to the great Edge browser :)

I'm going to do a little more testing, but this has happened more than three times now (on different machines running Windows 10).

Cheers, Jules

more options

Do the links that open in Edge have a specific file extension (i.e. not html) or are possibly send with a content-type that isn't text/html?

  • Tools > Page Info > General
more options

Open Windows Internet Explorer. Have it declared as the default browser. But turn off the option to check this when the browser opens (If you want).

Now do the same thing using Firefox.

more options

cor-el: no, it looks like a standard URL: http://answers.microsoft.com/en-us/page/gettingstarted - this link is on page http://answers.microsoft.com/en-us?auth=1.

more options

Fred - thought that was a brilliant suggestion that looked like it would work. Sadly, no. I tried it (with appropriate machine reboots in between to make sure the re-associations stuck). I am still being sent to IE against my will. :) Thanks for trying to help.

more options

I notice the Open in IE 1.5.0 extension in your System Detail list, so it is likely that this extension is causing your problem and you need to check its settings or disable the extension.