搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I disable gifs completely when image.animation_mode='none' has no effect whatsoever?

  • 12 回覆
  • 2 有這個問題
  • 1487 次檢視
  • 最近回覆由 cor-el

more options

I am really sick of gifs. They're distracting and useless. I want to disable them completely. I have tried image.animation_mode=none; this has no effect whatsoever. I've looked for extensions. None of them work. I'm really irritated by this. Can someone please help me to disable gifs completely?

thanks.

被選擇的解決方法

That preference works for me with GIFs and PNGs on Windows.

One possible way to investigate the format being used is the Page Info dialog's Media panel. You can open Page Info using either:

  • right-click a blank area of the and choose View Page Info > Media
  • (menu bar) Tools menu > Page Info > Media
  • click the padlock or globe icon to the left of the site address > More Information > Media
從原來的回覆中察看解決方案 👍 1

所有回覆 (12)

more options

image.animation_mode = none should work for animated GIF images.

Are you sure that it are GIF images and not an animation via other ways like a plugin (Flash) or JavaScript?

Can you post a link to s page where you see such an image?

more options

選擇的解決方法

That preference works for me with GIFs and PNGs on Windows.

One possible way to investigate the format being used is the Page Info dialog's Media panel. You can open Page Info using either:

  • right-click a blank area of the and choose View Page Info > Media
  • (menu bar) Tools menu > Page Info > Media
  • click the padlock or globe icon to the left of the site address > More Information > Media
more options

thanks for both replies. :)

i kept looking into this after i posted my question/problem. what i found was that image.animation_mode was actually doing its job; i went to a page loaded with gifs, and the animations were indeed paused when the page loaded. but the original page that prompted my post --- the gif is still running.

weird.

is there some super-gif that isn't affected by image.animation_mode? i've attached a screenshot that shows both the gif/animation in question. the animation was in a Twitter post in my Twitter feed. what's interesting, maybe, is that although the animation plays, regardless of image.animation_mode, on Twitter, it doesn't play on BoingBoing itself.

here's a link to the original, on BoingBoing: http://boingboing.net/2015/08/31/cockatoo-rocks-out-to-elvis.html

and here it is on Twitter: https://twitter.com/BoingBoing/status/638439574465839105

---

so my problem is *sort of* solved. image.animation_mode does appear to work so far as stopping normal gifs goes. but, this twitter thing is interesting ...

more options

annnd, okay, i looked at the page info/media, and it's an mp4, so that explains why image.animation_mode doesn't pause it.

more options

I have no idea why it says GIF on it. Maybe someone recorded an animated GIF to MP4?

<video src="https://pbs.twimg.com/tweet_video/CNwxaOiWwAAqj1O.mp4" data-media-id="638439573828321280" name="media" class="animated-gif" data-height="270" data-width="478" loop="" poster="https://pbs.twimg.com/tweet_video_thumb/CNwxaOiWwAAqj1O.png"> <source src="https://pbs.twimg.com/tweet_video/CNwxaOiWwAAqj1O.mp4" video-src="https://pbs.twimg.com/tweet_video/CNwxaOiWwAAqj1O.mp4" type="video/mp4" class="source-mp4"> </video>

At least there is a right-click > Pause option for the video player. Scrolling the page seems to trigger a script that starts it again. Maybe the menu should have a "hide" option.

more options

i know, right?

i wonder if this is something that Twitter does, or if it's something the user did. either way, a "hide" option would be awesome, or maybe an option to auto-pause mp4 animations rather than having them auto-play on page load?

more options

Firefox has a hidden option to prevent auto-playing of MP4s in the native video player at page load, in about:config: media.autoplay.enabled

The problem is, sites work around that by sending a Play command to the player when you scroll down to the video. There is going to be a change in Firefox 41 to try to deal with that. Until then, you could try the Flash Control extension:

https://addons.mozilla.org/firefox/addon/flash-control/

more options

i'm going to try the flash control extension. we'll see. :)

more options

amatasta said

i know, right? i wonder if this is something that Twitter does, or if it's something the user did. either way, a "hide" option would be awesome, or maybe an option to auto-pause mp4 animations rather than having them auto-play on page load?

It's something Vine did. And Giphy and probably others. They changed "gif" from a file format to a brand. What twitter does is a bait and switch, putting the letters "G" "I" and "F" on an mp4 container. I assume Twitter's position is that turning animation off by default constitutes stealing. I assume the reason Firefox settings for turning off animation basically don't work is because if they did, some corporate sponsor would drop them. Once "open source" means something other than "noncommercial" it may as well not mean anything.

What's changed in Firefox is that the "lego block" icon for plugins is no longer visible on the left end of the "wonder bar" (address bar). It's still on my IceCat, which is several versions behind Firefox and hopefully will never catch up...

由 n8chz 於 修改

more options

n8chz said

What's changed in Firefox is that the "lego block" icon for plugins is no longer visible on the left end of the "wonder bar" (address bar).

Could you make sure the plugin you want to control is set to "Ask to Activate" on the Add-ons page? That's how I have Flash set and it seems to working normally in Firefox 44 (screen shot attached).

But... if your Firefox can play MP4 natively without a plugin -- using the HTML5 video player, which varies depending on your OS -- then I don't think there's an icon for that. You could try the FlashControl extension, which also can stop auto-play through the HTML5 player, if that's the issue.

more options

I never see this "Lego Block" thing anymore either. Yes jscher, all settings have been changed and posting here is my last resort when Firefox simply will not do what it's been told to. The plugin run command is set to "Ask to activate".

I have two genuine questions, not challenges or complaints, just a need to understand choices being made that I can't seem to fathom (there are dozens upon dozens nonsensical changes I'd love to ask about, but I'll settle for two right now).

Q1: Please tell me why the simple and unobtrusive "ECSAPE" key was removed to pause gifs? I know it used to stop all requests, not just gifs, but why not fix it to control "image.animation_mode" or something else useful to us? I know...just get another plugin or add-on. Super.

Q2: Is Firefox working towards being unable to do anything in it's default state without add-ons? Is this the new vision? The past few months seem as if Firefox is meant to become just an empty shell for add-ons.

more options

Q1: You can look at this extension:


Bug 825486 – Escape no longer stops animated GIFs

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

由 cor-el 於 修改