搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesnt properly play flash on Lumosity correctly

  • 8 回覆
  • 7 有這個問題
  • 35 次檢視
  • 最近回覆由 SamssheepX

more options

Firefox is my default browser and I've been using it without issue for many years. Recently it has stopped playing the flash games on Lumosity properly. They previously worked without issue but are now jerky, skipping and missing frames making it impossible to use the browser for their site anymore. The site loads and plays fine on other browsers (IE&Chrome), and FF players other similar websites and flash games seemingly without issue. I waited a couple months hoping an update to the site, the flash player, or the browser would iron out this issue but it hasnt. Lumosity's site support has been less than helpful and basically consists of trying to get me to abandon FF in favor of chrome. I am a fairly knowledgeable computer user, and have tried a wide variety of fixes from various sources to no avail. So I'm hoping you can help me solve this issue finally.

I'm on a Vista system (for better or worse) with FF 37.0.1 (the issue has been happening since atleast V34. I have the following extensions: Adblock plus, Ghostery, HTTPS-Everywhere, NoScript, & I use CCleaner (I've tried solutions turning each of those off individually, or all at once with no improved results) All of my software, extensions, plugins, etc are all up to date and working fine.

If you have any questions or need further information please let me know. I'm hoping not to have to abandon Firefox. Thank you.

所有回覆 (8)

more options

Crashes or other problems with certain multimedia content in Firefox (such as YouTube videos and Flash animations or games) can often be resolved by performing the steps in these Knowledge Base articles:

Please tell us if this helped!

more options

Thank you for your quick reply. As I stated all my software and plug-ins are up to date and running fine. And I did eventually try and disabling of hardware acceleration and/or protected mode, to no avail. If you have any other ideas or suggestions please let me know. (And again it seems to be site specific, I play plenty of other flash games and content without any issues at all). TY.

more options

What site are you having problems? Please give us a link to check.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

http://kb.mozillazine.org/Error_loading_websites

https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently

more options

My copy/paste into the reply field resulted in odd formatting.

由 SamssheepX 於 修改

more options

Thank you for your reply. I use CCleaner to automatically flush my cache, cookies and temp files; but I did it manually (as per instructions) just in case, but with no change.

The problem persists while running FF in safe mode. I have turned of hardware acceleration in the FF settings, in the Flash settings (by right-clicking in the flash window itself). Neither one of those options had any effect either individually or together whether in safe mode or not.

If you want to check the issue yourselves; go to lumosity.com (you'll have to sign up, but you can throw it any garbage info and email). It will give you a 3 game “fit-test”; game 2 “train of thought” shows the issue quite well. Whenever you click the button to change the direction of a switch; the entire game freezes momentarily. The effect gets more and more pronounced the more trains are on the screen, or if you hit many buttons in quick succession. If you refresh the page before the game ends it will let you replay it (so you dont have to keep re-signing up to get to it. What I did in between settings changes).

Firefox is running the latest version 38.0.5, all my add-ons and plug-ins are updated and current. These should not be large or complex flash games; and I've played many other games on other sites without any issue. Also the site and games play fine on the exact same laptop through IE (which has been my work-around for now). Unfortunately I first began noticing the problem shortly after both FF and lumosity did an update (and I updated Flash when I updated FF) So I cant pin down where the problem “should” lie, and have so far been unable to get to the root of it. Lumosity's response (after a few of the cookie and other simple ideas); was to switch to Chrome. I would prefer not to do that, but if I cant get it working on FF I may have to jump ship.

Thank you again for any help you might be able to provide. I'm still hopeful for an answer.

由 SamssheepX 於 修改

more options

Note, please do not put a 'space' at the beginning of a sentence. That results in special formatting that you see above. And it's hard to read.

more options

Looks much better now, thank you.

more options

Thank you for your reply. I use CCleaner to automatically flush my cache, cookies and temp files; but I did it manually (as per instructions) just in case, but with no change.

The problem persists while running FF in safe mode. I have turned of hardware acceleration in the FF settings, in the Flash settings (by right-clicking in the flash window itself). Neither one of those options had any effect either individually or together whether in safe mode or not.

If you want to check the issue yourselves; go to lumosity.com (you'll have to sign up, but you can throw it any garbage info and email). It will give you a 3 game “fit-test”; game 2 “train of thought” shows the issue quite well. Whenever you click the button to change the direction of a switch; the entire game freezes momentarily. The effect gets more and more pronounced the more trains are on the screen, or if you hit many buttons in quick succession. If you refresh the page before the game ends it will let you replay it (so you dont have to keep re-signing up to get to it. What I did in between settings changes).

Firefox is running the latest version 38.0.5, all my add-ons and plug-ins are updated and current. These should not be large or complex flash games; and I've played many other games on other sites without any issue. Also the site and games play fine on the exact same laptop through IE (which has been my work-around for now). Unfortunately I first began noticing the problem shortly after both FF and lumosity did an update (and I updated Flash when I updated FF) So I cant pin down where the problem “should” lie, and have so far been unable to get to the root of it. Lumosity's response (after a few of the cookie and other simple ideas); was to switch to Chrome. I would prefer not to do that, but if I cant get it working on FF I may have to jump ship.

Thank you again for any help you might be able to provide. I'm still hopeful for an answer.