X
點擊此處開啟此網站的行動版。

技術支援討論區

How can I get my Bookmarks that ran across the top of my computer screen back?

已張貼

They are still in my Bookmarks tap, but the space across the top of the page is blank now. Thanks for your help!

They are still in my Bookmarks tap, but the space across the top of the page is blank now. Thanks for your help!

被選擇的解決方法

Hi Radicalreels, I'm not aware of any resolution-related limit on attachments on this forum, only file size limits. Since you only need the top bar, perhaps you can get under the limit by omitting the rest of the screen.

Did you ever try using the "Restore Defaults" button in the Customize dialog that I mentioned twice before?

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Facebook Video Calling Plugin
  • GEPlugin
  • Version 5.38.6.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nitro PDF Plug-in for Firefox and Chrome
  • npapicomadapter
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Download Plugin
  • This plug-in enables downloading of HTML5 videos
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 15.0 r0
  • 5.1.31010.0
  • VLC media player Web Plugin 2.1.3

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

更多資訊

CoryMH 229 個解決方法 1076 個答案

Hello,

Check your customization screen to make sure that "Bookmark Toolbar Items" is on your Bookmark Toolbar:

Let us know if that fixes it for you.

Hello, Check your customization screen to make sure that "Bookmark Toolbar Items" is on your Bookmark Toolbar: * Either enter '''about:customizing''' or go to Menu [[Image: New Fx Menu]] > Customize * If "Bookmark Toolbar Items" is not on your toolbar, click and drag it back there * Exit the customization screen by closing the tab or "Exit Customize" on near the bottom right of the page. * See the articles [[Bookmarks Toolbar - Display your favorite websites at the top of the Firefox window]] and [[Customize Firefox controls, buttons and toolbars]] for more information. Let us know if that fixes it for you.
eb88 0 個解決方法 8 個答案

有幫助的回覆

My "Bookmarks" is only a folder (imported from Chrome, I guess) in the ribbon across the top of screen. How do I get those bookmarks to display across the screen? Above answer doesn't do it. I've got it set up on my other laptop, but can't remember how I did it.

Any help? thanks. I'm trying not to return to Chrome...

My "Bookmarks" is only a folder (imported from Chrome, I guess) in the ribbon across the top of screen. How do I get those bookmarks to display across the screen? Above answer doesn't do it. I've got it set up on my other laptop, but can't remember how I did it. Any help? thanks. I'm trying not to return to Chrome...

提出問題者

I still never got it to work. No, there wasn't a "Bookmark Toolbar Items" in there... so I drag it from where? I never had this problem and I can't imagine why it all disappeared in the first place!

The toolbar is in my bookmarks, but I have to go into that every time to go anywhere now. This is what I like best about Firefox, without it, I'll finally try Crome.

Thank you... RAD

I still never got it to work. No, there wasn't a "Bookmark Toolbar Items" in there... so I drag it from where? I never had this problem and I can't imagine why it all disappeared in the first place! The toolbar is in my bookmarks, but I have to go into that every time to go anywhere now. This is what I like best about Firefox, without it, I'll finally try Crome. Thank you... RAD
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi Radicalreels, if Bookmarks Toolbar Items doesn't show up on any existing toolbar or in the Customize dialog, you might need to reset your toolbars. There is a button for that toward the bottom of the Customize dialog ("Restore Defaults").


If you have any add-ons which modify how your bookmarks work or how your toolbars are laid out, you may need to check them for updates. You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, above the list on the right side, look for the "gear" button and click that, then Check for Updates.

Hi Radicalreels, if Bookmarks Toolbar Items doesn't show up on any existing toolbar or in the Customize dialog, you might need to reset your toolbars. There is a button for that toward the bottom of the Customize dialog ("Restore Defaults"). ---- If you have any add-ons which modify how your bookmarks work or how your toolbars are laid out, you may need to check them for updates. You can do that on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then, above the list on the right side, look for the "gear" button and click that, then Check for Updates.
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi eb88, you can move imported bookmarks and bookmark folders directly to the "top level" of the bar using the Library dialog (Windows: Ctrl+Shift+b).

If you are concerned about possibly deleting or misplacing bookmarks in this process, you can make a backup first. This article has the procedure: Restore bookmarks from backup or move them to another computer.

Hi eb88, you can move imported bookmarks and bookmark folders directly to the "top level" of the bar using the Library dialog (Windows: Ctrl+Shift+b). If you are concerned about possibly deleting or misplacing bookmarks in this process, you can make a backup first. This article has the procedure: [[Restore bookmarks from backup or move them to another computer]].
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi eb88, in case you meant that the Bookmarks Toolbar isn't displayed, or that the import put the items on the menu instead of the Bookmarks Toolbar:

  • To display the Bookmarks Toolbar, you can use any of these:
    • right-click a blank area of the tab bar, or the "+" button on the tab bar
    • View menu > Toolbars > Bookmarks Toolbar
    • Customize feature > Show/Hide Toolbars
  • To move items from the Bookmarks Menu to the Bookmarks Toolbar, you can use the Library dialog as noted above.
Hi eb88, in case you meant that the Bookmarks Toolbar isn't displayed, or that the import put the items on the menu instead of the Bookmarks Toolbar: * To display the Bookmarks Toolbar, you can use any of these: ** right-click a blank area of the tab bar, or the "+" button on the tab bar ** View menu > Toolbars > Bookmarks Toolbar ** Customize feature > Show/Hide Toolbars * To move items from the Bookmarks Menu to the Bookmarks Toolbar, you can use the Library dialog as noted above.
eb88 0 個解決方法 8 個答案

Thanks--but yes, what I meant was on the bar where my bookmarks should normally display, all I get is the folder saying "Bookmarks Bar" -- which then becomes a dropdown for the bookmarks I *want* instead to ribbon across the entire horizontal bar (which has only that "Bookmarks Bar" folder). I have done this successfully on my other laptop, in my switch from Chrome to Firefox, but I don't remember how I did it, and after 2 hours of trying to figure this out, I'm thinking of heading back to the evil Chrome. (Not to mention my gmail fonts don't work in Firefox, but do work in Chrome.)

Thanks if you have any more guidance!

Thanks--but yes, what I meant was on the bar where my bookmarks should normally display, all I get is the folder saying "Bookmarks Bar" -- which then becomes a dropdown for the bookmarks I *want* instead to ribbon across the entire horizontal bar (which has only that "Bookmarks Bar" folder). I have done this successfully on my other laptop, in my switch from Chrome to Firefox, but I don't remember how I did it, and after 2 hours of trying to figure this out, I'm thinking of heading back to the evil Chrome. (Not to mention my gmail fonts don't work in Firefox, but do work in Chrome.) Thanks if you have any more guidance!
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi eb88, you should be able -- using the Library dialog -- to select the entire contents of the "Bookmarks Bar" folder and drag it up or left to Bookmarks Toolbar.

Hi eb88, you should be able -- using the Library dialog -- to select the entire contents of the "Bookmarks Bar" folder and drag it up or left to Bookmarks Toolbar.
eb88 0 個解決方法 8 個答案

Sorry--but can you walk me through this? And BTW, using Mac.

Never mind. THank you! I am not sure what worked, but I tried dragging that "bookmarks" folder into wherever it would go--and the "unsorted" bookmarks looks like it worked. Or maybe it was some other bit of magic. But there is my bookmark ribbon!

And suddenly, in the midst of writing a gmail, my Mac froze, and then when it unfroze, the correct gmail font started working.

Must be the snowstorm. thanks again-- eb88

Sorry--but can you walk me through this? And BTW, using Mac. Never mind. THank you! I am not sure what worked, but I tried dragging that "bookmarks" folder into wherever it would go--and the "unsorted" bookmarks looks like it worked. Or maybe it was some other bit of magic. But there is my bookmark ribbon! And suddenly, in the midst of writing a gmail, my Mac froze, and then when it unfroze, the correct gmail font started working. Must be the snowstorm. thanks again-- eb88

由 eb88 於 修改

提出問題者

I'll mark this as solved, even though it wasn't, at least for me! Strange someone can come along and take over on my issue...

Time to try CROME!

I'll mark this as solved, even though it wasn't, at least for me! Strange someone can come along and take over on my issue... Time to try CROME!
eb88 0 個解決方法 8 個答案

Hey, Radicalreels, this is too embarrassing to admit (but I'll do it anyway) -- turns out my bookmarks problem WASN'T solved after all. I had simply (unknowingly) switched over to Chrome and viola, there were my lovely bookmarks. So yes, I gave up and went back to the evil empire. If you get a solution, let me know. eb88

Hey, Radicalreels, this is too embarrassing to admit (but I'll do it anyway) -- turns out my bookmarks problem WASN'T solved after all. I had simply (unknowingly) switched over to Chrome and viola, there were my lovely bookmarks. So yes, I gave up and went back to the evil empire. If you get a solution, let me know. eb88

提出問題者

Having Bookmarks across the top is the main reason I liked Firefox the best! Been a user since 2008... Why did my Bookmarks vanish and HOW to get them back seems to be something no one can answer here!

Maybe a You Tube video will be featured on this issue soon!

Having Bookmarks across the top is the main reason I liked Firefox the best! Been a user since 2008... Why did my Bookmarks vanish and HOW to get them back seems to be something no one can answer here! Maybe a You Tube video will be featured on this issue soon!
cor-el
  • Top 10 Contributor
  • Moderator
17565 個解決方法 158873 個答案

Do you see the "Bookmarks Toolbar items" on the Bookmarks Toolbar when you are in customize mode?

Make sure that toolbars like the "Bookmarks Toolbar" are visible.

  • "3-bar" Firefox menu button > Customize > Show/Hide Toolbars
  • View > Toolbars
    Tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Open the Customize window and set which toolbar items to display.

  • "3-bar" Firefox menu button > Customize
  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the Customize palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the Customize palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button to restore the default toolbar setup

If "Bookmarks Toolbar items" on the Bookmarks Toolbar and you still do not see bookmarks and there are bookmarks present when you check that in the Bookmarks Manager (Library) then it is possible that there is a problem with the places.sqlite file.

You can check for problems with the places.sqlite database file in the Firefox profile folder.

Do you see the "Bookmarks Toolbar items" on the Bookmarks Toolbar when you are in customize mode? Make sure that toolbars like the "Bookmarks Toolbar" are visible. *"3-bar" Firefox menu button > Customize > Show/Hide Toolbars *View > Toolbars<br>Tap the Alt key or press F10 to show the Menu Bar *Right-click empty toolbar area Open the Customize window and set which toolbar items to display. *"3-bar" Firefox menu button > Customize *check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar *if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the Customize palette into the Customize window to the Bookmarks Toolbar *if missing items are in the Customize palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the Customize palette then click the Restore Defaults button to restore the default toolbar setup *https://support.mozilla.org/kb/customize-firefox-controls-buttons-and-toolbars If "Bookmarks Toolbar items" on the Bookmarks Toolbar and you still do not see bookmarks and there are bookmarks present when you check that in the Bookmarks Manager (Library) then it is possible that there is a problem with the places.sqlite file. You can check for problems with the <b>places.sqlite</b> database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Maybe I don't understand what you guys mean by "across the top." The standard layout of the toolbar area, from top to bottom, is:

  • Title bar - optional, turned off by default
  • Menu bar - optional, turned off by default
  • Tab bar
  • Navigation toolbar
  • Bookmarks toolbar - optional (I don't recall the default)
  • Toolbars created by add-ons, if any

You should be able to turn the Menu Bar, Bookmarks Toolbar, and add-on toolbars using the short menu that appears when you right-click the tab bar or the "+" button on the tab bar. (Or the several other ways that cor-el mentioned.)

Are we talking about the same thing??

Maybe I don't understand what you guys mean by "across the top." The standard layout of the toolbar area, from top to bottom, is: * Title bar - optional, turned off by default * Menu bar - optional, turned off by default * Tab bar * Navigation toolbar * Bookmarks toolbar - optional (I don't recall the default) * ''Toolbars created by add-ons, if any'' You should be able to turn the Menu Bar, Bookmarks Toolbar, and add-on toolbars using the short menu that appears when you right-click the tab bar or the "+" button on the tab bar. (Or the several other ways that cor-el mentioned.) Are we talking about the same thing??
eb88 0 個解決方法 8 個答案

Thank you for your persistence, jscher & cor-el! Yes, jscher, we're talking about the same things, as far as I can tell. My problem is, in one of my Macbooks, the "Bookmarks Toolbar" shows only one folder, flush left, now entitled "From Google Chrome," which I have to access via dropdown, rather than having the entire thing open across the ribbon of bookmarks. (Ribbon just beneath the navigation toolbar.) I don't understand why one of my Macs has it (Firefox 35.0.1), but my other (Firefox 36.0) cannot. (Both Macs = Yosemite, latest) On this latter Mac, (w/Firefox 36.0), my View > toolbars offers two things (plus customize): "Bookmarks toolbar" and "TV-Fox." Of course I've turned on "Bookmarks toolbar" -- but that simply gives me the folder mentioned above, "From Google Chrome."

It seems to me I figured this out on my other Mac, but honestly, I don't want to spend the time to do it again on this one. I'm guessing it's some little, easy thing, but for some reason it's eluding us for now. (Is this related to using a Mac? Maybe I found my answer before on a Mac forum?) I don't know. I wish I were smarter and had a better memory. Oh well.

Thanks again. I'm okay with Chrome, though I would rather support the Firefox community.

cheers,

Thank you for your persistence, jscher & cor-el! Yes, jscher, we're talking about the same things, as far as I can tell. My problem is, in one of my Macbooks, the "Bookmarks Toolbar" shows only one folder, flush left, now entitled "From Google Chrome," which I have to access via dropdown, rather than having the entire thing open across the ribbon of bookmarks. (Ribbon just beneath the navigation toolbar.) I don't understand why one of my Macs has it (Firefox 35.0.1), but my other (Firefox 36.0) cannot. (Both Macs = Yosemite, latest) On this latter Mac, (w/Firefox 36.0), my View > toolbars offers two things (plus customize): "Bookmarks toolbar" and "TV-Fox." Of course I've turned on "Bookmarks toolbar" -- but that simply gives me the folder mentioned above, "From Google Chrome." It seems to me I figured this out on my other Mac, but honestly, I don't want to spend the time to do it again on this one. I'm guessing it's some little, easy thing, but for some reason it's eluding us for now. (Is this related to using a Mac? Maybe I found my answer before on a Mac forum?) I don't know. I wish I were smarter and had a better memory. Oh well. Thanks again. I'm okay with Chrome, though I would rather support the Firefox community. cheers,
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi eb88, you should be able to drag the items in the "From Google Chrome" folder to the bar itself using the Library dialog (Mac: Command+Shift+b) just the way you would move any other kind of bookmarks around.

Hi eb88, you should be able to drag the items in the "From Google Chrome" folder to the bar itself using the Library dialog (Mac: Command+Shift+b) just the way you would move any other kind of bookmarks around.
cor-el
  • Top 10 Contributor
  • Moderator
17565 個解決方法 158873 個答案

Bookmarks that you want to appear on the Bookmarks Toolbar need to be located in the Bookmarks Toolbar folder. So you can open the Bookmarks Manager (Library) and copy or move bookmarks that are in another folder to the Bookmarks Toolbar folder.

Bookmarks that you want to appear on the Bookmarks Toolbar need to be located in the Bookmarks Toolbar folder. So you can open the Bookmarks Manager (Library) and copy or move bookmarks that are in another folder to the Bookmarks Toolbar folder. *https://support.mozilla.org/kb/how-do-i-use-bookmarks

提出問題者

The pink xxxxxxxxxxxxxxxxxxxxxxxxxxxx are where the tool bar always was. When I follow the steps, when I right click, the place where the pink xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx are goes away completely! This is not working....

The pink xxxxxxxxxxxxxxxxxxxxxxxxxxxx are where the tool bar always was. When I follow the steps, when I right click, the place where the pink xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx are goes away completely! This is not working....
jscher2000
  • Top 10 Contributor
8783 個解決方法 71823 個答案

Hi Radicalreels, if the bar with the pink x's appears and disappears when you turn Bookmarks Toolbar on and off (a checkmark appears/disappears on the right-click menu), then go ahead and leave it on.

It's hard to tell, but at the blue blobs at the left end of that bar some kind of buttons? Are they at all related to your bookmarks or are they something else?

I'm not sure whether you tried "Restore Defaults" to reset the toolbars; that's at the bottom of the Customize dialog.

Hi Radicalreels, if the bar with the pink x's appears and disappears when you turn Bookmarks Toolbar on and off (a checkmark appears/disappears on the right-click menu), then go ahead and leave it on. It's hard to tell, but at the blue blobs at the left end of that bar some kind of buttons? Are they at all related to your bookmarks or are they something else? I'm not sure whether you tried "Restore Defaults" to reset the toolbars; that's at the bottom of the Customize dialog.
cor-el
  • Top 10 Contributor
  • Moderator
17565 個解決方法 158873 個答案

Are there any bookmarks in the Bookmarks Toolbar folder if you check that in the Bookmarks Manager (Library)?

Are there any bookmarks in the Bookmarks Toolbar folder if you check that in the Bookmarks Manager (Library)?