X
點擊此處開啟此網站的行動版。

技術支援討論區

Release 29 and 29.1 do not size correctly on a PC screen.

已張貼

With the 29.0 release (and 29.1 after its release) the webpages do not cover the entire screen as it did in all previous releases. In order to complete the screen I have to hit F11once to get the screen to cover and then again to go to full screen.

With the 29.0 release (and 29.1 after its release) the webpages do not cover the entire screen as it did in all previous releases. In order to complete the screen I have to hit F11once to get the screen to cover and then again to go to full screen.

被選擇的解決方法

I can't think of a good reason for that... sometimes the file that Firefox uses to store toolbar layout and the sizes of various windows can become corrupted. A standard workaround is to rename the file and have Firefox regenerate it. Here's how.

Open your current Firefox settings (AKA Firefox profile) folder using either of these:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

Then in the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, which is either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Note: you usually can restore your session from the History menu after restarting Firefox, but not private windows, and not if you have Firefox set to clear all your history at shutdown.

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Start Firefox back up again. Any improvement in the window sizing?

從原來的回覆中察看解決方案 2

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 13.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.10
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • 5.1.30214.0
  • Citrix Online App Detector Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5.146
  • GEPlugin
  • Unity Player 4.2.0f4
  • Photodex Presenter Plugin 5,00,0,3310
  • NPWLPG
  • Office Live Update v1.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • RealArcade_NPAPI_Plugin
  • Citrix ICA Client Plugin (Win32)
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

應用程式

  • Firefox 29.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.0; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/29.0.1/WINNT/en-US/

擴充套件

  • Capture & Print 0.1.9.2 ({146f1820-2b0d-49ef-acbf-d85a6986e10c})
  • Clip to OneNote (Legacy Edition) 4.0.rev658 (jid0-e0l1gzjOmbUL1N6n3j8dBSBMcGE@jetpack)
  • Download Status Bar 9.8.8 ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • Email Link button 0.9 ({2A638E17-DE1D-48d3-A4B7-39E9670FF77A})
  • Google Translator for Firefox 2.1.0.3 (translator@zoli.bod)
  • Map This 0.3.1 ({05f6a7ea-896b-11da-8bde-f66bad1e3f3a})
  • New Tab Homepage 0.4.3 ({66E978CD-981F-47DF-AC42-E3CF417C1467})
  • Print/Print Preview 0.9 ({19EB90DC-A456-458b-8AAC-616D91AAFCE1})
  • RoboForm Toolbar for Firefox 7.9.6.7 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Google Gears 0.5.36.0 ({000a9d1c-beef-4f90-9363-039d445309b8}) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 6-27-2008
  • driverDate2:
  • driverVersion: 7.15.10.1511
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'7.1500.1000.1666']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'7.1500.1000.1666']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.newtab.url: http://start.sweetpacks.com/?barid={8DB46E18-CA1E-11E2-A0DF-005056C00008}&src=97&crg=3.5000006.10045&st=23
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 6
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807
  • browser.startup.homepage: http://my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20140506152807
  • browser.startup.homepage_override.mstone: 29.0.1
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0.1
  • font.default.x-western: sans-serif
  • font.internaluseonly.changed: False
  • general.useragent.extra.brc:
  • general.useragent.extra.microsoftdotnet: (.NET CLR 2.0.50727; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1400764420
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 103131
  • places.last_vacuum: 1318269286
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npdeployjava: 2
  • plugin.state.npdlplugin: 0
  • plugin.state.npican: 2
  • plugin.state.nppdf: 2
  • plugin.state.nppl: 0
  • plugin.state.nprndlchromebrowserrecordext: 0
  • plugin.state.nprndlhtml5videoshim: 0
  • plugin.state.nprndlpepperflashvideoshim: 0
  • plugin.state.nprpplugin: 0
  • plugin.state.npunity3d: 2
  • plugin.state.npvbp: 0
  • plugin.state.npveetle: 0
  • plugin.state.npvlc: 0
  • privacy.clearOnShutdown.cache: False
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.csp.enable: False
  • security.OCSP.enabled: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1399832739

其他

  • User JS: 是
  • 輔助功能: 是
cor-el
  • Top 10 Contributor
  • Moderator
17865 個解決方法 161655 個答案

You may have zoomed the page(s) by accident.
Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

You can check for problems caused by a corrupted localstore.rdf file.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

You may have zoomed the page(s) by accident.<br>Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages You can check for problems caused by a corrupted localstore.rdf file. *http://kb.mozillazine.org/Corrupt_localstore.rdf Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot.
jscher2000
  • Top 10 Contributor
8959 個解決方法 73404 個答案

選擇的解決方法

I can't think of a good reason for that... sometimes the file that Firefox uses to store toolbar layout and the sizes of various windows can become corrupted. A standard workaround is to rename the file and have Firefox regenerate it. Here's how.

Open your current Firefox settings (AKA Firefox profile) folder using either of these:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

Then in the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, which is either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Note: you usually can restore your session from the History menu after restarting Firefox, but not private windows, and not if you have Firefox set to clear all your history at shutdown.

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Start Firefox back up again. Any improvement in the window sizing?

I can't think of a good reason for that... sometimes the file that Firefox uses to store toolbar layout and the sizes of various windows can become corrupted. A standard workaround is to rename the file and have Firefox regenerate it. Here's how. Open your current Firefox settings (AKA Firefox profile) folder using either of these: * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information Then in the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, which is either: * "3-bar" menu button > "power" button * File menu > Exit ''Note: you usually can restore your session from the History menu after restarting Firefox, but not private windows, and not if you have Firefox set to clear all your history at shutdown.'' Pause while Firefox finishes its cleanup, then rename '''localstore.rdf''' to something like localstore.old Start Firefox back up again. Any improvement in the window sizing?

提出問題者

That worked. Thank you.

That worked. Thank you.

提出問題者

Same problem when v32.0 installed. Tried the same solution and that does not work. Ideas?

Same problem when v32.0 installed. Tried the same solution and that does not work. Ideas?
jscher2000
  • Top 10 Contributor
8959 個解決方法 73404 個答案

Do you ever connect a second monitor, or can you think of any other reason Firefox might not be able to correctly read your screen dimensions?

Do you ever connect a second monitor, or can you think of any other reason Firefox might not be able to correctly read your screen dimensions?
cor-el
  • Top 10 Contributor
  • Moderator
17865 個解決方法 161655 個答案

Try to set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 If necessary adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly.

See also:

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

You can look at this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

Try to set the <b>layout.css.devPixelsPerPx</b> pref on the <b>about:config</b> page to 1.0 If necessary adjust layout.css.devPixelsPerPx starting from 1.0 in 0.1 or 0.05 steps (1.1 or 0.9) to make icons show correctly. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/kb/forum-response-Zoom-feature-on-Firefox-22 Use an extension to adjust the text size in the user interface and the page zoom in the browser window. You can look at this extension to adjust the font size for the user interface. *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/

提出問題者

Thank you for answering. The only change from acting correctly to not acting correctly was the installation of v32.0. The second monitor stayed the same before and after.

Thank you for answering. The only change from acting correctly to not acting correctly was the installation of v32.0. The second monitor stayed the same before and after.

提出問題者

Thank you for answering, but your solutions had no effect. I will add an image to show what is happening.

Thank you for answering, but your solutions had no effect. I will add an image to show what is happening.

提出問題者

Sorry for the quality of the picture but I did not have time to work out the second monitor on a Print Screen.

The issue is to the far right. You can see where the FF screen ends. to the right of that is my desktop.

Sorry for the quality of the picture but I did not have time to work out the second monitor on a Print Screen. The issue is to the far right. You can see where the FF screen ends. to the right of that is my desktop.
cor-el
  • Top 10 Contributor
  • Moderator
17865 個解決方法 161655 個答案

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

提出問題者

cor-el, that did not work either. I am using Vista 64 so IE is not an option for me, and I do not like Chrome so I need to solve this. Do you know what has to be reset if I reset FF back to default? Do I have to re-download all plugins?

Thanks.

cor-el, that did not work either. I am using Vista 64 so IE is not an option for me, and I do not like Chrome so I need to solve this. Do you know what has to be reset if I reset FF back to default? Do I have to re-download all plugins? Thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17865 個解決方法 161655 個答案

You can try a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


You can try a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all.html If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

提出問題者

cor-el,

Tried everything and no joy. Since this has happened in the past after updates I have to assume that it has something to do with the updated version of FF and my Windows Vista.

Thank you for your help.

cor-el, Tried everything and no joy. Since this has happened in the past after updates I have to assume that it has something to do with the updated version of FF and my Windows Vista. Thank you for your help.