為什麽 Java,Silverlight,Adobe Acrobat 和其他外掛程式不再工作了?

自 2017/3/7 公佈的 Firefox 52 起,Firefox 將不再支援 Adobe Flash 以外的 NPAPI 外掛程式。有些外掛程式像是 Java、Microsoft Silverlight 和 Adobe Acrobat,雖然已安裝在您的電腦,但 Firefox 不會將其載入。請參考這份相容性文件以取得更多資訊。

在過去幾年裡,Firefox 已經實做了各種 Web API,使得網站可以在沒有外掛程式的情況下達到相同的效果,因此您很可能不會注意到瀏覽體驗有任何變化。

Firefox 為什麼要這麼做?

網際網路上充滿了非靜態網頁,像是影片、音樂和遊戲。NPAPI 外掛程式,尤其是 Flash,協助構成了這些互動式網頁。但是它們同時也拖慢了瀏覽器速度、降低了安全性,還更有可能導致瀏覽器發生錯誤。

過去幾年,Firefox 已經努力為這些外掛程式建立替代品,它們被稱為 Web API。Web API 被設計來取代這些外掛程式的功能,而不會影響您的網路安全性,穩定性和效能。

在以前,這些 Web API 還沒有準備好,所以 Firefox 讓使用者手動載入外掛程式

如今,它們已經準備好了。許多網站已經採用了它們,你可以拋棄舊的、不安全的外掛程式而繼續享受幾乎你所有喜愛的網站。Firefox 也加入了其他瀏覽器的行列,例如 Google Chrome 和 Microsoft Edge,一起停止對 NPAPI 外掛程式的支援。

我有些問題!

為了避免您尚未準備好進行此次切換,Firefox 52 的 ESR (Extended Support Release) 版本將繼續支援這些外掛程式到 2018 年年初。點選這裡下載 Firefox ESR。

注意:Windows 64 位元版本的 Firefox 52 ESR 僅支援 Adobe Flash 和 Microsoft Silverlight。如果您還需要對 Java 或其他已安裝的外掛程式的支援,請下載 32 位元版本。

在預設情況下,Firefox 52 ESR 會和其他 Firefox 版本共用相同的使用者設定檔。在使用 Firefox 55 或以後的版本後,又安裝 Firefox 52 ESR,可能導致錯誤發生,像是出現錯誤訊息、瀏覽器部分損毀,或在某些網站產生問題。您應該建立一個新的使用者設定檔讓 Firefox 52 ESR 使用,或在安裝後重設 Firefox

這篇文章有幫助嗎? 請稍候...

這些人們幫忙撰寫了這篇文章: Bor, Rayista, Coin。您也可以幫忙 - 看看要怎麼作