Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

Search engine directs you to a website with the keyword but not to Google search results

  • 2 àwọn èsì
  • 1 ní ìṣòro yìí
  • 16 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ cor-el

more options

Hi,

This happened today when I wanted to default my search engine to Google from previous Yahoo in the address bar. When I type in a keyword, it directs me to a website with the keyword as the URL. For example, if I type in a keyword "earth", it will direct me to "www.earth.com". However, my search bar is Google and it does give me regular search results.

I would be grateful for any help with the about:config page, since I believe that's where I must have messed up. I read some of the articles by Mozilla, but haven't yet come to a solution.

Thanks, Spruha

Hi, This happened today when I wanted to default my search engine to Google from previous Yahoo in the address bar. When I type in a keyword, it directs me to a website with the keyword as the URL. For example, if I type in a keyword "earth", it will direct me to "www.earth.com". However, my search bar is Google and it does give me regular search results. I would be grateful for any help with the about:config page, since I believe that's where I must have messed up. I read some of the articles by Mozilla, but haven't yet come to a solution. Thanks, Spruha

All Replies (2)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Try to reset some preferences to the default with the SearchReset extension:

You can look at this updated version of SearchReset that resets the search engine used on the about:home page:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: