Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

How do I disable not just LINK prefetching, but DNS prefetching in FF7/FF8?

  • 1 èsì
  • 1 ní ìṣòro yìí
  • 94 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ justthisguyyaknow

more options

I have a local (intranet) file with hundreds of links to various sites, which is my FireFox home page.

I don't wish all of these links' IP addresses to be requested constantly, when I will be clicking on approximately one at any point in time.

Even with [link] prefetching disabled in about:config, the [DNS] requests are still prefetching. There was a way, I believe, to disable this in the FF3 or so configuration, but I can't find it in newer versions.

I have a local (intranet) file with hundreds of links to various sites, which is my FireFox home page. I don't wish all of these links' IP addresses to be requested constantly, when I will be clicking on approximately one at any point in time. Even with [link] prefetching disabled in about:config, the [DNS] requests are still prefetching. There was a way, I believe, to disable this in the FF3 or so configuration, but I can't find it in newer versions.

Ọ̀nà àbáyọ tí a yàn

Problem solved! I was looking in about:config for the name "network.dns.disablePrefetch", so I could set it to True. I couldn't find this in the config anymore, so I asked the question.

Turns out, even FF8 will still obey this setting, though the actual entry must be explicitly entered. To do this, if anyone's needing such info:

  1. Open Firefox, and enter About:config into the address bar.
  2. Right-click on the list of entries; new >> boolean.
  3. The name for the boolean: "network.dns.disablePrefetch" (exactly as shown, but not including quotes).
  4. The value: True
Ka ìdáhùn ni ìṣètò kíkà 👍 0

All Replies (1)

more options

Ọ̀nà àbáyọ Tí a Yàn

Problem solved! I was looking in about:config for the name "network.dns.disablePrefetch", so I could set it to True. I couldn't find this in the config anymore, so I asked the question.

Turns out, even FF8 will still obey this setting, though the actual entry must be explicitly entered. To do this, if anyone's needing such info:

  1. Open Firefox, and enter About:config into the address bar.
  2. Right-click on the list of entries; new >> boolean.
  3. The name for the boolean: "network.dns.disablePrefetch" (exactly as shown, but not including quotes).
  4. The value: True