Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After updating MacOS to v. 13.6 using a PIA VPN Firefox will not connect to the internet

  • Amul benn tontu
  • 0 am na jafe-jafe bii
  • 7 views
more options

Using Firefox 17.0.1 on MacOS Ventura 13.6 on my 2017 iMac I am unable to connect to the internet while using Private Internet Access (PIA) VPN. All was working normally until I installed MacOS Ventura 13.6 yesterday. The VPN works normally when using Chrome or Safari. I have tried changing my network proxy setting without any luck. The default setting is "Use System Settings", using No Proxy or Auto Detect Proxy doesn't help. I don't see a switch for Enable DNS over HTTPS. All works fine when the VPN is disabled. I tried deleting the VPN a couple of times then reinstalling but that didn't help.

What am I missing here? I have used this VPN for years without any issues & it worked on Firefox until I installed MacOS 13.6...... using 13.5 I had no problems. Any suggestions or thoughts would be appreciated.

Thanks...... Brad

Using Firefox 17.0.1 on MacOS Ventura 13.6 on my 2017 iMac I am unable to connect to the internet while using Private Internet Access (PIA) VPN. All was working normally until I installed MacOS Ventura 13.6 yesterday. The VPN works normally when using Chrome or Safari. I have tried changing my network proxy setting without any luck. The default setting is "Use System Settings", using No Proxy or Auto Detect Proxy doesn't help. I don't see a switch for Enable DNS over HTTPS. All works fine when the VPN is disabled. I tried deleting the VPN a couple of times then reinstalling but that didn't help. What am I missing here? I have used this VPN for years without any issues & it worked on Firefox until I installed MacOS 13.6...... using 13.5 I had no problems. Any suggestions or thoughts would be appreciated. Thanks...... Brad