Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open gmail in Firefox browser.

  • 1 tontu
  • 1 am na jafe-jafe bii
  • 11 views
  • i mujjee tontu mooy Happy112

more options

Works fine in Internet Explorer. Firefox is up to date and cookies are enabled and have been cleared. Google.com opens.

This is error message:

Your connection is not secure

The owner of mail.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Works fine in Internet Explorer. Firefox is up to date and cookies are enabled and have been cleared. Google.com opens. This is error message: Your connection is not secure The owner of mail.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox may only connect to it securely. As a result, it is not possible to add an exception for this certificate.

All Replies (1)

more options

Hi   !

There is security software like Avast and Kaspersky and BitDefender and ESET that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content.

See : https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER
Your system details don't show what security software you're running, but try and disable it and see if that makes a difference.