Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Popup blocker blocks all 10+ popups even when not on

  • 5 tontu
  • 6 am na jafe-jafe bii
  • 7 views
  • i mujjee tontu mooy JFor13

more options

Hi! Since about a week ago, my Firefox started blocking popups listed on exception list, when there are over 10 of them. At my work I need to open 16 popup maps every morning by clicking on one button, so having to open the 6 remaining manually because they're blocked by popup blocker gets annoying really fast. The site they're opened from is on the exception list several times, even unticking "block popups" does not help.

Is this a new feature or is my browser misbehaving? Can you think of solutions?

Hi! Since about a week ago, my Firefox started blocking popups listed on exception list, when there are over 10 of them. At my work I need to open 16 popup maps every morning by clicking on one button, so having to open the 6 remaining manually because they're blocked by popup blocker gets annoying really fast. The site they're opened from is on the exception list several times, even unticking "block popups" does not help. Is this a new feature or is my browser misbehaving? Can you think of solutions?

Saafara biñ tànn

Possibly this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste popup and pause while the list is filtered

(3) Double-click the dom.popup_maximum preference and enter the desired value -- the default is 20, so if it's already on 20, maybe it's not this, but try 40 and see whether it helps

Jàng tontu lii ci fi mu bokk 👍 2

All Replies (5)

more options

Are you using add-on pop-up blocker add-ons or just the built in?

more options

Just the built in blocker. I do have Adblock Plus, but it has never caused problems with these windows.

more options

Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <website>. Reload the page.

Forum; AdBlock Plus Forum {web link} https://adblockplus.org/ Homepage

more options

Saafara yiñ Tànn

Possibly this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste popup and pause while the list is filtered

(3) Double-click the dom.popup_maximum preference and enter the desired value -- the default is 20, so if it's already on 20, maybe it's not this, but try 40 and see whether it helps

more options

Awesome, thanks! What jscher2000 said solved this.

Turns out, for reasons unknown to me, the service I need opens two popups each time one window is opened, the other one just disappears straight away. So, the default of 20 was not enough, had to change it to 40.

Also, I've never been to about:config before, very interesting! Thanks again! :)