Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Choppy 4K YouTube playback

  • 4 відповіді
  • 3 мають цю проблему
  • 85 переглядів
  • Остання відповідь від Federico Barutto

more options

I have a very good PC (5800X3D, 7900XT, 32GB DDR4 3600), but Firefox (either the normal, canary and nightly version) can't play smoothly any 4K video (like the Borderlands trailer: https://www.youtube.com/watch?v=lU_NKNZljoQ ). 1440 and lower resolutions are fine, as are 4K videos on Chrome and Edge. FWIW, my CPU during 4K playback is barely used (1-2%), and my GPU's video codec (VCE) is used by around a third. Disabling HW accel makes things better, as it still stutters but it's (barely) passable. I already tried creating a new profile, but still it's the same.

I have a very good PC (5800X3D, 7900XT, 32GB DDR4 3600), but Firefox (either the normal, canary and nightly version) can't play smoothly any 4K video (like the Borderlands trailer: https://www.youtube.com/watch?v=lU_NKNZljoQ ). 1440 and lower resolutions are fine, as are 4K videos on Chrome and Edge. FWIW, my CPU during 4K playback is barely used (1-2%), and my GPU's video codec (VCE) is used by around a third. Disabling HW accel makes things better, as it still stutters but it's (barely) passable. I already tried creating a new profile, but still it's the same.

Обране рішення

Install "VP9 Video Extensions" and "AV1 Video Extension" from the Microsoft Store then reboot.

Try disabling the AV1 codec by changing media.av1.enabled to false in about:config.

Читати цю відповідь у контексті 👍 1

Усі відповіді (4)

more options

Вибране рішення

Install "VP9 Video Extensions" and "AV1 Video Extension" from the Microsoft Store then reboot.

Try disabling the AV1 codec by changing media.av1.enabled to false in about:config.

Корисно?

more options

zeroknight said

Install "VP9 Video Extensions" and "AV1 Video Extension" from the Microsoft Store then reboot. Try disabling the AV1 codec by changing media.av1.enabled to false in about:config.

Thanks! I already had both the extensions installed. Disabling AV1 fixed the problem (despite having a GPU that can decode AV1...). 4K videos are now as smooth as 1440 and lower res.

Корисно?

more options

For AV1 support details, go to about:support in the address bar and check the "Codec Support Information" table.

Корисно?

more options

zeroknight said

For AV1 support details, go to about:support in the address bar and check the "Codec Support Information" table.

Here's my codec support table. Sorry for its language, I'm Italian.

Корисно?

Запитати

Щоб відповідати на повідомлення, ви повинні ввійти у свій обліковий запис. Поставте нове питання, якщо ви ще не маєте облікового запису.