Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the buttons and scroll wheel don't work on my mouse w/ firefox or thunderbird, but they work w/ everything else any help out there

  • 4 பதிலளிப்புகள்
  • 5 இந்த பிரச்னைகள் உள்ளது
  • 773 views
  • Last reply by chienetfou

they work fine in office and the control panel and other windows but not firefox and thunderbird my pc has windows 7 and no worries the mouse controls were working fine until the middle of feb i've updated the drivers and updated the logitech software in the mouse nada

All Replies (4)

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

iamjayakumars: thanks for the advice but no it didn't help it's weird because when i'm in safe mode the mouse buttons and scroll wheel work properly but as soon as i restart and run windows normally they quit working it is .... frustrating shall we say if you or anyone else out there has any more ideas i would like to hear them

thanks

Try to disable hardware acceleration in Firefox.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

cor-el i tried that before and after updating drivers that's when i decided to try getting answers from some of you who are more knowledgeable than i about this as i said everything works in safe mode other apps and programs or in windows 7 this one has me stumped and a little... "irked" shall we say thanks for the suggestions and help