Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

opensuse 11.4 firefox sync

  • 20 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 122 views
  • Last reply by atuor

I just can't get sync to work under FF 4 OpenSuse 11.4. It works on other versions (FF 3.x) Windows & OpenSuse 11.2 & 11.3). It worked the first time I set it up, and stopped. Even tried to create a new acct to test, also failed saying : Sync Encountered an error ... : Unknown error...


Here is the log :

1301819501298	Service.Main	INFO	Starting sync at 2011-04-03 10:31:41
1301819501299	Service.Main	INFO	In sync().
1301819501299	Service.Main	DEBUG	Clearing sync triggers.
1301819501537	Net.Resource	DEBUG	GET success 200 https://phx-sync236.services.mozilla.com/1.0/atuor/info/collections
1301819501537	Service.Main	DEBUG	Fetching global metadata record
1301819501537	Service.Main	DEBUG	Weave Version: 1.7b1pre Local Storage: 5 Remote Storage: 5
1301819501537	Service.Main	INFO	Sync key is up-to-date: no need to upgrade.
1301819501538	Service.Main	DEBUG	Fetching and verifying -- or generating -- symmetric keys.
1301819501538	Service.Main	INFO	Testing info/collections: {"clients":1301823091.1,"crypto":1293093075.38,"keys":1291356430.21,"meta":1301823031.76,"bookmarks":1301688477.97,"passwords":1301823097.92,"forms":1301823030.82,"history":1301823031.09,"prefs":1301823031.28,"tabs":1301823031.47}
1301819501538	CollectionKeys	INFO	Testing for updateNeeded. Last modified: 1293093075.38
1301819501538	Engine.Clients	INFO	0 outgoing items pre-reconciliation
1301819501539	Engine.Clients	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1301819501539	Service.Main	INFO	Updating enabled engines: 8 clients.
1301819501540	Engine.Bookmarks	DEBUG	First sync, uploading all items
1301819501788	Service.Main	DEBUG	bookmarks failed: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsINavHistoryQueryResultNode.childCount] Stack trace: BStore_getChildren()@resource://services-sync/engines/bookmarks.js:1431 < BStore_getChildren()@resource://services-sync/engines/bookmarks.js:1434 < BStore_getAllIDs()@resource://services-sync/engines/bookmarks.js:1458 < SyncEngine__syncStartup()@resource://services-sync/engines.js:568 < _syncStart()@resource://services-sync/engines/bookmarks.js:266 < SyncEngine__sync()@resource://services-sync/engines.js:964 < wrappedSync()@resource://services-sync/util.js:193 < batchedSync()@resource://services-sync/util.js:199 < WrappedNotify()@resource://services-sync/util.js:172 < Engine_sync()@resource://services-sync/engines.js:377 < WeaveSvc__syncEngine()@resource://services-sync/service.js:1913 < resource://services-sync/service.js:1793 < WrappedNotify()@resource://services-sync/util.js:172 < WrappedLock()@resource://services-sync/util.js:140 < _lockedSync()@resource://services-sync/service.js:1695 < resource://services-sync/service.js:1686 < WrappedCatch()@resource://services-sync/util.js:114 < sync()@resource://services-sync/service.js:1667 < browser.js:5317
1301819501788	Engine.Passwords	INFO	0 outgoing items pre-reconciliation
1301819501788	Engine.Passwords	INFO	Records: 0 applied, 0 failed to apply, 0 reconciled.
1301819501836	Service.Main	CONFIG	Starting backoff, next sync at:Sun Apr 03 2011 13:14:08 GMT+0200 (CEST)
1301819501837	Service.Main	DEBUG	Exception: Some engines did not sync correctly No traceback available
1301819517470	Service.Main	INFO	Logging out
1301819517470	Service.Main	DEBUG	Clearing sync triggers.
1301819517475	Service.Main	INFO	Service reset.
1301819517476	Engine.Clients	DEBUG	Resetting clients last sync time
1301819517477	Engine.Bookmarks	DEBUG	Resetting bookmarks last sync time
1301819517478	Engine.Forms	DEBUG	Resetting forms last sync time
1301819517478	Engine.History	DEBUG	Resetting history last sync time
1301819517479	Engine.Passwords	DEBUG	Resetting passwords last sync time
1301819517479	Engine.Prefs	DEBUG	Resetting prefs last sync time
1301819517480	Engine.Tabs	DEBUG	Resetting tabs last sync time
1301819517480	CollectionKeys	INFO	Clearing CollectionKeys...
1301819535537	Service.Main	DEBUG	Clearing sync triggers.

cor-el மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I had the same problem too. Specifically, problem started appearing most likely due to the fact that 2 of my computers have a master password in firefox. It seems that firefox sync can not start till the master password has been entered, hence for these "Clearing sync triggers" messages in the debug log.

Workaround that works fine for me: on these password-protected firefox systems, customize the firefox toolbar, by adding the "sync" button. You'll find it easily enough. Then, when you see from the debug log these messages, just force a manual sync. It should sync ok. If you don't close exit the application, no more manual syncs will be needed after this "kickstart" one.

Read this answer in context 👍 0

All Replies (20)

Tried that, didn't work :-( - exact same error

atuor மூலமாக திருத்தப்பட்டது

Sorry to hear that. This link leads you to general troubleshooting steps Firefox Sync troubleshooting and tips

I looked through all these, but didn't find anything that solved it; as mentioned, I even tried to create a new sync account, but it didn't work either. Maybe an issue specific to Opensuse distro !? I suppose only Mozilla peaople could check the reason from logs... hopefully they will

atuor மூலமாக திருத்தப்பட்டது

Seems to be explained here: (NS_ERROR_NOT_AVAILABLE)

I'm afraid I'm not familiar with Linux though, so I expect an expert will be along shortly to assist you further.

Well obviously not a Linux issue, just installed on Windows 7, did the same, same errror in Log; also worked the first time, and now fails :-(

I don't think you'll get it to work on a Windows machine: it's a Linux app: http://www.opensuse.org/en/

I meant Fireox 4 which is of course available for Windows. Installed it on Windows but it has the same issue

Actually, I should've asked you what your OS was before we started troubleshooting. Normally, the forum software records that where it becomes accessible via the "System details" link, but it appears to have been deleted.

Anyway, you've installed FF4 on Windows 7 and it's not working you say? Do you get an error message when you try to launch it?

Nope, the issue is Firefox 4 Sync, which, be it OpenSuse 11.4 or Windows 7, has the same issue, it syncs the first time, and doesn't work anymore, giving error messages, in about:sync-log, containing NS_ERROR_NOT_AVAILABLE as in my log extract. I just wonder if the error messages in the log are enough to find what causes it.

When I go to Firefox Sync Development it tells me I'm using an old version.

Do you see the same message and if so, does it make any difference if you install the new version?

I see the same, but there is no newer version I can Install :-( I already have the latest as I can see...

This solution seems to have resolved the issue for at least one user: Sync encountered an error while syncing: Unknown error Go to the 3rd post down.

ooops, that sounds complicated :-/ I understand there may be an issue with a specific record (but why w/FF4 and not 3.6 ?) - I wasn't able to reproduce this from your link, I might have to do further research there. Strangely enough, Xmarks can't sync either on my FF4, might be a hint !? If you know a 'simple way' to test against my bookmarks, sort of Debug mode of sync, would be great; the log just doesn't speak to me :-(

Possibly due to the extra Security Features in FF4 which differ from 3.6.

But I'm afraid I don't know of a way you can test it.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I had the same problem too. Specifically, problem started appearing most likely due to the fact that 2 of my computers have a master password in firefox. It seems that firefox sync can not start till the master password has been entered, hence for these "Clearing sync triggers" messages in the debug log.

Workaround that works fine for me: on these password-protected firefox systems, customize the firefox toolbar, by adding the "sync" button. You'll find it easily enough. Then, when you see from the debug log these messages, just force a manual sync. It should sync ok. If you don't close exit the application, no more manual syncs will be needed after this "kickstart" one.

Michail Pappas மூலமாக திருத்தப்பட்டது

Unfortunately that didn't solve the issue :-/ , I also tried to remove the remove master password, but it still does that error

Update - I removed password protection & reinitialised Sync completely, and now it works - Thanks carmik for the good hint  :-)

atuor மூலமாக திருத்தப்பட்டது

The issue reappeared, I suppose we have to wait for a Bug Fix update to be solved