Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hardware Acceleration causing display/CSS bugs?

  • 14 பதிலளிப்புகள்
  • 58 இந்த பிரச்னைகள் உள்ளது
  • 9 views
  • Last reply by WillGray

I noticed that page display was showing some spacing bugs in Firefox 4 in Vista and Windows 7 that weren't showing in XP. After testing on each platform using FF's safe mode and selectively enabling/disabling different add-ons and features, etc, I discovered that hardware acceleration appears to be the issue. I don't believe my XP system has it available, so it does nothing with the option turned on and produces no display bugs. But Vista & Win7 I believe do have hardware acceleration available, and produce the display bugs when it is enabled in FF4 in each. Here are screenshots: Without hardware acceleration enabled in FF4 (how it should appear). and With hardware acceleration enabled in FF4 (has display bugs).

You can try it for yourself with our site. Just enable or disable hardware acceleration in FF4, then close and re-open FF4 to see the bugs appear.

I noticed that page display was showing some spacing bugs in Firefox 4 in Vista and Windows 7 that weren't showing in XP. After testing on each platform using FF's safe mode and selectively enabling/disabling different add-ons and features, etc, I discovered that hardware acceleration appears to be the issue. I don't believe my XP system has it available, so it does nothing with the option turned on and produces no display bugs. But Vista & Win7 I believe do have hardware acceleration available, and produce the display bugs when it is enabled in FF4 in each. Here are screenshots: [http://www.greenwichlibrary.org/images/debug/FF4withoutHWaccel.jpg Without hardware acceleration enabled in FF4 (how it should appear).] and [http://www.greenwichlibrary.org/images/debug/FF4withHWaccel.jpg With hardware acceleration enabled in FF4 (has display bugs).] [http://www.greenwichlibrary.org/default.aspx You can try it for yourself with our site.] Just enable or disable hardware acceleration in FF4, then close and re-open FF4 to see the bugs appear.

WillGray மூலமாக திருத்தப்பட்டது

All Replies (14)

  • bump*

and

After fussing with this a bit more, it looks like the hardware acceleration is somehow messing with the text zoom on the page. I can pretty much duplicate the display bugs (with H.A. turned off) by zooming the text an increment higher. I don't know how or why hardware acceleration being on should mess with the text zoom, but maybe this is a clue that can help Mozilla solve this issue...?

Just tested in FF5 as well, and the problem persists.

Okay, just tested in Firefox 6 as well. Guess what? PROBLEM PERSISTS.

Seriously Mozilla, is it really that difficult to either NOT have hardware acceleration screw with the page zoom, or else to have it turned off by default until you actually fix it?!?

Try to toggle some Boolean gfx.font_rendering prefs on the about:config page to disable some features and maybe set gfx.direct2d.disabled -> true to disable Direct2D.
Filter: gfx

gfx.direct2d.disabled (f -> t)

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.

Hi cor-el! Thanks for the reply.

So I got home and decided to give your advice a try. Only when I started Firefox and re-enabled hardware acceleration and went to my page again, it already appeared correct! Maybe it was some kind of caching issue? I have no idea, but it looks okay now. I followed your suggestions anyway and the gfx.font settings were all already set at their defaults. I toggled the direct2d setting back and forth (closing out and re-opening browser) and either way, the page stayed looking correct. If it happens again, I'll post back here, but for now it seems fixed, so I'm going to clock the "solved it" button on your post.

Thanks!

EDIT:

And I just went back in again and the page is again screwed up. FFFFFFFUUUUUUUUUUUUUUUU!!!!!!!!! Damn it.

gtx settings are all still at defaults. HA is on. Zoom is set to default.

This is seriously driving me up the wall...

So just to reiterate, the problem still exists and is replicable in FF6 on Vista (and I'm assuming Win7).

The bug has already been filed here: https://bugzilla.mozilla.org/show_bug.cgi?id=635490 It appears that this rendering is the default one on Windows Vista and seven, as Internet Explorer renders fonts in the same way when rendering in "IE9 mode". Lr

Hi Louis-Remi, thanks for the reply! I was (obviously) unaware of the prior bug report, though in looking at the responses there, it doesn't look like anything has happened with it since May. I posted my own reply in that thread though with a link here, so hopefully this will get back onto someone's radar.

I've tried my pages in other browsers in Vista (IE8, IE9, Chrome, FF3x, etc) and the fonts look/ed fine in those. It definitely looks to me like FF4 broke it, whereas IE9 looks fine.

Please do not post comments like that in bug reports.
That is considered bug spammimg as email gets send to a lot of people if you do (you may have noticed that after submitting the comment).
If a lot of people do that then the effect may be the opposite and it may take longer time to get this fixed.

Yeah sorry about that--I did notice after submitting it that it emailed all those people and I was like WTF?!? *sigh*

This is still not fixed. And with Mozilla's ridiculous new 5-week release cycle (down from 6 weeks, pretty much just as bad) I don't have high hopes that this will in fact get fixed any time soon. How many version of Firefox do we even actually need? Just fix the current version already. Geez.

I think the remaining problem with the scrollbar appearing in HA mode for FF7, where no scrollbar appears in any other browser, might have to do with how FF7 is rendering the vertical space taken up by line breaks (in HA mode). Apparently the font rendering was at issue too, as that now appears to be fixed. Looks like the line breaks might have been broken also. I'll post back if I discover anything else.