Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla no longer works with my satellite modem!

  • 9 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 39 views
  • Last reply by willjoe24421

I was on phone for a couple hours last night with my satellite provider HughesNet to figure out why nothing would stream. We never gt it figured out. Then, I tried another browser and it worked fine!

Ihave been becoming more and more disenchanted with Firefox this year. SOOOOOOO many problems, it makes my life harder. The only alternative is Google. Everything works with Google pretty much. BUT I HATE GOOGLE!! EVIL. So please fix firefox!

I was on phone for a couple hours last night with my satellite provider HughesNet to figure out why nothing would stream. We never gt it figured out. Then, I tried another browser and it worked fine! Ihave been becoming more and more disenchanted with Firefox this year. SOOOOOOO many problems, it makes my life harder. The only alternative is Google. Everything works with Google pretty much. BUT I HATE GOOGLE!! EVIL. So please fix firefox!

All Replies (9)

Hi Krissy

Do you have ZoneAlarm installed on your computer?

Do you have Adblocker Ultimate installed in Firefox?

Adblocker. I never changed anything this week. It came out of nowhere. Still not working

Hi

We are currently looking into this issue with respect to Adblocker Ultimate. Until it is resolved, I suggest that you temporarily use a different content blocker and we will come back to you with news when we have it.

Looks like that worked. Why is there no post from Firefox about this? It should be an urgent message for users

We have only become aware of this in the last few hours and hope to better understand the underlying cause soon. I hope we can respond with more information when it is available.

Is there a specific filter involved if you check what the extension is blocking as it is possible that a filter update causes this ?

Hi

I understand that we may have a fix for this problem.

  1. Open AdBlocker Ultimate from the toolbar icon and select Settings.
  2. Next, select the Filters tab in the page that opens and turn off the Security option.
  3. Close the page and then repeat the process, but turning the Security option on.

Does this help fix the issue?

So, apparently I have Popup Blocker Ultimate. I went to settings and cannot follow those steps in this situation :/

Thanks!!

Setting the mail client used by Firefox In the Menu bar at the top of the screen, click Firefox and select Preferences. ... In the General panel, go to the Applications section. Search for the Content Type mailto and select it. Click on the Action column in the mailto row to change the action. ... Close the Settings page.

Regards, Diana