Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address Autofill is not an option

  • 11 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 66 views
  • Last reply by mark_holtom

I am a UK user and have just installed and started to use Firefox on a brand new Linux Mint installation. As I am transferring from a Windows/Chrome environment, there is a lot of setting up to do. Firefox transferred most of the chrome info for me, and so I was able to get up and running with bookmarks and logins quite quickly. However, there is one problem that I can't seem to resolve.

I have been able to set up my credit card details, and these are prompted when needed, BUT, Firefox will not remember my name, email, phone or address. Thus for every form that I have to fill, I have to enter these details, again and again (and again).

I have looked at settings and see that the 'Autofill Address' option is not present (see attachment).

I have followed and implemented the fix proposed elsewhere, to update/add GB as an address format. This has not made a difference.

Can anyone please help.

Regards,

Mark

I am a UK user and have just installed and started to use Firefox on a brand new Linux Mint installation. As I am transferring from a Windows/Chrome environment, there is a lot of setting up to do. Firefox transferred most of the chrome info for me, and so I was able to get up and running with bookmarks and logins quite quickly. However, there is one problem that I can't seem to resolve. I have been able to set up my credit card details, and these are prompted when needed, BUT, Firefox will not remember my name, email, phone or address. Thus for every form that I have to fill, I have to enter these details, again and again (and again). I have looked at settings and see that the 'Autofill Address' option is not present (see attachment). I have followed and implemented the fix proposed elsewhere, to update/add GB as an address format. This has not made a difference. Can anyone please help. Regards, Mark
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Change extensions.formautofill.addresses.supported back to default detect.

Read this answer in context 👍 1

All Replies (11)

You can force-enable support by going to about:config in the address bar and changing extensions.formautofill.addresses.supportedCountries to include GB. Note that it may not be compatible with all address formats.

Hi, I have already done this previously. It made no difference

Cheers

Attached is a screenshot of my autofill parameters. You can see they are all set on.

The browser might not think you are in GB, go to about:config and make sure browser.search.region is GB.

Thank you for your help, but I mentioned that I had done this in the original post and then showed it in the next attachment.

browser.search.region is a different setting to the one mentioned previously and is not in your attached screenshot. You will need to restart the browser for any country change to take effect.

Forgive me. My mistake.

browser.search.region is correctly set to GB.

Perhaps to clarify my situation.

In settings, privacy, there is no line for Autofill Address. There is one for Autofill Credit Cards.

On looking for a solution on the web, a lot of pages show that the relevant settings page includes BOTH of these options, whereas mine just has the one for credit cards.

I believe that I have the latest vsn of Firefox and Linix Mint.

WARNING from the moderator team: Changing Firefox preferences from the about:config page can sometimes break Firefox or cause strange behavior. You should only do this if you know what you're doing. Please read Firefox Advanced Customization and Configuration Options to learn more.

Hi Mark

I recommend that you rest those preferences to their defaults - I am a Linux user in the UK and credit autofill works fine for me without doing that.

Are you using a copy of Firefox you have installed from Mozilla or the one that came with Linux Mint?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Change extensions.formautofill.addresses.supported back to default detect.

Dear zeroknight,

I now have the option to see and save autofill addresses and it seems to work. I think that you may have solved my problem. Thank you.

I will now test more thoroughly.

Cheers,

Mark