Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps suggesting the wrong website addresses

  • 8 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 12 views
  • Last reply by jscher2000 - Support Volunteer

Hi,

I asked about this a while ago, but now I can't find the response. I go to about 10 websites regularly throughout the day every day. Yet for a few sites, FF refuses to autofill the actual sites I go to. If I type an r, I get Raw Story; if I type C, I get CNN, and so on. But even though I have never typed in "www.rawstory.com," that's what I get when I type a w even though Wonkette is one of the sites I'm on all day. I also never type in "mail.google.com" because I have my email on the bookmarks bar, but that's what I get when I type an m instead of Mediate, another of the daily sites.

And it doesn't stop with Ctrl + delete because they don't turn up on the drop down list; they automatically populate the search bar, and then hitting delete for any reason just removes it from the bar, not from the list of suggestions. So my question is, how can I get Firefox to stop imposing itself on me when there is a clear pattern by now of what sites I visit all the time?

Thank you very much, Nandi

Hi, I asked about this a while ago, but now I can't find the response. I go to about 10 websites regularly throughout the day every day. Yet for a few sites, FF refuses to autofill the actual sites I go to. If I type an r, I get Raw Story; if I type C, I get CNN, and so on. But even though I have '''never''' typed in "www.rawstory.com," that's what I get when I type a w even though Wonkette is one of the sites I'm on all day. I also never type in "mail.google.com" because I have my email on the bookmarks bar, but that's what I get when I type an m instead of Mediate, another of the daily sites. And it doesn't stop with Ctrl + delete because they don't turn up on the drop down list; they automatically populate the search bar, and then hitting delete for any reason just removes it from the bar, not from the list of suggestions. So my question is, how can I get Firefox to stop imposing itself on me when there is a clear pattern by now of what sites I visit all the time? Thank you very much, Nandi

All Replies (8)

Hi Nandi, I really don't know how Firefox decides what "autofill" suggestion to show in the address bar when you type w or m. As you've noticed, it's not necessarily based on how much you use the site.

Unfortunately, there's no easy way to delete specific "autofill" suggestions that appear inside the address bar. If you want to try to try to get rid of the rawstory suggestion because you don't visit that site, you can try this method:

(1) Call up the Library window to Show All History (Ctrl+Shift+h)

(2) In the small search box at the upper right of the Library window, type or paste rawstory.com

(3) Right-click any result for the site and choose Forget About This Site to delete all history entries, custom site permissions, etc., for the site

It's probably not worth doing that with mail.google.com because most likely you would be visiting it again very soon.

I'll also mention the keyword option. When you bookmark a page, you can create a short keyword to use in the address bar. For example:

(1) Find the page on Wonkette you want to bookmark

(2) Right-click the tab (up on the tab bar) and click Bookmark Tab...

Firefox should display a dialog overlaid over the tab.

(3) Edit the name as needed, then at the bottom, type w in the Keyword field and click Save

Now when you type w in the address bar, the top line of the autocomplete drop-down should say that Firefox intends to visit the bookmarked URL.

Thank you. But there was no button called Keywords; there was a box for tags, but that's it. I tried typing w and w, in the tag box, but that changed nothing. Every site technically starts with www; it doesn't make sense that it's only this one. Should I try anything else?

I think that you only find the Keyword row if you use "Add Bookmark" and "Edit Bookmark" in the right-click context menu.

You can consider to disable auto-fill by setting this pref to false on the about:config page, that way you can select an item in the drop-down list.

  • about:config => browser.urlbar.autoFill = false

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue" to open about:config.

The Keyword box should appear below the Tags box. But make sure to use the right-click tab context menu for this and not the star button at the right end of the address bar.

Hmm... Are you saying that it should be a bookmarked page? I haven't bookmarked any of these pages because it takes only one keystroke to just type the first letter, except for the few I've asked about. Will bookmarking make Firefox stop giving me these useless recommendations?

Thanks for helping.

If you bookmarks a specific link (URL) and set a keyword to this bookmark then you only need to type this keyword and press Enter to open this link.

nandibrown said

Hmm... Are you saying that it should be a bookmarked page? I haven't bookmarked any of these pages because it takes only one keystroke to just type the first letter, except for the few I've asked about. Will bookmarking make Firefox stop giving me these useless recommendations?

You can either keep in-URL-bar autofill suggestions as determined by the algorithm, or disable the feature completely and have the address bar stay empty as you type. cor-el mentioned the preference that turns the feature on and off.

If you like having the suggestions most of the time but need to fix a few specific cases, creating a bookmark with a keyword for those addresses is how you can do that -- keywords override autofill.