Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

insecure ssl certificate or cipher

  • 11 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 25 views
  • Last reply by larry

the certificate on my linksys lrt 214 router not recognized. used to be able with previous versions to bypass security with advanced tab no longer able to do this cannot use older versions of firefox to bypass. need to access web interface of router at 192.168.1.1 to upgrade certificate but cannot. linksys does not have a work around. please help

the certificate on my linksys lrt 214 router not recognized. used to be able with previous versions to bypass security with advanced tab no longer able to do this cannot use older versions of firefox to bypass. need to access web interface of router at 192.168.1.1 to upgrade certificate but cannot. linksys does not have a work around. please help

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Chris Ilias said

Yes, that image helps a lot. What that error page says is that your router is using an old security protocol, which is outdated. Your router must be really old. ☺️ Firefox disabled support for protocols older than TLS 1.2 a couple of years ago, and recently removed the option to re-enable it.

Well, there still is a back door method, but please reverse it after using it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste security.tls.version.min and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 (meaning TLS 1.0) then press Enter or click the blue check mark button to save the change.

Keep this page open. When finished with the old site, use the Reset button (left-arching arrow) at the right end of that row to restore the default value of 3 (meaning TLS 1.2).

Read this answer in context 👍 0

All Replies (11)

Hi Larry, There are a couple of options:

Theoretically, you shouldn't need a certificate when access a device on your local network, so there's no need to use HTTPS. Instead of going to https://192.168.1.1 go to http://192.168.1.1

The other option is to create an exception. When you experience the "Potential Security Risk" page, click Advanced, then click Accept the Risk and Continue.

Helpful?

larry said

the certificate on my linksys lrt 214 router not recognized. used to be able with previous versions to bypass security with advanced tab no longer able to do this

There is no Advanced button, or Firefox won't save an exception?

What is the SEC_ERROR_WHATEVER code (it doesn't always start with SEC_ERROR, but it is all caps separated by underscores)?

Helpful?

after updating Firefox,chrome, and safari you no longer have access to an advance tab. you cannot create an exception. the error message is error_ssl_certificate_match or cipher. I have have tried to use http instead of https, will not accept. I have tried downloading older versions of the above browsers but I am using Mac OS and apple servers will still not go to 192.168.1.1 even in the old servers

Helpful?

Hi Larry, The screenshot I posted was of the latest version of Firefox on macOS Monterey. Would you mind sending us a screenshot of what you're seeing? For instructions, see How do I create a screenshot of my problem?.

Helpful?

hopefully screenshot uploaded

Helpful?

Some router give specific instructions how to access the router did you read those instructions. Not all use 198 or 192 when first accessing the router for first time setup.

Helpful?

Hi Larry, Yes, that image helps a lot. What that error page says is that your router is using an old security protocol, which is outdated. Your router must be really old. ☺️ Firefox disabled support for protocols older than TLS 1.2 a couple of years ago, and recently removed the option to re-enable it.

According to https://www.linksys.com/us/support-article?articleNum=148352 there's a firmware update for your router last year that adds support for TLS 1.2.

The best and safest solution would be to update the Linksys software. Log in using a different browser, then check for updates to the router software, or install the firmware file I linked to.

Helpful?

Hi Chris. This is what I’m trying to do is update the software. I can’t log on to the router webpage through any browser. I spent two hours on the phone with Linksys yesterday trying to use old versions of the browsers in order to be able to reach the webpage management. Unable to use any of the older versions of the browsers to reach the page. I think that the Apple servers are blocking the use of the insecure certificates. The linksys technician suggested trying to use an old Windows computer with an old Internet explorer browser and see if I could reach the web management page that way. Unfortunately I don’t have an old Windows laptop or desktop computer to use. Was hoping to find some other work around for this problem.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Chris Ilias said

Yes, that image helps a lot. What that error page says is that your router is using an old security protocol, which is outdated. Your router must be really old. ☺️ Firefox disabled support for protocols older than TLS 1.2 a couple of years ago, and recently removed the option to re-enable it.

Well, there still is a back door method, but please reverse it after using it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste security.tls.version.min and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 1 (meaning TLS 1.0) then press Enter or click the blue check mark button to save the change.

Keep this page open. When finished with the old site, use the Reset button (left-arching arrow) at the right end of that row to restore the default value of 3 (meaning TLS 1.2).

Helpful?

Thanks Chris you were a great help. And I closed the back door after I installed the updated firmware and verified that it solved the problem. Really appreciate your help

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.