Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Middle Mouse opens link in 2 tabs / closes 2 tabs constantly

  • 4 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 335 views
  • Last reply by rayben1

Hi Firefoxes! I updated to the latest and greatest 99.0.1, whenever i use the middle mouse button it opens every link in 2 tabs. Also when i middle mouse on a tab, 2 tabs are closed. Anyone came along this bug? Restarting FF and Windows did not help. Trying to get my notebook charged and check it on my macbook.

TYVM! Best regards, -John.

Hi Firefoxes! I updated to the latest and greatest 99.0.1, whenever i use the middle mouse button it opens every link in 2 tabs. Also when i middle mouse on a tab, 2 tabs are closed. Anyone came along this bug? Restarting FF and Windows did not help. Trying to get my notebook charged and check it on my macbook. TYVM! Best regards, -John.
Attached screenshots

rayben1 மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I am so sorry. I was very tired when i was opening the question and now i have retested it... It was indeed a hardware fault on the mouse.

Read this answer in context 👍 0

All Replies (4)

Update: closing 2 tabs with 1 middle mouse click is not constant, but constant in opening tabs.

rayben1, have you tried another mouse to rule out issues with mouse you are using? as the Firefox browser most certainly supports the basic three button mouse setup since forever.


I use Logitech thumb trackballs including T-CH11 (from 1995) which is literally a three button mouse (buttons only, no scroll wheel) and middle click on each trackballs and mice works fine with Fx 99 with no opening double tabs.

Can you try a different mouse in case there is an hardware issue or possibly try to increase the double click delay to see if that has effect ?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I am so sorry. I was very tired when i was opening the question and now i have retested it... It was indeed a hardware fault on the mouse.