X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Failed to read configuration file

  • 8 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

We are currently having to role back to FireFox ESR 52.9 from the latest Quantum build of FireFox 60.3.0. Due to the fact that this version utilizes WebGl 2. Our older systems will not render one of the educational games we utilize in the our School District any longer due to the fact that Quantum uses WebGl 2 instead WebGl 1. We have tested and verified that ESR 52.9 renders the game properly.

I have been trying to disable the automatic update in utilizing the user.js file and the cfg file. The computers are apart of the domain. From what I have read only new user profiles will get the new user.js settings while all existing profiles will retain the old settings so we plan on reimaging these computers so all existing profiles will be wiped.

I have also seen users block the updates by changing the Host File which we will not do. Some sites state create a profile folder in the defaults folder other show place the user.js file in the pref folder. So I am lost at this point. I have followed this guide as well:

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Enterprise_deployment_before_60#Changes_Over_Time

I have placed the 00_admin-prefs.js with the exact settings shown and have the mozilla.cfg file in the same folder as the js. both are in the defaults\pref

When trying to run FireFox I am am not getting:

Failed to read the configuration file. Please contact your Administrator. (I am the Admin). My domain creds give me admin privileges on all computers.

I know this folder also holds the channel-pref.js so I am not sure if I can add what I need to that file.

If someone would please help me determine what is going on. Why wont firefox copy the either a user.js file or utilize the cfg file I created to each new profile that gets created when logging into the computer.

We are currently having to role back to FireFox ESR 52.9 from the latest Quantum build of FireFox 60.3.0. Due to the fact that this version utilizes WebGl 2. Our older systems will not render one of the educational games we utilize in the our School District any longer due to the fact that Quantum uses WebGl 2 instead WebGl 1. We have tested and verified that ESR 52.9 renders the game properly. I have been trying to disable the automatic update in utilizing the user.js file and the cfg file. The computers are apart of the domain. From what I have read only new user profiles will get the new user.js settings while all existing profiles will retain the old settings so we plan on reimaging these computers so all existing profiles will be wiped. I have also seen users block the updates by changing the Host File which we will not do. Some sites state create a profile folder in the defaults folder other show place the user.js file in the pref folder. So I am lost at this point. I have followed this guide as well: https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Enterprise_deployment_before_60#Changes_Over_Time I have placed the 00_admin-prefs.js with the exact settings shown and have the mozilla.cfg file in the same folder as the js. both are in the defaults\pref When trying to run FireFox I am am not getting: Failed to read the configuration file. Please contact your Administrator. (I am the Admin). My domain creds give me admin privileges on all computers. I know this folder also holds the channel-pref.js so I am not sure if I can add what I need to that file. If someone would please help me determine what is going on. Why wont firefox copy the either a user.js file or utilize the cfg file I created to each new profile that gets created when logging into the computer.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

cor-el said

This error message means that there are errors in the autoconfig.cfg file or the file isn't found in the correct location.. The autoconfig.cfg (Mozilla.cfg) file needs to be in the main Firefox program folder and not in the folder where the autoconfig.js (Mozilla.js) file is located that specifies to use an autoconfig file. You can directly lock pref (lockPref("<pref>", value);) via autoconfig.cfg to disable the updater, so there shouldn't be a need to copy a user.js file. In Firefox 52 this is still possible. In Firefox 60 you can disable the updater via policies.json.

Thank you the link I was going to did not say were to place the autoconfig file. I assumed the cfg file needed to be in the same place as the.js file since there was not path given. I will try that

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 27.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0

கூடுதல் தகவல்

user1929 72 தீர்வுகள் 290 பதில்கள்
பதிவிடப்பட்டது

Hi,

I don't know what the answer to the deployment issues is, hopefully someone else on this forum can help with that. However, a couple of things about webGL:

  • Later versions of Firefox have a "webgl.enable-webgl2" preference - does the game work correctly if you disable that?
  • As far as I know, existing webGL content should continue to work correctly even with webGL2 enabled, so this sounds like a bug. Do you have a link to the game that you could share so we can figure out why it isn't working?
Hi, I don't know what the answer to the deployment issues is, hopefully someone else on this forum can help with that. However, a couple of things about webGL: * Later versions of Firefox have a "webgl.enable-webgl2" preference - does the game work correctly if you disable that? * As far as I know, existing webGL content should continue to work correctly even with webGL2 enabled, so this sounds like a bug. Do you have a link to the game that you could share so we can figure out why it isn't working?
cor-el
  • Top 10 Contributor
  • Moderator
17419 தீர்வுகள் 157385 பதில்கள்
பதிவிடப்பட்டது

This error message means that there are errors in the autoconfig.cfg file or the file isn't found in the correct location..

The autoconfig.cfg (Mozilla.cfg) file needs to be in the main Firefox program folder and not in the folder where the autoconfig.js (Mozilla.js) file is located that specifies to use an autoconfig file.

You can directly lock pref (lockPref("<pref>", value);) via autoconfig.cfg to disable the updater, so there shouldn't be a need to copy a user.js file. In Firefox 52 this is still possible. In Firefox 60 you can disable the updater via policies.json.

This error message means that there are errors in the autoconfig.cfg file or the file isn't found in the correct location.. The autoconfig.cfg (Mozilla.cfg) file needs to be in the main Firefox program folder and not in the folder where the autoconfig.js (Mozilla.js) file is located that specifies to use an autoconfig file. You can directly lock pref (lockPref("<pref>", value);) via autoconfig.cfg to disable the updater, so there shouldn't be a need to copy a user.js file. In Firefox 52 this is still possible. In Firefox 60 you can disable the updater via policies.json. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig *https://github.com/mozilla/policy-templates/blob/master/README.md
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

cor-el said

This error message means that there are errors in the autoconfig.cfg file or the file isn't found in the correct location.. The autoconfig.cfg (Mozilla.cfg) file needs to be in the main Firefox program folder and not in the folder where the autoconfig.js (Mozilla.js) file is located that specifies to use an autoconfig file. You can directly lock pref (lockPref("<pref>", value);) via autoconfig.cfg to disable the updater, so there shouldn't be a need to copy a user.js file. In Firefox 52 this is still possible. In Firefox 60 you can disable the updater via policies.json.

Thank you the link I was going to did not say were to place the autoconfig file. I assumed the cfg file needed to be in the same place as the.js file since there was not path given. I will try that

''cor-el [[#answer-1177079|said]]'' <blockquote> This error message means that there are errors in the autoconfig.cfg file or the file isn't found in the correct location.. The autoconfig.cfg (Mozilla.cfg) file needs to be in the main Firefox program folder and not in the folder where the autoconfig.js (Mozilla.js) file is located that specifies to use an autoconfig file. You can directly lock pref (lockPref("<pref>", value);) via autoconfig.cfg to disable the updater, so there shouldn't be a need to copy a user.js file. In Firefox 52 this is still possible. In Firefox 60 you can disable the updater via policies.json. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig *https://github.com/mozilla/policy-templates/blob/master/README.md </blockquote> Thank you the link I was going to did not say were to place the autoconfig file. I assumed the cfg file needed to be in the same place as the.js file since there was not path given. I will try that
FredMcD
  • Top 10 Contributor
4227 தீர்வுகள் 59008 பதில்கள்
பதிவிடப்பட்டது

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 31.0.0.148

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

'''Separate Security Issue:''' Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 31.0.0.148 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
James
  • Moderator
1594 தீர்வுகள் 11232 பதில்கள்
பதிவிடப்பட்டது

FredMcD said

Flash Player Version: Version 31.0.0.148

The NPAPI Flash Player has been 31.0.0.153 since November 20.

''FredMcD [[#answer-1177086|said]]'' <blockquote> Flash Player Version: '''Version 31.0.0.148 ''' </blockquote> The NPAPI Flash Player has been [https://helpx.adobe.com/ca/security/products/flash-player/apsb18-44.html 31.0.0.'''153''' since November 20].
FredMcD
  • Top 10 Contributor
4227 தீர்வுகள் 59008 பதில்கள்
பதிவிடப்பட்டது

Thank you.

Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I just wanted to say THANK YOU to everyone that posted and helped with my question. It is refreshing to see such a helpful community without making you feel completely stupid for asking a question.

I just wanted to say THANK YOU to everyone that posted and helped with my question. It is refreshing to see such a helpful community without making you feel completely stupid for asking a question.
FredMcD
  • Top 10 Contributor
4227 தீர்வுகள் 59008 பதில்கள்
பதிவிடப்பட்டது

Always remember; the only stupid question, is the one you don't ask.

Always remember; the only stupid question, is the one you don't ask.