Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I continuously have to update flash to access certain websites?

  • 12 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 6 views
  • Last reply by FredMcD

I have been having frequent issues accessing certain websites that I use daily for work. The only fix I have found is to update my adobe flash even though it is current. When I do that and Firefox restarts, I am then able to access these websites.

However, this is a huge burden and I'm ready to pull the plug on using Firefox unless someone has input.

Hopefully it is a quick fix that I'm just not noticing? Everything was fine until Monday 2/26/18. Since then I'm constantly having to fix it.

All Replies (12)

How many websites are you having this problem with? Try other sites. Is there a problem? +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

The Flash Player 28.0.0.161 has been the current version since Feb 6 so you should not be getting multiple Flash updates once you have this version. Type about:plugins in the Location (address) bar to see what you Flash version is.

Make sure Firefox is completely closed when you install or update the Flash Player Plugin from Adobe.

James மூலமாக திருத்தப்பட்டது

I am aware of the current flash version. The two websites that I am having issues with are Slack and Amazon Seller Central (in the US). To be clear, I can access the websites. The issue is once I log in, the pages never fully load.

When I access these in Microsoft Edge they work just fine. It is a total band-aid and I'm sure it isn't Flash itself, but each time I download and install flash, it fixes the issue with Firefox. I have no issues when logging in to these two websites. It takes me to the pages and they work seamlessly. If I let my PC go to sleep, or I restart it, the cycle starts all over again.

@FredMcD - I just updated my video card drivers and it sadly didn't help.

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

The problem is still there in Safe Mode. Once I log in, the page is just gray and has 0 content.

FredMcD said

How many websites are you having this problem with?
Try other sites. Is there a problem?

The only two websites I’m having issues with are sellercentral.amazon.com and a Company Slack account.

The Amazon website loads the login screen and allows me to login. However, in the login process the screen goes gray. The Slack account also loads the login screen, then after logging in it goes to the last message/channel I was in and never fully loads.

All other websites are working fine in the same timeframe.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I was thinking your most recent suggestions did the trick, but I found myself back with the same issues this morning after a fairly painless Friday.

I removed the graphic acceleration; have cleared cache/cookies/history; went into the history/custom settings and removed all of the cookies as suggested and things seemed to clear up.

Today when I found myself with the same two websites giving me grief, doing these steps did not clear it up. However, I went and downloaded a fresh Adobe Flash, closed Firefox, did the install and now things are loading as they should.

I feel like I'm in this endless loop and there has got to be something simple causing it. I know it is associated with Firefox as it is not happening in other browsers. Sadly, I can't continue to do these ridiculous steps to use Firefox.

Any other ideas would surely be appreciated.

Til the Flash is totally gone or replaced with a more stable, secure Flash or something similiar or better some sites will still use it for better or worse. So it's just best to keep your flash up to date and if the site uses it it will run otherwise it stays idle. Put this way I use and install Flash, Shockwave, Sliverlight and Java just for the one in life time site that will say turn on your plugins. So I take this with a grain of salt.

WestEnd மூலமாக திருத்தப்பட்டது

What I don't understand is why installing the exact same fully up to date Flash fixes this issue. I have been on the current Flash since well before these issues started to come up.

I don't know if this will help, but check it out;

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.