Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Enabling Multi-process autmatically loads all tabs on launch.

  • 5 பதிலளிப்புகள்
  • 6 இந்த பிரச்னைகள் உள்ளது
  • 1 view
  • Last reply by mascarponi

Hi all,

I like the 'new' mozilla multiprocess feature. However when enabled it load automatically all the browser tabs that were open in my last browsersession, which i don't like. To disable loading all tabs on startup it set; 'tabs.remote.autostart' to 'false'. Which also disables multi-process..

How can i use multi-process without loading all tabs on firefox startup?

Cheers.

Hi all, I like the 'new' mozilla multiprocess feature. However when enabled it load automatically all the browser tabs that were open in my last browsersession, which i don't like. To disable loading all tabs on startup it set; 'tabs.remote.autostart' to 'false'. Which also disables multi-process.. How can i use multi-process without loading all tabs on firefox startup? Cheers.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks all. I found out that an extension called 'browsing protection by f-secure' (my virusscanner) was forcing to load all tabs on startup. Disabling this extension did the trick. However i now cannot make use of it now. That's a bit of a pitty.

Read this answer in context 👍 1

All Replies (5)

Hi, open Options > General (When Firefox starts) and make sure it isn't set to Show your windows and tabs from last time.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

But then i lose my tabs from last browsersession. I don't want to lose them, i only want to 'not load' them at startup. In previous version this was possible. Tabs load when clicking on them, not by themself.

hi, this should still be the default behaviour. could you enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.restore_on_demand. check that this preference is set to true.

See also this pref for pinned tabs:

  • browser.sessionstore.restore_pinned_tabs_on_demand
  • browser.sessionstore.restore_tabs_lazily

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks all. I found out that an extension called 'browsing protection by f-secure' (my virusscanner) was forcing to load all tabs on startup. Disabling this extension did the trick. However i now cannot make use of it now. That's a bit of a pitty.