X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Change default display for text only page (turn OFF "Wrap Long lines")

  • 2 replies
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by anev942
பதிவிடப்பட்டது

New Firefox user. Frequently I visit text only page- data strings are quite long. The default view for text only appears to be "Wrap Long Lines", which defeats the sorted information by line. Fortunately I found Page Style under View when I turned on Menu Bar. But when I revisit or refresh the page it defaults back to the word wrap, its getting old. Is there a way to change the default to "Basic page style"..or turn off word wrap, permanently. I looked under options but just havent seen a way to change this. Thanks

New Firefox user. Frequently I visit text only page- data strings are quite long. The default view for text only appears to be "Wrap Long Lines", which defeats the sorted information by line. Fortunately I found Page Style under View when I turned on Menu Bar. But when I revisit or refresh the page it defaults back to the word wrap, its getting old. Is there a way to change the default to "Basic page style"..or turn off word wrap, permanently. I looked under options but just havent seen a way to change this. Thanks

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well month past -I found setting! I appreciate the response. I played with the suggested workarounds for several hours with some very limited results (none really solving but learned a bit). I gave up -mostly not knowing what the heck I was doing. Was becoming more effort than clicking on page display & turning off word wrap :), thinking I'd get back to it... Then Mozilla upgraded... Searching for more critical fixes (firefox memory usage just keeps climbing) stumbled on a few ideas, still working on that. However one suggestion led me into about:config. Opening another tab & looking thru the list found plain_text.wrap_long_lines default boolean true I double clicked on it (or right click and select toggle) changed it to plain_text.wrap_long_lines user set boolean false WALA! Default page view for text is now 'Basic Page Style' not 'Wrap Long Lines'. Turning on word wrap is now the option. Cool. For viewing long data fields- nice. No more menu-View-Page Style-Basic Page Style repeatedly during session.

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

பயன்பாடு

  • Firefox 37.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.1/WINNT/en-US/

நீட்சிகள்

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6100 nForce 405
  • adapterDescription2:
  • adapterDeviceID: 0x03d1
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 128
  • adapterRAM2:
  • adapterSubsysID: 0d15105b
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6100 nForce 405 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17567 தீர்வுகள் 158896 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

You could use the userContent.css to set a CSS rule for that domain. You would have to check via the Inspector what selector(s) you need to use on each website (#id or .classname).

@-moz-document domain(<domain>){
 selector { white-space:normal!important; word-wrap:break-word!important; }
}

See:

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.


  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userContent.css file in the editor window
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
You could use the userContent.css to set a CSS rule for that domain. You would have to check via the Inspector what selector(s) you need to use on each website (#id or .classname). *https://developer.mozilla.org/en-US/docs/Web/Guide/CSS/Getting_started/Selectors *https://developer.mozilla.org/en/CSS/@document *https://developer.mozilla.org/Web/CSS/white-space *https://developer.mozilla.org/Web/CSS/word-break *https://developer.mozilla.org/Web/CSS/word-wrap <pre><nowiki>@-moz-document domain(<domain>){ selector { white-space:normal!important; word-wrap:break-word!important; } }</nowiki></pre> ---- See: *http://kb.mozillazine.org/userContent.css The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration ---- *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive) *Paste the code in the userContent.css file in the editor window *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.<br>Otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well month past -I found setting! I appreciate the response. I played with the suggested workarounds for several hours with some very limited results (none really solving but learned a bit). I gave up -mostly not knowing what the heck I was doing. Was becoming more effort than clicking on page display & turning off word wrap :), thinking I'd get back to it... Then Mozilla upgraded... Searching for more critical fixes (firefox memory usage just keeps climbing) stumbled on a few ideas, still working on that. However one suggestion led me into about:config. Opening another tab & looking thru the list found plain_text.wrap_long_lines default boolean true I double clicked on it (or right click and select toggle) changed it to plain_text.wrap_long_lines user set boolean false WALA! Default page view for text is now 'Basic Page Style' not 'Wrap Long Lines'. Turning on word wrap is now the option. Cool. For viewing long data fields- nice. No more menu-View-Page Style-Basic Page Style repeatedly during session.

Well month past -I found setting! I appreciate the response. I played with the suggested workarounds for several hours with some very limited results (none really solving but learned a bit). I gave up -mostly not knowing what the heck I was doing. Was becoming more effort than clicking on page display & turning off word wrap :), thinking I'd get back to it... Then Mozilla upgraded... Searching for more critical fixes (firefox memory usage just keeps climbing) stumbled on a few ideas, still working on that. However one suggestion led me into about:config. Opening another tab & looking thru the list found ''plain_text.wrap_long_lines default boolean true'' I double clicked on it (or right click and select toggle) changed it to '''''plain_text.wrap_long_lines user set boolean false''''' WALA! Default page view for text is now 'Basic Page Style' not 'Wrap Long Lines'. Turning on word wrap is now the option. Cool. For viewing long data fields- nice. No more menu-View-Page Style-Basic Page Style repeatedly during session.

anev942 மூலமாக திருத்தப்பட்டது