Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I get embed codes at YouTube using Firefox on my desktop, while it works fine on my Macbook Pro with Firefox? This is a recent change.

  • 6 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 674 views
  • Last reply by garybrantley

Recently, I noticed that when I attempt to "share" a YouTube video and click the share button, I get no embed codes. In fact I get no options at all. And, when I tried to share a YouTube playlist, again, nothing happens except an apparent text box opens that I cannot type or enter anything into. I use a Macbook Pro at work, with Firefox as my browser and everything works just as it should on YouTube. Since this is a quite recent problem with my Dell desktop (Firefox browser) at home, I suspect something has changed resulting in my current issue. Thanks for any help!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You need to determine what addons is causing the problem.

Please follow these instructions to disable addons: http://mzl.la/1xKrBZF

When you figure out how to disable addons please use this method to determine what addon is causing this issue.

  • Disable 1 Addon and test the page; repeat this, keeping the addons you have tested disabled. When you disable and test and find which addon is causing this issue, fully remove it.

Let us know if this helped.

Read this answer in context 👍 1

All Replies (6)

garybrantley said

Recently, I noticed that when I attempt to "share" a YouTube video and click the share button, I get no embed codes. In fact I get no options at all. And, when I tried to share a YouTube playlist, again, nothing happens except an apparent text box opens that I cannot type or enter anything into. I use a Macbook Pro at work, with Firefox as my browser and everything works just as it should on YouTube. Since this is a quite recent problem with my Dell desktop (Firefox browser) at home, I suspect something has changed resulting in my current issue. Thanks for any help!

YouTube Content Creators have the ability to disable embedding if they wish to keep their videos on YouTube only. This is most likely what has occurred and is more than likely not an issue with Firefox itself.

Let us know if this helped.

bohl3r மூலமாக திருத்தப்பட்டது

Well, as I stated above, I can embed a certain video on my Macbook and then when I try to embed the exact same video on my Dell desktop, there are no embed codes or other sharing options. Would the embedding be disabled only on my desktop and not on the laptop Macbook? That doesn't seem right. Thanks for the help, Gary

Here are the links to some knowledge base articles that might be able to assist you with this issue. I recommend you try this on your machine that doesn't get embed codes.

Troubleshoot Firefox issues using Safe Mode

Websites look wrong or appear differently than they should

If this doesn't help feel free to reply back to this post.

bohl3r மூலமாக திருத்தப்பட்டது

When I restarted Firefox in safe mode, my YouTube issues were solved. Back normal Firefox mode, they are still there. What next?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You need to determine what addons is causing the problem.

Please follow these instructions to disable addons: http://mzl.la/1xKrBZF

When you figure out how to disable addons please use this method to determine what addon is causing this issue.

  • Disable 1 Addon and test the page; repeat this, keeping the addons you have tested disabled. When you disable and test and find which addon is causing this issue, fully remove it.

Let us know if this helped.

bohl3r மூலமாக திருத்தப்பட்டது

After I updated AdBlockPlus, the problem disappeared! I thought it was set to update automatically, but it had not updated since July 2014. After the update, no more problems with YouTube. Thank you so much for your great help and patience too. Gary Brantley