Search Support

why does my search engine keep reverting to google?

  • 6 பதிலளிப்புகள்
  • 6 இந்த பிரச்னைகள் உள்ளது
  • 2299 views
  • Last reply by FredMcD

I have deleted all search engines except yahoo. But now google will come up as my search engine and show up in the list of search engines. I do not want google. So how do I permanently get rid of google search engine.

I have deleted google several times. I have restored firefox to the default state several times. I have uninstalled firefox to get rid of google search, then rebooted my computer and reinstalled firefox from a new download. After trying all of this google keeps showing up as my search engine. Hope you can help me get rid of google. Thanks

தீர்வு தேர்ந்தெடுக்கப்பட்டது

When you change the search engine using the icon next to the search bar, that should "stick". Do you find that it changes randomly, or the next time you exit and restart Firefox, or notice any other pattern?

For issues that occur when exiting and restarting Firefox, see:

  • Consider whether you use any utility or security software (e.g., Advanced SystemCare) that have a feature such as "Surfing Protection", "Home Page Protection", etc. These features may undo your browser settings changes to protect you from unwanted changes -- and from yourself. Not always helpful...
Read this answer in context 👍 2

All Replies (6)

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, check the programs that are on your computer Windows > Start > Control Panel > Uninstall Programs. Go thru the list and use a web search to check any that you don't know what they are.

Troubleshoot Firefox Issues Caused By Malware

தீர்வு தேர்ந்தெடுக்கப்பட்டது

When you change the search engine using the icon next to the search bar, that should "stick". Do you find that it changes randomly, or the next time you exit and restart Firefox, or notice any other pattern?

For issues that occur when exiting and restarting Firefox, see:

  • Consider whether you use any utility or security software (e.g., Advanced SystemCare) that have a feature such as "Surfing Protection", "Home Page Protection", etc. These features may undo your browser settings changes to protect you from unwanted changes -- and from yourself. Not always helpful...

Thank you - I checked my Advanced System AutoCare Homepage Protection page and it did list my search engine as google. Hopefully this will fix the problem. Thanks again.

lee369 மூலமாக திருத்தப்பட்டது

Thank you for your help. I checked my Advanced System Autocare Homepage Protection and is showed my search engine as google. I changed it to Yahoo and hopefully that will correct the problem. Thank you again for all your help.

lee369 மூலமாக திருத்தப்பட்டது

Hi Edward27821, it sounds as though you have a different issue and I suggest starting a new question with a full description of what is happening. You can use this link, and scroll down past the suggestions if they don't look relevant to continue with the form.

https://support.mozilla.org/questions/new/desktop/fix-problems

Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.