X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

firefox wont dowload any attachments from yahoo mail, all other downloads work

Pridané

Basic download function for firefox still works (I can download things), it used to work for yahoo mail attachments, but now for last 2 days I cant download any attachments from yahoo mail (used to have no problems with yahoo mail). If I go back to IE I can download yahoo mail attachments. Havent added any new programs etc so dont know why it just started hating yahoo mail.

Basic download function for firefox still works (I can download things), it used to work for yahoo mail attachments, but now for last 2 days I cant download any attachments from yahoo mail (used to have no problems with yahoo mail). If I go back to IE I can download yahoo mail attachments. Havent added any new programs etc so dont know why it just started hating yahoo mail.

Vybrané riešenie

It did not fix it. The scanning of the requested download of the attachment is actually Yahoo's Norton scan.

Studying the behavior more closely, I did notice a difference in what appears in Chrome when I hover on the "Save to My Computer" prompt.

Here is Chrome

us-mg6.mail.yahoo.com/neo/launch?.rand= (and then a string of alpha/numeric chars which I think are my id)

Here is Firefox

us,mg5.yahoo.com/dc/launch# (the end, as in no id, etc.)

I had been using a saved bookmark to launch Yahoo in Firefox while in Chrome, I was googling for the Yahoo Mail url and I did not notice they were different until now.

I used the same url in Firefox to launch Yahoo as I did in Chrome and voila! it works!!!

Thank you so much for your suggestions. I hope this helps somebody else.

Čítať túto odpoveď v kontexte 74

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • npsitesafety
  • Shockwave Flash 11.9 r900
  • SiteAdvisor
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • McAfee MSC FF plugin DLL
  • 5.1.20913.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • McAfee Virtual Technician plugin
  • Google Update
  • Microsoft Lync 2010 Attendee Meeting Join Plug-in
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Office Live Update v1.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0

Viac informácií

Wesley Branton
  • Top 10 Contributor
641 riešení 5230 odpovedí

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back soon.
Wesley Branton
  • Top 10 Contributor
641 riešení 5230 odpovedí

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' Please report back soon.

Autor otázky

ComputerWhiz Thank you for the response. I did the two things you recommend and doesnt solve problem, so as you say, likely an extension problem, that I will look into later. Not a critical problem, just use IE if I have to.

Thanks again for the responses.

ComputerWhiz Thank you for the response. I did the two things you recommend and doesnt solve problem, so as you say, likely an extension problem, that I will look into later. Not a critical problem, just use IE if I have to. Thanks again for the responses.
Wesley Branton
  • Top 10 Contributor
641 riešení 5230 odpovedí

Feel free to use Internet Explorer while you look for extension issues.
Sorry for any inconvenience that this may cause.

Please report back with the results of your extension search.

Feel free to use Internet Explorer while you look for extension issues.<br>Sorry for any inconvenience that this may cause. Please report back with the results of your extension search.
Borstegis 0 riešení 3 odpovedí

What should you do if the problem persists in the Safe Mode? Does that mean it is an extension problem?

What should you do if the problem persists in the Safe Mode? Does that mean it is an extension problem?
Mojo3mama 1 riešení 2 odpovedí

Yahoo is not downloading attachments in Firefox. I cannot for the life of me discover what version I am running but the address bar says "http://us.mg5.mail.yahoo.com/dc/launch". I can't recall when I last downloaded but I do all the time so I think this is new this week. When I click on the "Download Attachment" link, the file scans but does not initiate a pop up to Save, etc. Gmail is downloading attachments ok in Firefox. Yahoo Basic downloads ok as well. Running Firefox in Safe Mode also allows Yahoo downloads. I went through the steps of unchecking the accelerator and disabling the extensions one by one, clearing cache and cookies with no luck. Yahoo mail downloads ok in IE and Chrome. I know others who are also having this problem.

Yahoo is not downloading attachments in Firefox. I cannot for the life of me discover what version I am running but the address bar says "http://us.mg5.mail.yahoo.com/dc/launch". I can't recall when I last downloaded but I do all the time so I think this is new this week. When I click on the "Download Attachment" link, the file scans but does not initiate a pop up to Save, etc. Gmail is downloading attachments ok in Firefox. Yahoo Basic downloads ok as well. Running Firefox in Safe Mode also allows Yahoo downloads. I went through the steps of unchecking the accelerator and disabling the extensions one by one, clearing cache and cookies with no luck. Yahoo mail downloads ok in IE and Chrome. I know others who are also having this problem.
Wesley Branton
  • Top 10 Contributor
641 riešení 5230 odpovedí

If the issue continues in safe mode, that means that the issue is most likely not an extension issue.


The cause might be antivirus software which tries to scan the file and during that process hangs the Firefox instance.

In order to fix the problem, try disabling the scanning as follows:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page. A list of settings should appear
  3. Filter the list by typing in the search bar at the top. Type in scanWhenDone. You should now find the "browser.download.scanWhenDone" preference.
  4. Double-click on that preference to set the value to false.
  5. Next, try to download something and see if it still hangs.

Please reply and tell us whether this helped you!

If the issue continues in safe mode, that means that the issue is most likely not an extension issue. -------------------- The cause might be antivirus software which tries to scan the file and during that process hangs the Firefox instance. In order to fix the problem, try disabling the scanning as follows: # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. A list of settings should appear # Filter the list by typing in the search bar at the top. Type in ''scanWhenDone''. '''You should now find the "browser.download.scanWhenDone" preference'''. #Double-click on that preference to set the value to ''false''. #Next, try to download something and see if it still hangs. Please reply and tell us whether this helped you!
Mojo3mama 1 riešení 2 odpovedí

Vybrané riešenie

It did not fix it. The scanning of the requested download of the attachment is actually Yahoo's Norton scan.

Studying the behavior more closely, I did notice a difference in what appears in Chrome when I hover on the "Save to My Computer" prompt.

Here is Chrome

us-mg6.mail.yahoo.com/neo/launch?.rand= (and then a string of alpha/numeric chars which I think are my id)

Here is Firefox

us,mg5.yahoo.com/dc/launch# (the end, as in no id, etc.)

I had been using a saved bookmark to launch Yahoo in Firefox while in Chrome, I was googling for the Yahoo Mail url and I did not notice they were different until now.

I used the same url in Firefox to launch Yahoo as I did in Chrome and voila! it works!!!

Thank you so much for your suggestions. I hope this helps somebody else.

It did not fix it. The scanning of the requested download of the attachment is actually Yahoo's Norton scan. Studying the behavior more closely, I did notice a difference in what appears in Chrome when I hover on the "Save to My Computer" prompt. Here is Chrome us-mg6.mail.yahoo.com/neo/launch?.rand= (and then a string of alpha/numeric chars which I think are my id) Here is Firefox us,mg5.yahoo.com/dc/launch# (the end, as in no id, etc.) I had been using a saved bookmark to launch Yahoo in Firefox while in Chrome, I was googling for the Yahoo Mail url and I did not notice they were different until now. I used the same url in Firefox to launch Yahoo as I did in Chrome and voila! it works!!! Thank you so much for your suggestions. I hope this helps somebody else.
kmh123 0 riešení 1 odpovedí

Užitočné odpovede

Thanks, Mojo3mama.

I was having the same problem with attachment on two different computers. When I was composing email messages, I also was receiving pop-up messages as if I was trying to exit and whether I wanted to save my message to Drafts. Taking your advice, I cleared my Firefox history files, deleted my Yahoo! Mail bookmark, then logged into Yahoo! Mail at http://mail.yahoo.com. My login location is similar to the one you were seeing in Chrome:

us-mg6.mail.yahoo.com/neo/launch?.rand=[...].

I tried uploading and downloading attachments, and everything appears to be working well. I also am not receiving any more pop-up's messages asking if I want to exit and/or save my message to Drafts.

Thanks, again!

Thanks, Mojo3mama. I was having the same problem with attachment on two different computers. When I was composing email messages, I also was receiving pop-up messages as if I was trying to exit and whether I wanted to save my message to Drafts. Taking your advice, I cleared my Firefox history files, deleted my Yahoo! Mail bookmark, then logged into Yahoo! Mail at http://mail.yahoo.com. My login location is similar to the one you were seeing in Chrome: us-mg6.mail.yahoo.com/neo/launch?.rand=[...]. I tried uploading and downloading attachments, and everything appears to be working well. I also am not receiving any more pop-up's messages asking if I want to exit and/or save my message to Drafts. Thanks, again!
Borstegis 0 riešení 3 odpovedí

ComputerWhiz,

Thanks, but when I looked at the setting it was already set on false. Problem persists.

ComputerWhiz, Thanks, but when I looked at the setting it was already set on false. Problem persists.
Wesley Branton
  • Top 10 Contributor
641 riešení 5230 odpovedí

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.

Fx23MixedContentBlocker

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: [[How does content that isn't secure affect my safety?]] To temporarily allow the mixed content to be displayed: *Click the '''shield icon''' [[Image:Mixed Content Shield]] in the address bar and choose '''Disable Protection on This Page''' from the dropdown menu. [[Image:Fx23MixedContentBlocker]] To allow insecure content to be displayed in all secure pages, enter '''about:config''' in the address bar and double-click on this preference, to toggle it from true to false: '''security.mixed_content.block_active_content''' You can also use this add-on instead, to toggle the preference: *[https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ Toggle Mixed active content] add-on You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about. Let us know if this helps!
Borstegis 0 riešení 3 odpovedí

Spooky, but this works. Thanks.

Spooky, but this works. Thanks.
exfordy 0 riešení 4 odpovedí

I had this problem on our mac. AOK until a couple of days ago. Didn't work in Firefox, did work in Safari. Did work in Firefox safe mode. I found we had no extensions. Then found it was not working when Yahoo mail started from the bookmark toolbar but it did work when started from 'Google, Yahoo mail, sign in'. Then I saw the url started with an icon looking like a small Lego brick. When I clicked on that it said '"Adobe Flash" is enabled on uk-mg-bt.mail.yahoo.com' and offered 'Block Plugin'. That did not fix it. I copied the url from Safari (which did work) to Firefox bookmark toolbar and it still did not work.

I had this problem on our mac. AOK until a couple of days ago. Didn't work in Firefox, did work in Safari. Did work in Firefox safe mode. I found we had no extensions. Then found it was not working when Yahoo mail started from the bookmark toolbar but it did work when started from 'Google, Yahoo mail, sign in'. Then I saw the url started with an icon looking like a small Lego brick. When I clicked on that it said '"Adobe Flash" is enabled on uk-mg-bt.mail.yahoo.com' and offered 'Block Plugin'. That did not fix it. I copied the url from Safari (which did work) to Firefox bookmark toolbar and it still did not work.
jscher2000
  • Top 10 Contributor
8789 riešení 71878 odpovedí

Hi exfordy, many users are complaining about attachments not downloading from Yahoo! mail over the past several days. I don't think it should be necessary to block Flash on Yahoo to get your mail.

Is there any pattern to the type of attachment that won't download?

Hi exfordy, many users are complaining about attachments not downloading from Yahoo! mail over the past several days. I don't think it should be necessary to block Flash on Yahoo to get your mail. Is there any pattern to the type of attachment that won't download?
jz152 0 riešení 2 odpovedí

Same problem. I can't download or open attachments in Yahoo Mail on my primary computer. The problem started several days ago. No problem with Yahoo Mail on my other computer. Both are running Firefox 25.0.1 and NoScript. The problem computer is running AVG as the virus protector, but disabling it doesn't help. Yahoo Tech Support says it appears to be a conflict with the Norton attachment scanner that Yahoo uses by default for all attachments. Tried restarting and clearing caches etc. disabling plug-ins and add-ons with no success. Running Firefox in Safe Mode solves the problem, but I haven't figured out with the hangup is yet.

Same problem. I can't download or open attachments in Yahoo Mail on my primary computer. The problem started several days ago. No problem with Yahoo Mail on my other computer. Both are running Firefox 25.0.1 and NoScript. The problem computer is running AVG as the virus protector, but disabling it doesn't help. Yahoo Tech Support says it appears to be a conflict with the Norton attachment scanner that Yahoo uses by default for all attachments. Tried restarting and clearing caches etc. disabling plug-ins and add-ons with no success. Running Firefox in Safe Mode solves the problem, but I haven't figured out with the hangup is yet.
jscher2000
  • Top 10 Contributor
8789 riešení 71878 odpovedí

Hi jz152, thank you for your report.

Firefox's Safe Mode also disables hardware acceleration of graphics and Firefox's JavaScript compilers. It's easy to manually disable hardware acceleration of graphics in the options to see whether that's relevant.

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect after you exit and restart Firefox.

Hi jz152, thank you for your report. Firefox's Safe Mode also disables hardware acceleration of graphics and Firefox's JavaScript compilers. It's easy to manually disable hardware acceleration of graphics in the options to see whether that's relevant. (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Firefox menu > Preferences > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" This takes effect after you exit and restart Firefox.
giakalp 0 riešení 1 odpovedí

I had this problem too, i solved it by switching the advanced view to basic(i am sorry if the definitions i am using aren't correct since i have a greek interface). In basic view i could download attachements. By switching again from basic to advanced view everything worked just fine.

I had this problem too, i solved it by switching the advanced view to basic(i am sorry if the definitions i am using aren't correct since i have a greek interface). In basic view i could download attachements. By switching again from basic to advanced view everything worked just fine.
exfordy 0 riešení 4 odpovedí

jscher2000, there is no pattern to the type of attachment that won't download. They are .doc, .docx and jpeg that have not downloaded.

jscher2000, there is no pattern to the type of attachment that won't download. They are .doc, .docx and jpeg that have not downloaded.
bangingmyheadonthewall 0 riešení 2 odpovedí

Same problem here changing to basic seems to have solved it for me, but what a pain! I'm getting really fed up with Yahoo mail since the last "improvements" I certainly seem to have had more problems since then.

Best wishes to all.

Oh dear just found the mail reverts to the new all singing all dancing one each time it is opened, so only a work around really, not a simple permanant cure.

Same problem here changing to basic seems to have solved it for me, but what a pain! I'm getting really fed up with Yahoo mail since the last "improvements" I certainly seem to have had more problems since then. Best wishes to all. Oh dear just found the mail reverts to the new all singing all dancing one each time it is opened, so only a work around really, not a simple permanant cure.

Upravil(a) bangingmyheadonthewall dňa

shargrove 1 riešení 3 odpovedí

This worked for me: I went to settings and change to basic email. That gave me the ability to download the attachment I needed. Then I went clicked to update to the new spiffy yahoo mail, and everything works like new again.

Hope that works for someone.

This worked for me: I went to settings and change to basic email. That gave me the ability to download the attachment I needed. Then I went clicked to update to the new spiffy yahoo mail, and everything works like new again. Hope that works for someone.