Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 20.0 adobe flash 11.7 100% crashes. Cannot watch any videos at all anymore. Help?

  • 30 odpovedí
  • 139 má tento problém
  • 78347 zobrazení
  • Posledná odpoveď od fdmbb

more options

3 days ago I was trying to watch videos on youtube and i kept getting adobe flash player crash error. i went ahead and updated to firefox 20.0.1 and i updated to flash player 11.7. still getting the error. Ive clean installed both since. I've reverted to older versions even the 10.3 listed on Firefox Troubleshooting guide. Nothing seems to work. I cannot watch any video period on any website that i've tried. Ive ran Malwarebytes and virus scans both with latest definitions and all is clean. Now firefox just crashed as i was writing this. weird. some assistance would be appreciated. Thanks

Vybrané riešenie

One issue people have identified with YouTube in particular is a conflict with certain AdBlock Plus rules. I haven't kept track of the details, but if the problem becomes limited to YouTube, definitely try making an exception if you use that extension.


One thing that might have changed this week is that Windows updated recently. Sometimes this process also installs graphics driver updates at the same time.

This is some standard guidance that addresses the most common issues:

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Win Vista & Win 7 & maybe Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Čítať túto odpoveď v kontexte 👍 10

Všetky odpovede (20)

more options

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Thanks amishree but if you read my post you'd see that i stated that i already have malwarebytes and a solid antivirus (avast!) and i ran scans with both.

more options

Vybrané riešenie

One issue people have identified with YouTube in particular is a conflict with certain AdBlock Plus rules. I haven't kept track of the details, but if the problem becomes limited to YouTube, definitely try making an exception if you use that extension.


One thing that might have changed this week is that Windows updated recently. Sometimes this process also installs graphics driver updates at the same time.

This is some standard guidance that addresses the most common issues:

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button or classic Tools menu > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Win Vista & Win 7 & maybe Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

I was having a similar problem. I thought it was malware too, but nothing came up when I did a full system scan. So if that turns out not to be the problem for you either, maybe my sharing my experience will help you out too.

Today, after updating Java Runtime Environment (6 and 7), Adobe AIR, Flash Player ActiveX and Flash Player Plugin, Flash seems to be working within the Firefox browser with no crashes or busy notifications. I think I may have also had the problems I did because of how little space I had left on the harddrive at the time. Upon erasing about 10 gigs of data, bringing the available space back into the blue for C:, all's well today.

After reading the answer above, I wonder if the new Windows update had something to do with it also. I hope yours works soon, OP. Thank you to the above responders too. Your answers helped me out a lot.

Upravil(a) unpluggedbyjc dňa

more options

Thanks jscher! step (1)(B) fixed it. i'd disabled acceleration through firefox yesterday but it didnt work. doing it through adobe fixed it for me. thank you all.

more options

Adobe Flash 11.7 freezes at install 95%. Maybe I should be happy (video and youtube still work). OS 10.6.8, Firefox 20

more options

SOLVED IT FOR REAL!!!

Hopefully that got your attention. The problem is not hardware acceleration. Disabling hardware acceleration may help, but it hasn't helped everyone (including me) and it's just a band-aid. I have the exact same problems, all flash content would cause the flash plugin to crash instantly. I tried IE for a comparison and it wouldn't work there either. I had the most recent versions of flash and firefox installed. Also I couldn't play any video files on my computer with Windows Media Player.

This led me to believe that it was not flash specifically, but either a virus/malware got onto the computer, or some other recent change caused it. AVG and Malwarebytes revealed nothing, so I started trying to remember any recent changes I had made. The only ones in the last couple days were removing a couple programs I no longer used, and 1 update from Microsoft. I didn't think uninstalling software would cause it, so I tracked down the update.

Once I found it, uninstalled it, and rebooted, the computer worked perfectly again. All flash content works fine, ie - youtube, facebook, etc., and I can play video files with media player normally again. The update is KB2840149, which after googling it I learned that it's coincidentally, a re-release of a previous update that was so horribly botched that in some cases Microsoft had to send out repair disks to people who hadn't removed it before it completely bjorked their computer.

This newer version is supposed to be fixed, and I didn't find anything through google search indicating it was a problem for anyone else, but it was the source of my problems and if you've just started experiencing flash problems since your computer last installed Windows updates, remove this one ASAP. I've subsequently hidden the update so it will no longer nag me to install it.

So to recap, removing update KB2840149 has restored my Win7 (x64, Ultimate) computer to normal working order, with flash version 11.7 and firefox version 20.0.1 installed, and all hardware acceleration turned on.

more options

I accidentally found a way around this issue. For me using private window mode or select "Never remember history" pull down menu under option --> privacy --> history. With normal mode it always crashes.

more options

Hi soistheman, I think the main difference between permanent private browsing mode and regular mode is that automatic private mode does not use your normal browser cache or cookies. Perhaps those files are corrupted? Maybe there is some other difference that isn't coming to mind.

more options

I tried uninstalling the Windows KB2840149 update, to no avail. The Microsoft Safety scanner found nothing suspicious on my PC.

In the end what did work was to downgrade to Flash Player 11.6, which someone had suggested in another thread here (and disabling the automatic updates, obviously).

No further problems.

more options

Solved it by update the graphic card's driver to the newest version with clean install.

At first the disable hardware accelerator helps. But with schlicky13's advice I downloaded my Nvidia's driver and reinstalled it with the option 'clean install' and the problem is fixed.

thanks schlicky13! :D

more options

My solution to this problem of SWF in FF locking up: For Win7 x64 SP1, FF 20.0.1, SWF 11.7.7.202:

Besides writing ProtectedMode=0 into mms.cfg in C:\windows\syswow64\macromed\flash , I had to set the three SWF exe files' compatibility property to Vista SP2.

It doesn't seem necessary to mess around with update KB2840149.

I'm not sure that changing ProtectedMode is needed. Leaving the default works on some sites, nt on others. I still once in a while have to clear lockups by going into task manager, ending the process tree for firefix,exe *32, and restarting FF. I haven't yet had time to track down the reason for this. It seems to happen for only some sites that make heavy use of SWF, e.g. http://www.nbcnews.com/id/26315908/#51912353 .

HTH eda

more options

Hi i was tearing my hair out with this also i tried all of the above solutions including many more on other web sites . I found the Microsoft update KB 2840149 mentioned deleted it -restarted my computer and fire-fox and flash player now work fine .I rarely use videos or flash applications so it was only when my wife tried to play a video it started to play up . Thaks for posting this fix

Andrew

more options

A few weeks ago my macbook pro started crashing and freezing . It got consistently worse until one day, I couldn't open anything without having to do a hard reboot. It even began to freeze when starting up and shutting down. Took almost an entire day to trouble-shoot the problem. I narrowed it down to the latest Adobe flash update. I ran through all the suggested fixes and finally just uninstalled it and reinstalled 10.3 -thanks for that suggestion. I ran a disk repair and everything looks to be running normally again, but what a pain.

Upravil(a) itsizzi dňa

more options

How do you find that update to delete it?

more options

Hi junebugknits, if you visit the Windows Control Panel and open Programs > Programs and Features > View Installed Updates (Win 7) or a similar button in the Add/Remove Program dialog (Win XP) you can review/remove an update there.

more options

Junebugknits -If you have a Mac, it's most likely in your applications folder. There should be an Adobe install manager folder that you can click on to find the uninstall option.

Upravil(a) itsizzi dňa

more options

just registered an account to say this. I had similar problems described by the op and tried a few things before finding this thread. My system was generally unresponsive, firefox and chrome both took ages to start. Flash plugin would randomly freeze my browser even with no flash on the page.

I just uninstalled KB2840149 and my computer is working fine again, no need to disable flash or protected mode. Everything is much more responsive too, I was close to formatting my C drive!

thanks! :)

more options

Hello, I did the "acceleration" workaround and it didn't work. In my case uninstalling KB2840149 did the trick!

Edit: Just want to add that I use W7 Ultimate 32bit, with Firefox 22 and Flash 11.7.700.224. About the issue, I had one flash crash after that, so I'm thinking that maybe KB2840149 is not 100% guilty, but that is still better than 100% crashes.

Upravil(a) Petes2013 dňa

more options

Reviewing the posts, it seems that the fix that helps most people is to remove KB2840149. But has anyone noticed other deleterious safety results of removing this update?

When reportingexperiences with this or other fixes, please remember to also note the OS and the FF version you're referring to. A fix in one OS may not work in a different one. This problem is hairy enough without having to guess whether a poster is referring to one's OS and FF version.

  1. 1
  2. 2