Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

in firefox 20.0 why is never remember history the same as in private browsing

  • 15 odpovedí
  • 11 má tento problém
  • 2 zobrazenia
  • Posledná odpoveď od cheroz

more options

I just updated to firefox 20.0. In the previous version, I could set it to "never remember history" and it would not be the same as "in private browsing". Now when I set it to "never remember history" it restats in "in private browsing". Not only that, in IPB, the appearance I've selected disappears and the Firefox search bar is totally unresponsive. That is, in the previous version, I could select "never remember history", it didn't have to go to IPB, the appearance theme I selected would not disappear and the FF search box worked just fine. Now, none of that happens!! What gives?????

I just updated to firefox 20.0. In the previous version, I could set it to "never remember history" and it would not be the same as "in private browsing". Now when I set it to "never remember history" it restats in "in private browsing". Not only that, in IPB, the appearance I've selected disappears and the Firefox search bar is totally unresponsive. That is, in the previous version, I could select "never remember history", it didn't have to go to IPB, the appearance theme I selected would not disappear and the FF search box worked just fine. Now, none of that happens!! What gives?????

Všetky odpovede (15)

more options

I can't answer the "why" question, but can you set Firefox to work the way you want by choosing "Use custom settings" and unchecking the relevant boxes? For cookies, I recommend accepting both first party and third party cookies, and setting "Keep until: I close Firefox", to maximize website functionality without retaining data between sessions.

more options

Regarding the search bar being unresponsive, is the address bar also unresponsive? There is an issue with Firefox 20.0 in business environments that put your Windows user profile folder on a remove server (using a UNC path). Do you think that might be applicable to you?

more options

Again, when I select Never Remember History from the Privacy Settings, now in version 20.0, you have to restart it and it restarts in the In Private Browsing mode and the appearance theme I selected and add-ons disappear. Before I could browse the net in the Never Remember History mode, the new appearance theme I chose would remain the same and all of my add-ons would work. Now, if I want to do that, I have to select "Remember History" to have the FFox page maintain the appearance I chose. I DO NOT WANT TO BROWSE IN THE "REMEMBER HISTORY" MODE. I WOULD LIKE TO BROWSE IN THE "NEVER REMEMBER HISTORY MODE" WITHOUT HAVING FIREFOX RESTARTING ITSELF IN THE PRIVATE MODE (Sorry for all the caps) I could do all of this in old version.

more options

Okay, my main problem now after much futzing about is that it seems that in the new version (20.0), the Never Remember History" is the same as the "In Private Browsing" where it was not before. So be it. But the question remains as to how do I get to keep my new appearance selection (theme) in the IPB mode?? When Firefox restarts in the NRH mode- or the IPB mode - it reverts back to its old appearance and nothing I do wil allow me to keep the appearance theme. Please help.

more options

A fix might be coming in Firefox 22 for the lack of the light-weight theme in Private Browsing mode.

more options

If the theme is paramount for you, do you want to try the "Use custom settings" approach I mentioned in an earlier reply?

more options

Unfortunately, I have no idea what a "light weight theme" is that you're referring to. I found out about why Never Remember History and In Private Browsing are the same now in 20.0 since FF posted the explanation. However, my problem is that while all of my add-ons remain the same in the IPB mode, any new "appearance" theme add-ons disappear unless you switch to the "Remember History" mode, which I don't want. Do you know why I cannot select a new appearance in the NRH setting or the IPB mode?

Thanks

more options

By 'appearance' we assume you are referring to an image for the Toolbar area of the browser windows. That 'appearance' image was known as a "Persona" until recently, when a new Mozilla feature assumed the Persona name. Now those 'appearance' images are referred to as Lightweight Themes.


https://bugzilla.mozilla.org/show_bug.cgi?id=852295
(Please don't comment in that Bug report unless you can provide a patch to fix the problem.)
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

What's up with the use of the word "paramount"? All I want it to be able to use a feature that I could use before. What's the point of offering people a choice of appearances in Firefox and then, not being able to use them in any mode I choose. In other words, its NOT paramount; however, there is no reason why I shouldn't be able to keep a new theme in the IPB mode. Also, I tried your Custom Setting suggestion and it didn't help.

more options

Sorry, that's the way the developers decided to handle the New Private Window feature. It looks like that will be changed in Firefox 22 which is due to be released in 12 weeks.

more options

What I'm referring to is in the Add-Ons manager, you can select "Themes" which can give the FF page a whole new look (Brushed Chrome, etc.). If you select a new theme from the dozens offered, that theme disappears once you get into the In Private Browsing Mode; that is, FF returns to it's old bland looking theme. Once you set it to Remember History, it restarts displaying the new theme you've chosen. When you switch back to Never Remember History, which now is the same as IPB, the new theme you've selected disappears, goes, vanishes, doesn't hang around. I really don't know how to make it any clearer than that.

more options

I think what the-edmeister is saying is that this is a known "bug" with no current solution that might be fixed 12 weeks from now.

I tried your Custom Setting suggestion and it didn't help.

You mean Firefox still started up in private browsing mode? I've attached a screen shot showing what I had in mind.

more options

Previous Firefox versions (19 and before) also switched to Private Browsing mode when you selected the "Never Remember History" choice as can be verified by choosing the "Use custom settings for history" choice that allows to inspect the current settings and checking the cookies. The only change in Firefox 20 is that you now have to restart Firefox to make this change affective (you can't have none "Private Window" windows with this setting).

What are your main reasons why you want to be in Private Browsing mode?

You can disable the history and the disk cache (keep the memory cache) and let cookies expire when you close Firefox (i.e. make them session cookies).

more options

I don't want to be in the private browsing mode!!!!!!! Geez!!!! After Firefox updated this morning it switched to the IPBrowsing mode all by itself! At the top of my screen - in brackets - after where it says "Mozilla Firefox" it NOW says "Private Browsing". Why??? It never said that before. Also, and I'm sick and tired of writing this, the "theme" I chose from the wide selection of themes that Firefox offers its users, does not work when Firefox is in the private browsing setting. The only way I can get the theme back is to switch to "remember history" in the settings which I don't want to do. And you're wrong: before this "update", I could set my preferences to Never Remember History and the words Private Browsing NEVER appeared at the top of my screen and I could quite happily use any theme I wanted to select. Moreover, the custom settings don't do squat to fix this. You know, first, I'm not an idiot. Second, I've been using Firefox for a couple of years so I am familiar with what I could and could not do before this update so please don't tell me there are no changes with this update.

more options

Actually, I apologize. As suggested here by others, I fixed the problem by using the Use Custom Settings option. So again, my apologies.

Having said that, I'm sticking to my story about how Firefox operated in its previous incarntations; specifically, I was never prompted to restart Firefox after choosing Never Remember History and, in all the previous updates that I can recall, I was always returned to the same page as before, themes and all. This time, after updating, my theme was gone and I was put into the Private Browsing Mode. Why I have no idea. But in all the times I have updated Firefox in previous years, this has never happened.