Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Dropdown list requires backspacing

  • 31 odpovedí
  • 0 má tento problém
  • 2 zobrazenia
  • Posledná odpoveď od roselaw

more options

About three days ago, the dropdown lists for various websites I use stopped populating unless I use the backspace. So, for instance, if I want to find "John", nothing happens if I just start to type it in. But if I type in "Jo" and then backspace, John pops up. (Perhaps important: Even though I have now deleted the "o", only John pops up, not names beginning with J but followed by a different letter.) Curiously, it seems like the first time each day that I go onto any given website, the dropdown does populate properly, but just that once. I checked Edge and Chrome, and the dropdowns work fine there, so it's definitely a Firefox problem. Any ideas about what is going on and how I can fix it? Thanks.

About three days ago, the dropdown lists for various websites I use stopped populating unless I use the backspace. So, for instance, if I want to find "John", nothing happens if I just start to type it in. But if I type in "Jo" and then backspace, John pops up. (Perhaps important: Even though I have now deleted the "o", only John pops up, not names beginning with J but followed by a different letter.) Curiously, it seems like the first time each day that I go onto any given website, the dropdown does populate properly, but just that once. I checked Edge and Chrome, and the dropdowns work fine there, so it's definitely a Firefox problem. Any ideas about what is going on and how I can fix it? Thanks.

Všetky odpovede (11)

more options

Thanks @zeroknight, I don't know if that response is for @cor-el or for me, but if it's for me, I don't know what to make of it. BTW, I just noticed that the "backspace" issue isn't confined to forms -- it is also affecting the subject line when I draft an e-mail in Juno. I'd love it if you and @cor-el could continue trying to help me, but I feel like I'm becoming a burden and these problems just don't seem to have answers. Please only continue if you have the time and inclination.

more options

The three input fields do not have type attribute or other special attributes, so I don't know why in your case Firefox sees this as a form for credit card details unless you have saved this data as normal form autocomplete data (this data is not site specific, but is about name/id).

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the webpage to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press "Delete" or "Shift+Delete" to delete the highlighted entry

Note that hovering with the mouse doesn't work.

more options

Thanks, I know how to remove items from a drop-down list but I'm not seeing the relevance here. To recap, about a week ago, all (or almost all) of the websites that used to autocomplete just fine started this thing where the first time each day I go into them, the first box autocompletes just fine, but after that I have to type the first letter (nothing shows at that point) and then backspace (at which point it gives me the drop-down list). Then about three days ago, WebCrims (and only WebCrims) decided that what used to be regular fields only want my saved credit card info and won't save anything else. I don't know if the two problems are related, if they're coincidental, or if the various things I did to try to correct the first problem somehow caused the second problem.

more options

What happens if you disable autofill for credit cards in Settings ?

more options

Great question! But it didn't make a difference.  :-(

more options

That would still suggest that the credit card relation is merely coincidence and that this is about saved form data. You can try to rename formhistory.sqlite (formhistoryOLD.sqlite) to see if that has effect.

more options

Nope, that didn't help either.

more options

Can you remove items from the list by pressing Shift+Delete?

Are you able to share a screenshot of the drop-down list with private information redacted?

more options

Sure, here's the screenshot (attached). I don't understand your question though: Do you mean on this particular website (like you want me to remove my name), or do you mean on the other websites (where I still get a normal drop-down with names from the history even though the backspace error continues)?

more options

Disable "Autofill addresses" in settings to get the normal drop-down form history.

Can you share a screenshot of the drop-down that has the backspace problem?

more options

Holy cow, @zeroknight, that not only fixed the most recent problem, but it also cured the "backspace" problem!!! Thanks so much to you and @cor-el for persevering with this, even in the face of my lack of tech knowledge. Now if I could trouble you just a bit further: Now that you know that, is there a way to fix this so that I can have "autofill addresses" on and still not have to backspace, or do I have to learn to live with one or the other?

  1. 1
  2. 2