Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

HSTS issue on vercel deployed app

more options

Hello,

I deployed my NextJS app on Vercel, but I cannot access my deployed app through firefox because of HSTS.

I tried to access several sites with domain .vercel.app but the issue persists.

I can access all sites with ".vercel.app" domain just fine on other browsers except Mozilla Firefox.

I already looked for solution on the internet such as:

  1. Removing entry on SiteSecurityServiceState.txt
  2. Forget site
  3. Clear browser cache & history
  4. Restart browser

Any help will be appreciated.

Thank you for your time and attention.

Hello, I deployed my NextJS app on Vercel, but I cannot access my deployed app through firefox because of HSTS. I tried to access several sites with domain ''.vercel.app'' but the issue persists. I can access all sites with ".vercel.app" domain just fine on other browsers except Mozilla Firefox. I already looked for solution on the internet such as: # Removing entry on SiteSecurityServiceState.txt # Forget site # Clear browser cache & history # Restart browser Any help will be appreciated. Thank you for your time and attention.
Priložené obrázky

Vybrané riešenie

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (11)

more options

It works for me and looks good on SSL Labs.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

more options

zeroknight said

It works for me and looks good on SSL Labs. Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Thanks for replying, I tried all the things you mentioned but it still didn't work sadly.

The firefox developer edition was freshly installed but it still shows the same error. The new profile and refreshing my profile also didn't work as well as incognito tab.

more options

Hi

Can you use this app?:

https://octoart.vercel.app/

more options

Paul said

Hi Can you use this app?: https://octoart.vercel.app/

Sadly no, it's the same result. You can see the result on the attached screenshot.

more options

Additional info:

  1. I clicked "Advanced..." button and it showed me some certification error. Please take a look at the screenshot given.
  2. I tried to disable HSTS by accessing about:config and setting network.stricttransportsecurity.preloadlist to false. Then, I access several .vercel.app sites with incognito mode and I found out that all .vercel.app is being blocked by internetpositif.id for some reason.

I don't understand why it's being disabled only on Mozilla Firefox. What I understand is, if it's actually being blocked by Indonesia government then I shouldn't be able to access .vercel.app sites through all browsers.

Upravil(a) Muhammad Fikri Syahid dňa

more options

That site opens fine for me.

If access is being restricted by a government body, there is not much we can do to assist.

more options

Try to set this pref:

  • about:config => security.enterprise_roots.enabled = true
more options

Paul said

That site opens fine for me. If access is being restricted by a government body, there is not much we can do to assist.

I see, thank you for your help

more options

cor-el said

Try to set this pref:
  • about:config => security.enterprise_roots.enabled = true

I tried setting it to true and access the sites through incognito mode. Still the same result though.

more options

Vybrané riešenie

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

cor-el said

You can check the connection settings.
  • Settings -> General -> Network: Connection -> Settings
If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings":

Hello, thanks for replying

Setting the proxy to "No Proxy" doesn't seem to fix the issue.

But I managed to fix it by setting the DNS manually using cloudflare.

Thank you for your help